cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
ashish
New Contributor

How to connect Adtran 1335 switch to Netgear (model: gs748tps) switch so that we can connect my phones to Adtran switch 1335 also.

Jump to solution

Hi,

I need your help. Currently I have Netgear L2 switch (model: gs748tps) and configured two vlan in this switch. One for data (i.e. Laptop, desktop and server) and second for Voice (Polycom IP Phone) . so both the network data and voice working fine. 

Network and VLAN details information are given below.

Network information: Data device we can use 10.1.255.xyz/24 IP range and Voice Device we can use 10.2.200.xyz/24 IP range.

DHCP Server: we are using two DHCP server  for data and voice and configured on different servers.

VLAN :  we have configured two VLAN. Default vlan (VLAN ID : 1) and  Voice VLAN (VLAN ID 2).  Now we have set all port except data and voice dhcp server , all port of default  Untagged member of Default vlan and Tagged member of Voice vlan. DHCP server of voice network port is member of only for  voice vlan and set PVID  2. DHCP server of Data network port is member  of only for data vlan and set the PVID 1.

With the help of above configuration. We can do the following.

  1. If I have connected phone to any port of Netgear switch , Phone will take the IP  address from  Phone DHCP server (ex: 10.1.200.xyx/24) and phone will work. And if I have connected the laptop to same port Laptop taking the IP address from data DHCP server (ex: 10.1.255.xyx/24)

My Actual requirement is.

Recently we have purchased new Adtran switch 1335 and connected to Netgear switch. If I have connected the data device (Laptop) to Adtran Netvanta switch 1335 is taking the IP address from data DHCP server and it is working fine and communicates with Data devices. But if I have connected phone to Netvanta 1335 switch , phone device not taking the IP address from Voice DHCP server and It will not work.

How to connect Adtran 1335 switch to Netgear (model: gs748tps) switch so that we can connect my phones to Adtran switch 1335 also.

Ashish

Tags (3)
0 Kudos
1 Solution

Accepted Solutions
vmaxdawg05
Contributor III
Contributor III

Re: How to connect Adtran 1335 switch to Netgear (model: gs748tps) switch so that we can connect my phones to Adtran switch 1335 also.

Jump to solution

There is nothing in this configuration that indicates that you are using VLAN 2 or trunking any of your ports.

I only know that at minimum, you would need to define VLAN 2 in our configuration, and you would need to connect a switchport that is in TRUNK mode to the Netgear.  The Netgear would ideally have PVID = 1, and would be configured for VLAN 2 TAGGED.

Example for 1335:

!

vlan 2

  name Voice

!

.

.

.

.

!

interface switchport 0/38

switchport mode trunk

no shutdown

!

Assuming that something else connected to the Netgear is responsible for routing and DHCP, it should work.

As for switchport 0/22 for the IP phone, you should be able to configure the following:

!

interface switchport 0/22

switchport voice vlan 2

no shutdown

!

This should work for you.  The unknowns that I see here is where DHCP is coming from, or are you using static IP addresses for your IP phones?

View solution in original post

0 Kudos
7 Replies
Anonymous
Not applicable

Re: How to connect Adtran 1335 switch to Netgear (model: gs748tps) switch so that we can connect my phones to Adtran switch 1335 also.

Jump to solution

- Thanks for posting your question on the forum!

Could you post your 1335 configuration to this thread so we can verify the settings? Please remember to remove any sensitive information. Also, please let us know which port is the uplink to the Netgear and which port you are using to test with.

By default, all switchports are access ports for VLAN 1 on the 1335. If you plan on plugging just a phone into that switchport (with no PC plugged into the phone's data port) then you will want to assign that switchport to be an access port for the voice vlan. Also, you will want to make sure that the uplink between the 1335 and Netgear is set up as a trunk so that all VLANs are allowed to go between both switches.

Please do not hesitate to let us know if you have any questions.

Thanks,

Noor

ashish
New Contributor

Re: How to connect Adtran 1335 switch to Netgear (model: gs748tps) switch so that we can connect my phones to Adtran switch 1335 also.

Jump to solution

Hi Noor,

I have test some below configuration but I have not get the success.

I have used Port 38 as a uplink port of netgear switch. This port is Untagged and member of data VLAN (Data VLAN  ID:1) and also the member of Voice VLAN (VLAN ID: 2)and set as a Tagged. This port 38 connected to Adtran 1335 switch port 21. Adtran 1335 port set as a trunk port. Then I have set another port 22 of Adtran 1335 switch set as a trunk port and connected my IP Phone to port 22 of Netvanta 1335 switch. But IP Phone not getting the IP address (10.1.200.xyx/24). but on same port if I connect Laptop, Laptop getting the data network IP address (10.1.255.xyx/24).

Port 38 of Netgear switch PVID set 1.

Note: Just for your information in polycom IP phone setup we have set VLAN ID 2 manually.

Adtran 1335 current configuration are given below.

!

!

! ADTRAN, Inc. OS version R10.8.0.E

! Boot ROM version 15.01.B1

! Platform: NetVanta 1335 PoE, part number 1700525E2

! Serial number LBADTN1304AG087

!

!

hostname "Switch"

enable password password

!

clock timezone -11

clock no-auto-correct-DST

!

ip subnet-zero

ip classless

ip default-gateway 10.1.255.1

no ip routing

!

!

!

!

no ip route-cache express

!

no auto-config

!

event-history on

no logging forwarding

no logging email

!

no service password-encryption

!

username "admin" password "password"

!

banner motd #

                 ****** Important ******

Enable and Telnet passwords are configured to "password".

Please change them immediately.

The vlan 1 interface is enabled with an address of 10.10.10.1

Telnet access is also enabled.

#

!

!

no ip firewall alg msn

no ip firewall alg mszone

no ip firewall alg h323

!

!

!

!

!

!

!

!

dot11ap access-point-control

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

vlan 1

  name "Default"

!

!

interface switchport 0/1

  no shutdown

!

interface switchport 0/2

  no shutdown

!

interface switchport 0/3

  no shutdown

!

interface switchport 0/4

  no shutdown

!

interface switchport 0/5

  no shutdown

!

interface switchport 0/6

  no shutdown

!

interface switchport 0/7

  no shutdown

!

interface switchport 0/8

  no shutdown

!

interface switchport 0/9

  no shutdown

!

interface switchport 0/10

  no shutdown

!

interface switchport 0/11

  no shutdown

!

interface switchport 0/12

  no shutdown

!

interface switchport 0/13

  no shutdown

!

interface switchport 0/14

  no shutdown

!

interface switchport 0/15

  no shutdown

!

interface switchport 0/16

  no shutdown

!

interface switchport 0/17

  no shutdown

!

interface switchport 0/18

  no shutdown

!

interface switchport 0/19

  no shutdown

!

interface switchport 0/20

  no shutdown

!

interface switchport 0/21

  no shutdown

!

interface switchport 0/22

  no shutdown

!

interface switchport 0/23

  no shutdown

!

interface switchport 0/24

  no shutdown

!

!

interface gigabit-switchport 0/1

  no shutdown

!

interface gigabit-switchport 0/2

  no shutdown

!

!

!

interface vlan 1

  ip address  10.1.255.253  255.255.255.0

  no ip route-cache express

  no shutdown

!

!

interface dot11ap 1 ap-type nv16x

  access-point mac-address 00:19:92:11:DA:A0

  name GRI-AP160-001

  location GRIOffice

!

!

interface dot11ap 1/1 radio-type 802.11bg

  no shutdown

!

!

interface dot11ap 1/1.1

  description Wiz_802.11BG_VAP

  ssid broadcast-mode "AdtranAP-01"

  security mode wpa aes-ccmp psk peppermint1!

  no shutdown

!

!

interface dot11ap 1/2 radio-type 802.11a

  no shutdown

!

!

interface dot11ap 1/2.1

  description Wiz_802.11A_VAP

  ssid broadcast-mode "AdtranAP-01"

  security mode wpa aes-ccmp psk peppermint1!

  no shutdown

!

!

interface dot11ap 2 ap-type nv16x

  access-point mac-address 00:19:92:11:DF:E0

  name GRI-AP160-002

  location GRIOffice

!

!

interface dot11ap 2/1 radio-type 802.11bg

  no shutdown

!

!

interface dot11ap 2/1.1

  description Wiz_802.11BG_VAP

  ssid broadcast-mode "AdtranAP-02"

  security mode wpa aes-ccmp psk peppermint1!

  no shutdown

!

!

interface dot11ap 2/2 radio-type 802.11a

  no shutdown

!

!

interface dot11ap 2/2.1

  description Wiz_802.11A_VAP

  ssid broadcast-mode "AdtranAP-01"

  security mode wpa aes-ccmp psk peppermint1!

  no shutdown

!

!

!

!

!

!

!

!

!

no tftp server

no tftp server overwrite

http server

no http secure-server

no snmp agent

no ip ftp server

ip ftp server default-filesystem flash

no ip scp server

no ip sntp server

!

!

!

!

!

!

!

!

!

!

sip udp 5060

sip tcp 5060

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

line con 0

  no login

!

line telnet 0 4

  login

  password password

  no shutdown

line ssh 0 4

  login local-userlist

  no shutdown

!

!

!

!

!

!

!

end

Let me know if I missout any configuration from my end.

Thanks

Ashish

vmaxdawg05
Contributor III
Contributor III

Re: How to connect Adtran 1335 switch to Netgear (model: gs748tps) switch so that we can connect my phones to Adtran switch 1335 also.

Jump to solution

There is nothing in this configuration that indicates that you are using VLAN 2 or trunking any of your ports.

I only know that at minimum, you would need to define VLAN 2 in our configuration, and you would need to connect a switchport that is in TRUNK mode to the Netgear.  The Netgear would ideally have PVID = 1, and would be configured for VLAN 2 TAGGED.

Example for 1335:

!

vlan 2

  name Voice

!

.

.

.

.

!

interface switchport 0/38

switchport mode trunk

no shutdown

!

Assuming that something else connected to the Netgear is responsible for routing and DHCP, it should work.

As for switchport 0/22 for the IP phone, you should be able to configure the following:

!

interface switchport 0/22

switchport voice vlan 2

no shutdown

!

This should work for you.  The unknowns that I see here is where DHCP is coming from, or are you using static IP addresses for your IP phones?

View solution in original post

0 Kudos
ashish
New Contributor

Re: How to connect Adtran 1335 switch to Netgear (model: gs748tps) switch so that we can connect my phones to Adtran switch 1335 also.

Jump to solution

Hi

Thanks for this information, As per my understanding, I need to create Voice VLAN in Netvanta 1335 and set any port as a trunk port. This trunk port connect (Uplink) to netgear switch port 38 and also another port of Netvanta 1335 switch set as a trunk and connect my IP phone to this trunk port Right?  Please confirm the same so that I can try here and test it.

DHCP server connected to netgear switch and that port is a member of voice VLAN only and set PVID is 2. my all IP phones are taking the IP address from DHCP server.

Thanks

Ashish

vmaxdawg05
Contributor III
Contributor III

Re: How to connect Adtran 1335 switch to Netgear (model: gs748tps) switch so that we can connect my phones to Adtran switch 1335 also.

Jump to solution

That is correct.

vmaxdawg05
Contributor III
Contributor III

Re: How to connect Adtran 1335 switch to Netgear (model: gs748tps) switch so that we can connect my phones to Adtran switch 1335 also.

Jump to solution

Yes. If you want to leave the ports for the IP phone in access mode on VLAN 1, you can still achieve VLAN 2 for the IP phone by adding (“switchport voice vlan 2”) in the port configuration. That effectively puts the port in limited trunk mode (only carrying the native vlan 1 and voice vlan 2).

If the IP phones support LLDP-MED, they will automatically be put on VLAN 2.

ashish
New Contributor

Re: How to connect Adtran 1335 switch to Netgear (model: gs748tps) switch so that we can connect my phones to Adtran switch 1335 also.

Jump to solution

Hi,

As per your instruction, I have done all configuration.  My Phone is working on 1335 switch.

Thanks a Lot.