cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
petermckennaedc
New Contributor

Voice Vlan conf

I am trying to set up lldp and voice vlan on a 1560 poe switch. 

NJFCU-Totowa-156024P-DHCP# conf t
NJFCU-Totowa-156024P-DHCP(config)# int gi 1/5
NJFCU-Totowa-156024P-DHCP(config-if)# switchport voice vlan 172
^
% Invalid word detected at '^' marker.

NJFCU-Totowa-156024P-DHCP(config-if)# switchport voice vlan ?
discovery-protocol Set Voice VLAN port discovery protocol
mode Set Voice VLAN port mode
security Enable Voice VLAN port security mode

 

it does not take the voice vlan <vlan id> command

What are the equivalent settings in the new firmware

Active Image
------------
Version : v4.4-42
Date : 2020-09-29T10:51:17+08:00
Upload filename : NV1560-24_v4.4-42.mfi

 

0 Kudos
3 Replies
childebrecht
New Contributor

Re: Voice Vlan conf

Good afternoon,  Was curious if you ever got this working.  I am coming across same issue with the 1560's.   I have a config built but it ignoring my voice vlans and just passing the native vlan 1.

olywrestle
New Contributor III

Re: Voice Vlan conf

There are many ways to configure voice vlans in the 1560. I have used these as guides to help find the config that works best depedning on provider/phone.

!
vlan 1
!
vlan 100
 name Data
!
vlan 300
 name VOICE
!
!
lldp med media-vlan-policy 0 voice tagged 300 l2-priority 0 dscp 46
lldp med media-vlan-policy 1 voice-signaling tagged 300 l2-priority 0 dscp 38
!
voice vlan
voice vlan id 300
voice vlan oui 00-04-F2 description Polycom phones
voice vlan oui 80-5E-C0 description Yealink phones
!

Polycom
Trunk port config Polycom: 
!
interface GigabitEthernet 1/1
 switchport voice vlan mode auto
 switchport voice vlan discovery-protocol both
 switchport trunk native vlan 100
 switchport trunk allowed vlan 100,300
 switchport mode trunk 
 no lldp med transmit-tlv location
 lldp med media-vlan policy-list 0,1
 spanning-tree edge
!

Hybrid port config Polycom:
Hybrid ports resemble trunk ports in many ways but adds additional port configuration features. 
In addition to the characteristics described for trunk ports, hybrid ports have these abilities:
Can be configured to be VLAN tag unaware, C-tag aware, S-tag aware, or S-custom-tag aware.

!
interface GigabitEthernet 1/1
 switchport voice vlan mode auto
 switchport voice vlan discovery-protocol both
 switchport access vlan 300
 switchport hybrid native vlan 100
 switchport hybrid allowed vlan 100,300
 switchport trunk vlan tag native
 switchport mode hybrid
 no lldp med transmit-tlv location
 lldp med media-vlan policy-list 0,1
 spanning-tree edge
!

Yealink
Trunk port config Yealink:
!
interface GigabitEthernet 1/1
 switchport voice vlan mode auto
 switchport voice vlan discovery-protocol both
 switchport trunk native vlan 100
 switchport trunk allowed vlan 100,300
 switchport mode trunk 
 no lldp med transmit-tlv location
 lldp med media-vlan policy-list 0,1
 spanning-tree edge
!

Hybrid port config Yealink:
Hybrid ports resemble trunk ports in many ways but adds additional port configuration features. 
In addition to the characteristics described for trunk ports, hybrid ports have these abilities:
Can be configured to be VLAN tag unaware, C-tag aware, S-tag aware, or S-custom-tag aware.

!
interface GigabitEthernet 1/1
 switchport voice vlan mode auto
 switchport voice vlan discovery-protocol both
 switchport access vlan 300
 switchport hybrid native vlan 100
 switchport hybrid allowed vlan 100,300
 switchport trunk vlan tag native
 switchport mode hybrid
 no lldp med transmit-tlv location
 lldp med media-vlan policy-list 0,1
 spanning-tree edge
!
huckleberry1
New Contributor

Re: Voice Vlan conf

Thank you olywrestle!  I as well struggled with the voice vlan config changes from AOS to ASE.  I thought I had it but must have been a tick off as I am now in working business with IP phones and PCs working off the same physical port but on different vlans.  I was following the "configuring layer 2 services" document but I could never get the system to trigger the voice vlan.  I messed with it for hours and hours.....ugh.  Much better now!

Peter