Link Agg does work between the 2 switches, but the 1560 uses an active component that the 1550 never had. So you have to use the less intelligent version of LACP (STATIC) in order for it to be compatible with the 1550 and other AOS based switches. I have this functioning in my lab with the below config.
1560 Config:
!
!
interface llag 1
!
interface GigabitEthernet 1/23
switchport trunk allowed vlan 1,99,300
switchport mode trunk
speed auto 10 100 1000
description Rdnt Link to 1550 1/43
aggregation group 1 mode on
!
interface GigabitEthernet 1/24
switchport trunk allowed vlan 1,99,300
switchport mode trunk
speed auto 10 100 1000
description Rdnt Link to 1550 1/44
aggregation group 1 mode on
!
1550 Config
!
!
interface port-channel 2
description 1560 LAG Link
no shutdown
switchport mode trunk
switchport gvrp
!
!
interface gigabit-switchport 0/43
description 1560 LAG Link 1
no shutdown
channel-group 2 mode on
!
interface gigabit-switchport 0/44
description 1560 LAG Link 2
no shutdown
channel-group 2 mode on
!