Showing results for 
Show  only  | Search instead for 
Did you mean: 
New Contributor

Error uploading firmware on 3140.

When trying to upload the latest firmware I get an error saying the filename is to long.

I have shortened the name, changed the folder it was in, re downloaded the firmware, tried older firmware, setting the 3140 back to factory default.

Gives the same error when trying to upload a config as well.

Tags (2)
0 Kudos
3 Replies
Honored Contributor
Honored Contributor

Re: Error uploading firmware on 3140.

The filename is too long, or the file is too long as in not enough room on the flash? I've not heard of a filename too long error.

When you type "show flash" from enabled mode, is the "bytes available" smaller than the file size of the new firmware? If so you'll need to delete some files, either older no-longer-used configurations, exception reports, or other files cluttering the flash.

If it's really "filename too long" you may have to open a support ticket. It's should not be necessary nor is it usually a good idea to rename firmware files.

New Contributor II

Re: Error uploading firmware on 3140.

Try using a different browser If you are using the GUI. I've had the same issue, that seems to fix the problem. I have 3 browsers on my laptop and sometimes I have to repeat the process with all 3 until one works. It seems like Firefox was the one that works best, if not try others.

New Contributor

Re: Error uploading firmware on 3140.

...I'll second using another browser.  Changed from Edge to Firefox and it worked 100%