cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
jgard
New Contributor

QoS through ACL? ShoreTel Voice

Jump to solution

Hello All,

I've successfully applied QoS on my Adtran, and it's marking the packets correctly. However, i'm still seeing some voice quality issues at the remote locations. Below is what I have applied, but came across someones post suggesting I create an ACL and doing the following:

access-list 105 remark : ShoreTel VoIP Call Control and CSIS

access-list 105 permit udp any any range 5440 5448

access-list 105 permit udp any any eq 2427

access-list 105 permit udp any any eq 2727

access-list 105 permit tcp any any eq sunrpc

access-list 105 permit udp any any eq sunrpc

access-list 105 permit tcp any any eq 5440


I'm not really familiar with creating and marking through ACL's. Could someone please help me out?


My Current Configuration

ip dhcp-server pool "Admin"

  network 10.7.51.0 255.255.255.0

  domain-name "test.lan"

  dns-server 10.7.62.3 10.7.62.4

  netbios-node-type h-node

  default-router 10.7.51.1

  tftp-server 10.7.62.15

  ntp-server 10.7.57.249

  timezone-offset -8

  option 156 ascii ftpservers=10.8.59.205, country=1, language=1

  option 161 ip 10.7.62.15

!

!

!

qos map VOICE 20

  match dscp 46

  priority 1000

!

!

!

interface eth 0/1

  encapsulation 802.1q

  no shutdown

!

interface eth 0/1.1

  vlan-id 1 native

  no shutdown

  ip address  10.7.51.1  255.255.255.0

!

interface eth 0/2

  ip address dhcp hostname "Router"

  shutdown

!

!

!

!

interface t1 1/1

  description GAN_MPLS

  tdm-group 1 timeslots 1-24 speed 64

  no shutdown

!

interface t1 1/2

  clock source through

  tdm-group 1 timeslots 1-24 speed 64

  no shutdown

!

interface ppp 1

  description GAN/QWEST Bonded MPLS

  ip address  121.31.54.123  255.255.255.252

  ppp multilink interleave

  ppp multilink fragmentation

  ppp multilink

  qos-policy out VOICE

  no shutdown

  cross-connect 1 t1 1/1 1 ppp 1

  cross-connect 2 t1 1/2 1 ppp 1

!

!

!

!

!

!

!

!

ip route 0.0.0.0 0.0.0.0 121.31.54.123

Tags (3)
0 Kudos
1 Solution

Accepted Solutions
Anonymous
Not applicable

Re: QoS through ACL? ShoreTel Voice

Jump to solution

- Thanks for posting your question on the forum!

With the configuration you provided, QoS is currently setup to match traffic marked with a DSCP value of 46. This is the DSCP value most voice packets from IP phones are marked with. This traffic would then be given priority of 1 Mbps should the link become congested.

I would be more than happy to help you configure the ACL in your QoS map, however, I am a little unclear if you would like to mark the traffic in your ACL with a certain DSCP or precedence value or if you would just like to prioritize this traffic?

Please do not hesitate to let us know if you have any questions.

Thanks,

Noor

View solution in original post

0 Kudos
4 Replies
Anonymous
Not applicable

Re: QoS through ACL? ShoreTel Voice

Jump to solution

- Thanks for posting your question on the forum!

With the configuration you provided, QoS is currently setup to match traffic marked with a DSCP value of 46. This is the DSCP value most voice packets from IP phones are marked with. This traffic would then be given priority of 1 Mbps should the link become congested.

I would be more than happy to help you configure the ACL in your QoS map, however, I am a little unclear if you would like to mark the traffic in your ACL with a certain DSCP or precedence value or if you would just like to prioritize this traffic?

Please do not hesitate to let us know if you have any questions.

Thanks,

Noor

0 Kudos
Anonymous
Not applicable

Re: QoS through ACL? ShoreTel Voice

Jump to solution

- Do you have any further questions or are still in need of assistance regarding this subject?

Thanks,

Noor

Anonymous
Not applicable

Re: QoS through ACL? ShoreTel Voice

Jump to solution

Depending on what version ShoreTel you are using may change your QOS needs.

You can set RTP DSCP for shore Gears and phones only on pre 13.x code.  What that means, only set to
set or Shore gear RTP is prioritized no signaling and no Call server RTP.

13.x and later you can set the call server RTP and signaling
DSCP.

If you run “sho qos map int ppp 1”  do you see matches?

I sometimes do this to set dscp on input interface:

qos map remark 10

match ip list 105

set precedence 46

interface eth 0/1.1

vlan-id 1 native

no shutdown

ip address 10.7.51.1 255.255.255.0

qos-policy in remark

jgard
New Contributor

Re: QoS through ACL? ShoreTel Voice

Jump to solution

My QoS is matching the packets, and have tracked some internal issues that was causing the jitter for our voice traffic. Thanks for the response, I will keep this in mind.