cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
New Contributor

adtran 3430 setup subinterface and 802.1q will not connect to dell 5448 port 1 (trunk)

Jump to solution

Here is the configuration:

!

! ADTRAN, Inc. OS version 18.02.02.00.E

! Boot ROM version 17.06.01.00

! Platform: NetVanta 3430, part number

!

interface eth 0/1

  description VOIP & DATA

  encapsulation 802.1q

  no shutdown

!

interface eth 0/1.1

  vlan-id 1

  ip address  192.168.4.1  255.255.255.0

  no shutdown

interface eth 0/1.2

  vlan-id 10

  ip address  192.168.5.1  255.255.255.0

  no shutdown

!

interface eth 0/2

  description QMOE_WAN

  speed 100tru

  ip address  10.0.1.2  255.255.255.0

  traffic-shape rate 10000000

  qos-policy out VOIP

  no shutdown

!

!

*************************************************************************

With this configuration, the router will not communication with my Dell 5448 switch.  But once we remove all the 802.1q configuration and set interface eth0/1 with an ip address, it will work.  Any one can help?

Labels (1)
Tags (4)
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Anonymous
Not applicable

Re: adtran 3430 setup subinterface and 802.1q will not connect to dell 5448 port 1 (trunk)

Jump to solution

:

Thank you for asking this question in the support community.  If the physical connection comes up, then based on the information you provided, it appears you will need to add the keyword native to VLAN 1.  I believe this is the case because when you do not configure the ADTRAN's port for trunking, the connection works, which leads me to believe there are no VLAN tags (native) on the link.  Therefore, I recommend adding the command vlan-id 1 native.

The configuration would look similar to the following:

interface eth 0/1

  description VOIP & DATA

  encapsulation 802.1q

  no shutdown

!

interface eth 0/1.1

  vlan-id 1 native

  ip address  192.168.4.1  255.255.255.0

  no shutdown

interface eth 0/1.2

  vlan-id 10

  ip address  192.168.5.1  255.255.255.0

  no shutdown

I hope that makes sense, but please do not hesitate to reply to this post with any additional questions or information.  I will be happy to assist in any way I can.

Levi

View solution in original post

0 Kudos
5 Replies
Highlighted
New Contributor

Re: adtran 3430 setup subinterface and 802.1q will not connect to dell 5448 port 1 (trunk)

Jump to solution

Additional info, it connects to Port 1 on my Dell 5448 switch, and port 1 is setup as Trunk, allow all VLAN.

Highlighted
Anonymous
Not applicable

Re: adtran 3430 setup subinterface and 802.1q will not connect to dell 5448 port 1 (trunk)

Jump to solution

:

Thank you for asking this question in the support community.  If the physical connection comes up, then based on the information you provided, it appears you will need to add the keyword native to VLAN 1.  I believe this is the case because when you do not configure the ADTRAN's port for trunking, the connection works, which leads me to believe there are no VLAN tags (native) on the link.  Therefore, I recommend adding the command vlan-id 1 native.

The configuration would look similar to the following:

interface eth 0/1

  description VOIP & DATA

  encapsulation 802.1q

  no shutdown

!

interface eth 0/1.1

  vlan-id 1 native

  ip address  192.168.4.1  255.255.255.0

  no shutdown

interface eth 0/1.2

  vlan-id 10

  ip address  192.168.5.1  255.255.255.0

  no shutdown

I hope that makes sense, but please do not hesitate to reply to this post with any additional questions or information.  I will be happy to assist in any way I can.

Levi

View solution in original post

0 Kudos
Highlighted
Anonymous
Not applicable

Re: adtran 3430 setup subinterface and 802.1q will not connect to dell 5448 port 1 (trunk)

Jump to solution

:

I went ahead and flagged this post as “Assumed Answered.”  If any of the responses on this thread assisted you, please mark them as either Correct or Helpful answers with the applicable buttons.  This will make them visible and help other members of the community find solutions more easily.  If you still need assistance, I would be more than happy to continue working with you on this - just let me know in a reply.

Levi

Highlighted
New Contributor

Re: adtran 3430 setup subinterface and 802.1q will not connect to dell 5448 port 1 (trunk)

Jump to solution

Levi:

Native solved the problem.  Appears Dell default VLAN 1 is untagged, by adding Native to the VLAN 1 on the Adtran router.  It worked.  Thank you!

Highlighted
Anonymous
Not applicable

Re: adtran 3430 setup subinterface and 802.1q will not connect to dell 5448 port 1 (trunk)

Jump to solution

I went ahead and flagged the "Correct Answer" on this post to make it more visible and help other members of the community find solutions more easily. If you don't feel like the answer I marked was correct, feel free to come back to this post and unmark it and select another in its place with the applicable buttons.  If you still need assistance, we would be more than happy to continue working with you on this - just let us know in a reply.

Thanks,

Noor