cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Contributor III
Contributor III

Cannot get remote phones to work. I've tested remotely via Wan and it does not work

Jump to solution

Hi,

I have a Polycom VX400 phone that I'm trying to make it work remotely.  At my remote site, I have a cheap Linksys router that does not support any options, so I had to manually enter in the ftp server address on the phone.  I had to use the wan ip address on the phone so it will connect.  However looks like the adtran is giving me back the internal FTP address of the server.  Does anyone know how to change this just for the remote phones?  See ip ftp debug below.

Here is another weird thing, I try to connect ftp from another computer ftp://public ip address
It then prompt me for password.
An error occurred opening that folder on the FTP Server.  Make sure you have permission to access that folder.

I even tried forwarding port 21 to the private ip address of the adtran.
What other ports do I needed to forward?

Here is the error I'm getting from windows - FTP Folder Error - An error occurred opening that folder on the FTP Server.  Make sure you have permission to access that folder.  Details:  The operation timed out.
This worked fine locally, just not remotely.

AULT-.

2013.09.16 00:37:41 IP.FTP_SERVER (PWD) '/' is current directory.

2013.09.16 00:37:42 IP.FTP_SERVER (CWD) Directory changed to 'Polycom'.

2013.09.16 00:37:42 IP.FTP_SERVER (PASV) Entering Passive Mode (192,168,152,253,                                                                                                                                                             20,181) on VRF: -DEFAULT-.

2013.09.16 00:37:42 IP.FTP_SERVER (TYPE) Type is set to I.

2013.09.16 00:37:42 IP.FTP_SERVER (SIZE) Cannot read 'sip.ld'.

2013.09.16 00:37:42 IP.FTP_SERVER (RETR) Cannot read 'sip.ld' on VRF: -DEFAULT-

2013.09.16 00:37:42 IP.FTP_SERVER (PASV) Entering Passive Mode (192,168,152,253,                                                                                                                                                             19,239) on VRF: -DEFAULT-.

2013.09.16 00:37:42 IP.FTP_SERVER (SIZE) Command successful '131.cfg'  325 bytes                                                                                                                                                             .

2013.09.16 00:37:42 IP.FTP_SERVER BINARY data connection for '131.cfg' on VRF: -                                                                                                                                                             DEFAULT-.

2013.09.16 00:37:42 IP.FTP_SERVER (USER) Password required for 'polycomftp'.

2013.09.16 00:37:42 IP.FTP_SERVER (RETR) 'BINARY' transfer complete on VRF: -DEF                                                                                                                                                             AULT-.

2013.09.16 00:37:42 IP.FTP_SERVER (USER) User 'polycomftp' logged in.

2013.09.16 00:37:42 IP.FTP_SERVER (PWD) '/' is current directory.

2013.09.16 00:37:42 IP.FTP_SERVER (CWD) Directory changed to 'Polycom'.

2013.09.16 00:37:42 IP.FTP_SERVER (PASV) Entering Passive Mode (192,168,152,253,                                                                                                                                                             20,81) on VRF: -DEFAULT-.u

2013.09.16 00:37:42 IP.FTP_SERVER (TYPE) Type is set to I.

2013.09.16 00:37:42 IP.FTP_SERVER (SIZE) Cannot read 'Sample-1.wav'.

2013.09.16 00:37:42 IP.FTP_SERVER (RETR) Cannot read 'Sample-1.wav' on VRF: -DEF                                                                                                                                                             AULT-

2013.09.16 00:37:42 IP.FTP_SERVER (PASV) Entering Passive Mode (192,168,152,253,                                                                                                                                                             19,240) on VRF: -DEFAULT-.

2013.09.16 00:37:42 IP.FTP_SERVER (SIZE) Command successful 'polycomboot.cfg'  8                                                                                                                                                             20 bytes.

2013.09.16 00:37:42 IP.FTP_SERVER BINARY data connection for 'polycomboot.cfg' o                                                                                                                                                             n VRF: -DEFAULT-. a

2013.09.16 00:37:43 IP.FTP_SERVER (USER) Password required for 'polycomftp'.

2013.09.16 00:37:43 IP.FTP_SERVER (RETR) 'BINARY' transfer complete on VRF: -DEF                                                                                                                                                             AULT-.

2013.09.16 00:37:43 IP.FTP_SERVER (USER) User 'polycomftp' logged in.

2013.09.16 00:37:43 IP.FTP_SERVER (PWD) '/' is current directory.l

2013.09.16 00:37:43 IP.FTP_SERVER (CWD) Directory changed to 'Polycom'.

2013.09.16 00:37:43 IP.FTP_SERVER (PASV) Entering Passive Mode (192,168,152,253,                                                                                                                                                             20,81) on VRF: -DEFAULT-.

2013.09.16 00:37:43 IP.FTP_SERVER (TYPE) Type is set to I.

2013.09.16 00:37:43 IP.FTP_SERVER (SIZE) Cannot read 'Sample-2.wav'.l

2013.09.16 00:37:43 IP.FTP_SERVER (RETR) Cannot read 'Sample-2.wav' on VRF: -DEF                                                                                                                                                             AULT-

2013.09.16 00:37:43 IP.FTP_SERVER (PASV) Entering Passive Mode (192,168,152,253,                                                                                                                                                             19,241) on VRF: -DEFAULT-.

2013.09.16 00:37:43 IP.FTP_SERVER (SIZE) Command successful 'customer-sip.cfg'                                                                                                                                                               125 bytes.

2013.09.16 00:37:43 IP.FTP_SERVER BINARY data connection for 'customer-sip.cfg'                                                                                                                                                              on VRF: -DEFAULT-.

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Anonymous
Not applicable

Re: Cannot get remote phones to work. I've tested remotely via Wan and it does not work

Jump to solution

It looks like the result of this issue was DHCP option 66 was not configured and needed to be added to the NetVanta 7100.  This option is detailed in our guide.

Thanks,

Matt

View solution in original post

0 Kudos
6 Replies
Highlighted
Contributor III
Contributor III

Re: Cannot get remote phones to work. I've tested remotely via Wan and it does not work

Jump to solution

I've remove the port forwarding manually and only keep the admin - ftp allow from the 7100.  Now it does the public ip address, yet it still doing this.  Any ideas?

2013.09.16 09:16:16 IP.FTP_SERVER (USER) Password required for 'admin'.

2013.09.16 09:16:16 IP.FTP_SERVER (USER) User 'admin' logged in.

2013.09.16 09:16:16 IP.FTP_SERVER (PWD) '/' is current directory.

2013.09.16 09:16:16 IP.FTP_SERVER (CWD) Directory changed to 'polycom'.

2013.09.16 09:16:16 IP.FTP_SERVER (PASV) Entering Passive Mode (24,xx,xx,xx,20,81) on VRF: -DEFAULT-.

2013.09.16 09:16:21 IP.FTP_SERVER (USER) Password required for 'admin'.

2013.09.16 09:16:21 IP.FTP_SERVER (USER) User 'admin' logged in.

2013.09.16 09:16:21 IP.FTP_SERVER (PWD) '/' is current directory.

2013.09.16 09:16:21 IP.FTP_SERVER (CWD) Directory changed to 'polycom'.

2013.09.16 09:16:21 IP.FTP_SERVER (PASV) Entering Passive Mode (24,xx,xx,xx,19,237) on VRF: -DEFAULT-.

2013.09.16 09:16:38 IP.FTP_SERVER (USER) Password required for 'admin'.

2013.09.16 09:16:38 IP.FTP_SERVER (USER) User 'admin' logged in.

2013.09.16 09:16:38 IP.FTP_SERVER (PWD) '/' is current directory.

2013.09.16 09:16:38 IP.FTP_SERVER (CWD) Directory changed to 'polycom'.

2013.09.16 09:16:38 IP.FTP_SERVER (PASV) Entering Passive Mode (24,xx,xx,xx,19,237) on VRF: -DEFAULT-.

Highlighted
Contributor III
Contributor III

Re: Cannot get remote phones to work. I've tested remotely via Wan and it does not work

Jump to solution

It looks like the FTP issue was that I have FTP alg turn off.  Tech support enable it, now it works.  How ever I still cannot get the phone to register.  Here is my debug.  Anyone help is appreciated.

2013.09.16 11:51:20 IP.FTP_SERVER (PWD) '/' is current directory.

2013.09.16 11:51:20 IP.FTP_SERVER (PASV) Entering Passive Mode (24,173,XX,XX,XX,XX) on VRF: -DEFAULT-.

2013.09.16 11:51:20 IP.FTP_SERVER (CWD) Directory changed to 'Polycom'.

2013.09.16 11:51:20 IP.FTP_SERVER (PASV) Entering Passive Mode (24,173,XX,XX,XX,XX) on VRF: -DEFAULT-.

2013.09.16 11:51:20 IP.FTP_SERVER (TYPE) Type is set to I.

2013.09.16 11:51:20 IP.FTP_SERVER (SIZE) Cannot read '000000000000-license.cfg'.

2013.09.16 11:51:20 IP.FTP_SERVER (RETR) Cannot read '000000000000-license.cfg' on VRF: -DEFAULT-

2013.09.16 11:51:20 IP.FTP_SERVER (USER) Password required for 'polycomftp'.

2013.09.16 11:51:20 IP.FTP_SERVER (USER) User 'polycomftp' logged in.

2013.09.16 11:51:21 IP.FTP_SERVER (PWD) '/' is current directory.

2013.09.16 11:51:21 IP.FTP_SERVER (CWD) Directory changed to 'Polycom'.

2013.09.16 11:51:21 IP.FTP_SERVER (PASV) Entering Passive Mode (24,173,XX,XX,20,181) on VRF: -DEFAULT-.

2013.09.16 11:51:23 IP.FTP_SERVER (TYPE) Type is set to I.

2013.09.16 11:51:23 IP.FTP_SERVER (SIZE) Cannot read 'Sample-4.wav'.

2013.09.16 11:51:23 IP.FTP_SERVER (RETR) Cannot read 'Sample-4.wav' on VRF: -DEFAULT-

2013.09.16 11:51:24 IP.FTP_SERVER (TYPE) Type is set to I.

2013.09.16 11:51:24 IP.FTP_SERVER (SIZE) Cannot read '0004f26af4c2-license.cfg'.

2013.09.16 11:51:24 IP.FTP_SERVER (RETR) Cannot read '0004f26af4c2-license.cfg' on VRF: -DEFAULT-

2013.09.16 11:51:24 IP.FTP_SERVER (USER) Password required for 'polycomftp'.

2013.09.16 11:51:24 IP.FTP_SERVER (USER) User 'polycomftp' logged in.

2013.09.16 11:51:24 IP.FTP_SERVER (PWD) '/' is current directory.

2013.09.16 11:51:25 IP.FTP_SERVER (CWD) Directory changed to 'Polycom'.

2013.09.16 11:51:25 IP.FTP_SERVER (PASV) Entering Passive Mode (24,173,XX,XX,20,81) on VRF: -DEFAULT-.

2013.09.16 11:51:25 IP.FTP_SERVER (TYPE) Type is set to I.

2013.09.16 11:51:25 IP.FTP_SERVER BINARY data connection for '0004f26af4c2-boot.log' on VRF: -DEFAULT-.

2013.09.16 11:51:25 IP.FTP_SERVER (STOR) BINARY transfer of '0004f26af4c2-boot.log' complete.

2013.09.16 11:51:26 IP.FTP_SERVER (USER) Password required for 'polycomftp'.

2013.09.16 11:51:26 IP.FTP_SERVER (USER) User 'polycomftp' logged in.

2013.09.16 11:51:26 IP.FTP_SERVER (PWD) '/' is current directory.

2013.09.16 11:51:26 IP.FTP_SERVER (CWD) Directory changed to 'Polycom'.

2013.09.16 11:51:26 IP.FTP_SERVER (PASV) Entering Passive Mode (24,173,XX,XX,20,81) on VRF: -DEFAULT-.

2013.09.16 11:51:26 IP.FTP_SERVER (TYPE) Type is set to I.

2013.09.16 11:51:26 IP.FTP_SERVER (SIZE) Command successful '0004f26af4c2-app.log'  182503 bytes.

2013.09.16 11:51:26 IP.FTP_SERVER BINARY data connection for '0004f26af4c2-app.log' on VRF: -DEFAULT-.

2013.09.16 11:51:27 IP.FTP_SERVER (APPE) BINARY transfer of '0004f26af4c2-app.log' complete.u all

Anonymous
Not applicable

Re: Cannot get remote phones to work. I've tested remotely via Wan and it does not work

Jump to solution

I saw you opened a support ticket for this.  I would recommend continuing to work the issue on the ticket.  Once you have reached a resolution please come back to this thread and post the solution so others can benefit from it.

Thanks,

Matt

Highlighted
Anonymous
Not applicable

Re: Cannot get remote phones to work. I've tested remotely via Wan and it does not work

Jump to solution

It looks like the result of this issue was DHCP option 66 was not configured and needed to be added to the NetVanta 7100.  This option is detailed in our guide.

Thanks,

Matt

View solution in original post

0 Kudos
Highlighted
Contributor III
Contributor III

Re: Cannot get remote phones to work. I've tested remotely via Wan and it does not work

Jump to solution

You are right.  I was treating this phone (Adtran VX400) as an Adtran phone which use option 157.  I needed to treat it as TFTP or polycom phone.

Highlighted
Contributor III
Contributor III

Re: Cannot get remote phones to work. I've tested remotely via Wan and it does not work

Jump to solution

Another thing that I had to do here was to enable FTP alg onthe router.  It was disable.