The purpose is to replicate a point-point connection between an NV6355 and NV7100 via the fiber, or more specifically to connect the systems without changing the current IP configurations.
The customer currently has a NV7100 that is connected to a 6355 via a point-point T1. The industrial park has installed fiber connections between buildings recently and has given them access. The connection works great and this could be an easy fix just setup the 6355 as a switch and omit the function of the router, firewall, etc. The customer would prefer to maintain each location independent of the other. Each location has its own DSL. The DSL connections are slow and there are devices on the 6355 that we need to maintain a separate IP from the 7100. Can the point to point connection be replicated with the fiber?
Steps taken so far.
The configuration for the 7100 and 6355 Ethernet ports, setup a VLAN 99 for the connection and removed the trunking from the ports. Configured a GRE tunnel between the locations.
The Ethernet port on the 7100 is Ethernet 0/10 and Ethernet 0/10 on the 6355. This configuration is setup the same on the 6355.
7100 interface Ethernet 0/10 (truncated information...)
"interface eth 0/10
speed auto
full-duplex
mac-address
no shutdown
switchport mode access
switchport access vlan 99
switchport trunk native vlan 99
switchport trunk allowed vlan none
no switchport voice vlan
switchport trunk fixed vlan 99"
interface vlan 99
description
ip address 2.2.1.1 255.255.255.248
no rtp quality-monitoring
no shutdown
interface tunnel 1
description tunnel to corporate
ip address 2.2.3.1 255.255.255.248
ip proxy-arp
ip ospf authentication-key
ip ospf authentication null
ip ospf message-digest-key 1 md5
ip ospf message-digest-key 2 md5
no ip ospf cost
ip ospf retransmit-interval 5
ip ospf transmit-delay 1
ip ospf priority 1
ip ospf hello-interval 10
ip ospf dead-interval 40
no ip ffe
no ip policy route-map
no ip mcast-stub helper-enable
ip igmp version 2
ip igmp last-member-query-interval 1000
ip igmp query-interval 60
ip igmp query-max-response-time 10
ip igmp querier-timeout 120
no ip igmp immediate-leave
ip route-cache
no ip pim
ip pim-sparse dr-priority 1
ip pim-sparse propagation-delay 500
ip pim-sparse override-interval 2500
ip pim-sparse nbr-timeout 105
ip pim-sparse hello-interval 30
ip split-horizon
no crypto map
no ip directed-broadcast
no dynamic-dns
no ip flow ingress
no ip flow egress
rtp quality-monitoring
tunnel mode gre
tunnel source vlan 99
tunnel destination 2.2.2.1
no tunnel checksum
no tunnel key
no tunnel sequence-datagrams
no keepalive
mtu 1476
bandwidth 100000
alias
no shutdown
If both locations have internet access and everything is working with that configuration and all your doing is just replacing a PPP T1 with a Fiber connection, then create a new VLAN with the ip address of the PPP connection and assign that VLAN to the Gigabit port of the fiber. Make sure you have the media-gateway command set to primary on that interface.
-Mark
I think you are making this more complicated than it ought to be.
Can you answer the following questions:
(1) Is the fiber between the two units point-to-point private? If private, there is no need for GRE.
(2) What are the networks on the 7100? I assume 10.10.10.0 for data and 10.10.20.0 for voice.
(3) What are the networks behind the 6355?
-Mark
Hi Mark - I thought about that after I left the site. The NV7100 has both default networks, and the NV6355 has 10.10.50.0 and 10.10.60.0.
Here is the solution that I came up with;
Allow only VLAN 2 trunking on the Ethernet port used to connect to the fiber. Remove the DHCP server on the NV6355, as the NV7100 will provide. Since both locations are connected via an Ethernet this is a simple solution. Change the DHCP server on the NV6355 VLAN 1 to set the options back to the VLAN 2 on the NV7100. Do I need to have an IP on the VLAN 2 on the 6355?
On the NV6355, the VLAN 1 does not need to be changed, since we are not using the same subnet, but also I will not be permitting VLAN 1 from the NV7100 over the trunk. The NV6355 will continue to have a separate default VLAN and separate Internet connection for now.
Please let me know if I have missed anything.
Correction; removing only the DHCP pool for VLAN 2 on the NV6355. Since VLAN 1 on the NV6355 will continue to operate as is.
There is a lot to take into consideration when networking a 7100 and a 6355 together. We actually have a class that goes over this:
Re: New ATSE/UCAS Certification Class Coming Soon
You have two options.
Option 1 - Configure 6355 using different networks
Option 2 - Just extend the 10.10.10.0 network and 10.10.20.0 network over the fiber.
Which one do you want to do? 1 is much more configuration, and 2 is very easy.
If you want OPtion 2, let me know.
If you choose Option 1, then the following applies.
I would see the config guide below on help on what you need to do. It is connecting the sites using Eth 0/0, but you would just change that to a VLAN like VLAN 100. I would create a different network to connect the sites together. If your 6355 site has PSTN connectivity, then there will be further configuration to take that to use. You will also need to configure your 6355 as SIP Transparent Proxy for failover when the 7100 is not reachable. the guide goes over that.
Regarding DHCP, it is best to configure DHCP on the 6355 for your two data networks. The guide goes over how to configure the DHCP pools.
Multi-Site config guide:
option 2 looks like the only option that would permit the use of the second Internet connection on the NV 6355.
The sites look like this;
NV7100 VLAN 1 - 10.10.10.0/24 ; VLAN 2 - 10.10.20.0/24; VLAN 99 - 172.22.22.0/29
NV6355 VLAN 1 - 10.10.50.0/24; VLAN 2 - 10.10.60.0/24; VLAN 99 - 172.22.22.0/29
All phones register back to the NV7100. A PRI is used for all of the voice, no analog.
The purpose is to replace the current T1 point-point with a fiber connection. The 7100 and 6355 have individual connections to the Internet. This is closer to a campus environment, where there might be multiple buildings and VLAN's. There is currently no data traffic going over the point-point. The only use has been for voice traffic from the 7100 to the 6355.
The guide mentioned above is connecting the 7100 to 6355 using SIP trunks. Our configuration does not use SIP trunks. The buildings are located across the street from each other.
I need only to change the routing of the packets destined for the NV6355. The easy part then is just replacing the ppp1 with VLAN 99 in routing.
If both locations have internet access and everything is working with that configuration and all your doing is just replacing a PPP T1 with a Fiber connection, then create a new VLAN with the ip address of the PPP connection and assign that VLAN to the Gigabit port of the fiber. Make sure you have the media-gateway command set to primary on that interface.
-Mark
Mark, that was the only configuration change that had to happen. Thank you for the help.