cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
New Contributor

VM to Email failure

Jump to solution

I know there are a number of posts on this subject but I cannot seem to find anything of benefit so I am throwing this out there.

Debug looks like:

SMTP Response: 220
mailpod.hostingplatform.com ESMTP

To SMTP server: EHLO
[192.168.22.3]

To SMTP server: 21 bytes of data

SMTP Not enough info to send.

SMTP Response:
250-mailpod.hostingplatform.com

SMTP Response: 250-STARTTLS

SMTP Response: 250-PIPELINING

SMTP Response: 250-8BITMIME

SMTP Response: 250-SIZE 65000000

SMTP Response: 250 AUTH LOGIN
PLAIN CRAM-MD5

To SMTP server: STARTTLS

To SMTP server: 10 bytes of data

SMTP Response: 220 ready for tls

To SMTP server: AUTH PLAIN

To SMTP server: 12 bytes of data

To SMTP server:
***************************************

To SMTP server: 62 bytes of data

SMTP Response: 235 ok, go ahead
(#2.0.0)

To SMTP server: AUTH CRAM-MD5

To SMTP server: 15 bytes of data

Invalid server response.

Thanks in advance for taking a look.

Eric B.

Message was edited by: txtechy Sub'd yahoo mail account info and still cannot send email notification.

Message was edited by: matt - removed hash

0 Kudos
Reply
1 Solution

Accepted Solutions
Highlighted
Anonymous
Not applicable

Re: VM to Email failure

Jump to solution

I just wanted to update this post to mention that AOS R10.9.2 was recently released, which included a fix for e-mail servers that use TLS.

View solution in original post

0 Kudos
Reply
8 Replies
Highlighted
Anonymous
Not applicable

Re: VM to Email failure

Jump to solution

Eric,

Can you submit your complete unfiltered configuration to our FTP server with the instructions below?  I would like to start by looking at it.


Open Internet Explorer web browser on their PC
Type the following URL:  ftp://ftp.adtran.com


Press the Alt key, click View, and then click Open FTP Site in Windows Explorer


Double-click the "Incoming" folder
Drag and drop files from PC into the Internet Explorer window


Reply to this post with the exact filenames used so we can retrieve the files



Thanks,

Matt

0 Kudos
Reply
Highlighted
New Contributor

Re: VM to Email failure

Jump to solution

Matt,  Sorry for the delay.  I copied the following to the FTP site:

config-7100-09-19-2013.cfg

putty_7100_09_19_2013

Eric

0 Kudos
Reply
Highlighted
Anonymous
Not applicable

Re: VM to Email failure

Jump to solution

Eric,

Thank you for providing the configuration.  Yahoo, Hotmail, and Gmail were all tested and confirmed working when this feature was introduced in R10.8.0.  TLS is not guaranteed to work with other mail providers using different authentication and encryption methods.  If you are seeing “Invalid server response” in the output of a debug system after STARTTLS is sent to the mail server, you may be communicating with a mail server that is incompatible with our current implementation.  If that is the case, here are some potential workarounds:

  • Create a new a mail account for the business from a compatible email provider like mybusiness@gmail.com and use that email address to send out all email notifications.
  • Use an SMTP relay, like the one explained in this guide: https://supportforums.adtran.com/docs/DOC-4819
  • Try connecting to the mail server on a different port that does not advertise TLS.
  • Have the mail server administrator disable TLS.
  • Downgrade to R10.7.0.

Hopefully one of these will work for your situation.

Thanks,

Matt

0 Kudos
Reply
Highlighted
Anonymous
Not applicable

Re: VM to Email failure

Jump to solution

I just wanted to update this post to mention that AOS R10.9.2 was recently released, which included a fix for e-mail servers that use TLS.

View solution in original post

0 Kudos
Reply
Highlighted
New Contributor III

Re: VM to Email failure

Jump to solution

Matt,

     Any ideas on this one? I have updated to 10.11 to alleviate any issues with TLS and still see am not able to make it work. I can login to the Exchange server with the account I have setup on the 7100 so the "invalid username/password" at the end doesn't seem accurate.

To SMTP server: 19 bytes of data

SMTP Response: 250-XXX.XXX.local Hello [172.30.6.2]

SMTP Response: 250-SIZE 36700160

SMTP Response: 250-PIPELINING

SMTP Response: 250-DSN

SMTP Response: 250-ENHANCEDSTATUSCODES

SMTP Response: 250-STARTTLS

SMTP Response: 250-AUTH LOGIN

SMTP Response: 250-8BITMIME

SMTP Response: 250-BINARYMIME

SMTP Response: 250 CHUNKING

To SMTP server: STARTTLS

To SMTP server: 10 bytes of data

SMTP Response: 220 2.0.0 SMTP server ready

To SMTP server: EHLO [172.30.6.2]

To SMTP server: 19 bytes of data

SMTP Response: 250-BC-MAIL.bc.local Hello [172.30.6.2]

SMTP Response: 250-SIZE 36700160

SMTP Response: 250-PIPELINING

SMTP Response: 250-DSN

SMTP Response: 250-ENHANCEDSTATUSCODES

SMTP Response: 250-AUTH LOGIN

SMTP Response: 250-8BITMIME

SMTP Response: 250-BINARYMIME

SMTP Response: 250 CHUNKING

To SMTP server: AUTH LOGIN

To SMTP server: 12 bytes of data

SMTP Response: 334 VXNlcm5hbWU6

To SMTP server: YmMubG9jYWxcYWR0cmFu

To SMTP server: 22 bytes of data

SMTP Response: 334 UGFzc3dvcmQ6

To SMTP server: YWR0cmFuODAwMA==

To SMTP server: 18 bytes of data

Invalid username/password.

0 Kudos
Reply
Highlighted
New Contributor III

Re: VM to Email failure

Jump to solution

Matt,

I figured it out with the help of our MS Engineer. The 7100>Utilities>>logging>Email Forwarding> "Email Sender" address has to be a valid full email address(adtran@yourdomain.com).Or else, you get the above message (Invalid username/password).

It would be nice if there was a document showing these minor nuances. Hopefully this will help someone else fighting this issue.

0 Kudos
Reply
Highlighted
Anonymous
Not applicable

Re: VM to Email failure

Jump to solution

Thanks for the update.  Here is a guide that covers some of the setup in the GUI: NetVanta 7000 Series Voicemail Quick Config Guide.  Also, here is a sample CLI configuration:

!

ip name-server <primary DNS server> <secondary DNS server>

logging email receiver-ip smtp.yahoo.com port 587 auth-username <yahoo-account>@yahoo.com auth-password <yahoo password>

logging email sender <yahoo-account>@yahoo.com

!

voice user <extension>

  email <e-mail address>

  voicemail notify email attach-message pcm

  voicemail notify schedule Sunday 12:00 am

    notify email primary

!

You would just need to substitute the Yahoo mail information for your specific mail server.

Thanks,

Matt

0 Kudos
Reply
Highlighted
New Contributor

Re: VM to Email failure

Jump to solution

I had the same problem, I disabled TLS on the Exchange server and it works now.

0 Kudos
Reply