cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
New Contributor II

Why would Adtran 7100 continuously report "INTERFACE_STATUS.giga-eth 0/1 changed state to testing"?

Jump to solution

Connected to HP switch of unknow model.
Current config:

interface gigabit-eth 0/1

  speed 100

  no shutdown

auto-speed gets the same result.

OS version A4.09.00.E

giga-eth 0/1 is IN TEST, line protocol is UP

  Hardware address is 00:A0:C8:79:9C:9F

  RJ-45 Shielded

  100Mb/s, full-duplex

giga-eth 0/1 is UP, line protocol is UP

  Hardware address is 00:A0:C8:79:9C:9F

  RJ-45 Shielded

  100Mb/s, full-duplex

Labels (1)
0 Kudos
Reply
1 Solution

Accepted Solutions
Highlighted
Anonymous
Not applicable

Re: Why would Adtran 7100 continuously report "INTERFACE_STATUS.giga-eth 0/1 changed state to testing"?

Jump to solution

ctheise,

Thanks for posting this.  The “IN TEST” port state occurs when the NetVanta receives a frame that has a source MAC address equal to the MAC address assigned to that Ethernet port.  A switch should never see it’s port MAC address as the source unless there is some kind of an Ethernet loopback in place or a device generated a frame with the unit’s MAC address by spoofing it.  The port MAC address is different than the system or VLAN MAC address.  Frames with a port MAC address will be sent with the following features:

LLDP  - turned off by issuing no lldp send-and-receive

BPDU - turned off by issuing spanning-tree bpdufilter enable on a switchport

GVRP - off by default

This physical loop that is being reported is different than a network topology loop that spanning-tree protocol would detect. You can observe this same behavior by making an Ethernet loop back plug and inserting it into a port on the unit.  If you are seeing this I would suggest investigating what is plugged into the unit and determining how or where a loopback is being created by it.

Thanks,

Matt

View solution in original post

0 Kudos
Reply
4 Replies
Highlighted
Anonymous
Not applicable

Re: Why would Adtran 7100 continuously report "INTERFACE_STATUS.giga-eth 0/1 changed state to testing"?

Jump to solution

ctheise,

Thanks for posting this.  The “IN TEST” port state occurs when the NetVanta receives a frame that has a source MAC address equal to the MAC address assigned to that Ethernet port.  A switch should never see it’s port MAC address as the source unless there is some kind of an Ethernet loopback in place or a device generated a frame with the unit’s MAC address by spoofing it.  The port MAC address is different than the system or VLAN MAC address.  Frames with a port MAC address will be sent with the following features:

LLDP  - turned off by issuing no lldp send-and-receive

BPDU - turned off by issuing spanning-tree bpdufilter enable on a switchport

GVRP - off by default

This physical loop that is being reported is different than a network topology loop that spanning-tree protocol would detect. You can observe this same behavior by making an Ethernet loop back plug and inserting it into a port on the unit.  If you are seeing this I would suggest investigating what is plugged into the unit and determining how or where a loopback is being created by it.

Thanks,

Matt

View solution in original post

0 Kudos
Reply
Highlighted
New Contributor II

Re: Why would Adtran 7100 continuously report "INTERFACE_STATUS.giga-eth 0/1 changed state to testing"?

Jump to solution

Thank you Matt,  The suggested commands seem to have cleared the event entries.   I have marked you answer as correct.

0 Kudos
Highlighted
Anonymous
Not applicable

Re: Why would Adtran 7100 continuously report "INTERFACE_STATUS.giga-eth 0/1 changed state to testing"?

Jump to solution

You are welcome.  I am glad that helped.  I wanted to add a quick note that disabling these will just prevent the port from going into the "IN TEST" mode.  This does not break the physical loop that likely still exists.  Keep that in mind if you have network performance problems or other future issues.

Thanks,

Matt

Highlighted
New Contributor

Re: Why would Adtran 7100 continuously report "INTERFACE_STATUS.giga-eth 0/1 changed state to testing"?

Jump to solution

Hi,

I am having the same problem with my 7100, but the thing is, there is NOTHING connected to the port.

The mac address table shows that the port has a dynamic entry for it's own mac address. Even if I change the mac address of the port and bring it up, it adds its new own mac address to the table again.

2015.03.31 10:51:42 INTERFACE_STATUS.eth 0/7 changed state to administratively up

2015.03.31 10:51:55 INTERFACE_STATUS.eth 0/7 changed state to up

2015.03.31 10:51:56 INTERFACE_STATUS.eth 0/7 changed state to testing

Again, there is no cable connected to this interface!

port mac address : 00:a0:c8:95:9f:5e

mac table

2      00:a0:c8:95:9f:5e   DYNAMIC   eth 0/7

after changing the mac (to final 7F) it adds it too :

2      00:a0:c8:95:9f:7f   DYNAMIC   eth 0/7

Could it be a hardware problem?

Thanks.

0 Kudos