cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
New Contributor

Netvanta 1224STR w/T1 module to TSU100e/Cisco 2513

Greetings,

The 1224 is connected to the TSU100e with a T1x.  The cable is cat5 and about 3 feet long.  Here's the setup:

  1. TSU provides telco layer 1 timing
  2. TSU and 1224 have 1 DS0 allocated, HDLC
  3. TSU DS0 timing is set to internal
  4. Behind the 1224 is the following Dynamips setup
    1. 4 3725's w/16FE acting as switches
    2. 7 3725's
    3. 3 1900's
    4. 2 ASA's
  5. Behind the TSU100 is the following physical gear
    1. 1 4000 w/4 Serial and 1 tokenring
    2. 3 2500's

When the T1 is up I can ping from tip to tail and everything is cool, then for some unknown reason the T1 goes down.  It might be becuase I bumped the cable but I'm not sure...but once it goes down it's a full on production with snake charmers, belly dancers, and tibetin monks to get it back up and I can't figure out why.

Any thoughts or guidance?

0 Kudos
7 Replies
Highlighted
Valued Contributor
Valued Contributor

Re: Netvanta 1224STR w/T1 module to TSU100e/Cisco 2513

The TSU 100e is a layer 1 device. It is providing physical
layer connectivity between the T1 and the V.35 interface.

When the T1 goes down, what alarms or errors are indicated
on the TSU 100e? You can go into the STATUS menu and look at the ACTIVE ALARMS,
as well as NI ERRORS. In the Netvanta 1224 you can do a “show interface” to see
the status of the T1 interface. If there is an LOS alarm, this is “loss of
signal” which means a total disconnect. A red alarm is a loss of framing,
indicating the T1 signal is there but the equipment cannot get frame sync. If
there are alarms, you can try a T1 loopback plug to verify the alarms clear to
a loopback. If they do not, then the cable, the loopback plug, or the T1
interface is bad.

Hope this helps,

Patrick

Highlighted
New Contributor

Re: Netvanta 1224STR w/T1 module to TSU100e/Cisco 2513

Hey Patrick, thanks for the quick reply...It's showing LOS now.  Thinking it might have been the cable I made a new one (1<>4, 2<>5, 3<>3, 4<>1, 5<>2, 6<>6, 7<>7, 8<>8) this morning and I might have goofed, I'm gonna head home in at 1130 to swap it out for the one I know works.

Here's the TSU info:

TSU > Status > Network Errors shows a continuious * above CRC and BPV and an intermitant * above FER ever ~2-5 seconds

      15MIN/ 24HR

%AS =  56.4/  NA
%EF =   1.4/  NA
ES  =   501/  NA
SES =     0/  NA
UAS =   392/  NA

             HISTORY

15:57 07/02 0.1     CLOCK SLIP    
15:57 07/02 0.1     PLL ALARM     
15:59 07/02 NI      YELLOW ALARM   
16:00 07/02 NI      YEL ALRM CLEAR 
17:16 07/02 NI      LINE ON (NI)   
17:18 07/02 NI      PAYLOAD ON (NI)
17:19 07/02 NI      LOOPBACK OFF   
17:21 07/02 NI      LOOPBACK OFF   
17:22 07/02 NI      LOOPBACK OFF   
17:34 07/02 NI      YELLOW ALARM   
17:35 07/02 NI      YEL ALRM CLEAR 
17:46 07/02 1.1     RED ALARM     
17:46 07/02 1.1     LOSS OF SIGNAL
17:46 07/02 1.1     FRAME SLIP    
17:47 07/02 1.1     FRAME SLIP    
17:47 07/02 1.1     FRAME SLIP    
17:48 07/02 1.1     FRAME SLIP    
17:48 07/02 1.1     FRAME SLIP    
17:48 07/02 1.1     FRAME SLIP    
17:49 07/02 1.1     FRAME SLIP    


Network Configuration
1) Format                        ESF 
2) Code                          B8ZS
3) Yellow Alarm                  ENA
4) Transmit PRMs                 OFF
5) Timing Mode                   INTERNAL     
6) Set Line Build Out             0.0
7) Remote Loopback Det           ACCEPT ALL     
😎 Bit Stuffing                  DISABLE
9) TR-08 Options                
10) Exit                         
Command:

Port 0.1 NX/DBU

1)DS0 RATE:         64 KBPS
2)TX CLK CNTRL:     NORMAL
3)DATA:             NORMAL
4)CTS:              NORMAL 
5)DCD:              NORMAL 
6)DSR:              NORMAL 
7)"0" INHIB:        OFF     
8)INBAND MODE:      OFF     
9)TX CLK SOURCE:    INTERNAL

Here's the 1224 info

2021_1#show running-config interface t1 1/1 verbose

Building configuration...

!

!

interface t1 1/1

  description

  framing esf

  clock source line

  coding b8zs

  lbo long 0

  fdl none

  remote-loopback

  remote-alarm rai

  alias

  snmp trap link-status

  no snmp trap threshold-reached

  no snmp trap line-status

  tdm-group 1 timeslots 1 speed 64

  no shutdown

!

2021_1#show running-config interface hdlc 1 verbose

Building configuration...

!

!

interface hdlc 1

  description

  ip address  10.1.1.2  255.255.255.0

  ip proxy-arp

  ip ospf authentication-key

  ip ospf authentication null

  ip ospf message-digest-key 1 md5

  ip ospf message-digest-key 2 md5

  no ip ospf cost

  ip ospf retransmit-interval 5

  ip ospf transmit-delay 1

  ip ospf priority 1

  ip ospf hello-interval 10

  ip ospf dead-interval 40

  no ip ffe

  no ip mcast-stub helper-enable

  ip igmp version 2

  ip igmp last-member-query-interval 1000

  ip igmp query-interval 60

  ip igmp query-max-response-time 10

  ip igmp querier-timeout 120

  no ip igmp immediate-leave

  ip route-cache

  ip split-horizon

  no dynamic-dns

  keepalive 10

  alias

  fair-queue

  no hold-queue out

  no qos-policy out

  max-reserved-bandwidth 75

  bandwidth 0

  mtu 1500

  lldp send-and-receive

  lldp send port-description

  lldp send system-name

  lldp send system-description

  lldp send system-capabilities

  lldp send management-address

  no shutdown

  cross-connect 1 t1 1/1 1 hdlc 1

!

end

2021_1#show interfaces t1 1/1
t1 1/1 is DOWN
  Transmitter is sending remote alarm
  Receiver has loss of signal, loss of frame
  T1 coding is B8ZS, framing is ESF
  Clock source is line, FDL type is ANSI
  Line build-out is 0dB
  No remote loopbacks, No network loopbacks
  Acceptance of remote loopback requests enabled
  Tx Alarm Enable: rai
  Last clearing of counters 01:25:26
    loss of frame  : 1, current duration 01:25:26
    loss of signal : 1, current duration 01:25:26
    AIS alarm      : 0
    Remote alarm   : 0

  DS0 Status: 123456789012345678901234
              N-----------------------
  Status Legend: '-' = DS0 is unallocated
                 'N' = DS0 is dedicated (nailed)

  Line Status: -- LOS -- Red -- Tx Yellow --

  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  Current Performance Statistics:
    0 Errored Seconds, 0 Bursty Errored Seconds
    0 Severely Errored Seconds, 295 Severely Errored Frame Seconds
    295 Unavailable Seconds, 0 Path Code Violations
    0 Line Code Violations, 0 Controlled Slip Seconds
    0 Line Errored Seconds, 0 Degraded Minutes

  TDM group 1, line protocol is DOWN
  Encapsulation HDLC (hdlc 1)
    0 packets input, 0 bytes, 0 no buffer
    0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame
    0 abort, 0 discards, 0 overruns
    0 packets output, 0 bytes, 0 underruns

Highlighted
New Contributor

Re: Netvanta 1224STR w/T1 module to TSU100e/Cisco 2513

And here's some info on the 2513 connected to the TSU

2513#show running-config
Building configuration...

Current configuration:
!
version 11.2
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname 2513
!
aaa new-model
enable password
!
username privilege 15 password 0
!
interface Ethernet0
no ip address
shutdown
!
interface Serial0
ip address 10.1.1.1 255.255.255.0
!
interface Serial1
ip address 10.1.2.1 255.255.255.252
!
interface TokenRing0
no ip address
shutdown
!
no ip classless
ip route 172.20.1.0 255.255.255.0 10.1.1.2
!
line con 0
line aux 0
line vty 0 4
!
end

2513#show interfaces serial 0

Serial0 is down, line protocol is down

  Hardware is HD64570

  Internet address is 10.1.1.1/24

  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, rely 255/255, load 1/255

  Encapsulation HDLC, loopback not set, keepalive set (10 sec)

  Last input 03:22:33, output 03:23:10, output hang never

  Last clearing of "show interface" counters 01:32:43

  Input queue: 0/75/0 (size/max/drops); Total output drops: 0

  Queueing strategy: weighted fair

  Output queue: 0/1000/64/0 (size/max total/threshold/drops)

     Conversations  0/2/256 (active/max active/max total)

     Reserved Conversations 0/0 (allocated/max allocated)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     0 packets input, 0 bytes, 0 no buffer

     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

     473 input errors, 157 CRC, 0 frame, 0 overrun, 0 ignored, 26 abort

     0 packets output, 0 bytes, 0 underruns

     0 output errors, 0 collisions, 29 interface resets

     0 output buffer failures, 0 output buffers swapped out

     8 carrier transitions

     DCD=down  DSR=down  DTR=up  RTS=up  CTS=down

2513#show controllers serial 0

HD unit 0, idb = 0xA7990, driver structure at 0xAC718

buffer size 1524  HD unit 0, V.35 DTE cable

cpb = 0xE4, eda = 0xC140, cda = 0xC000

RX ring with 16 entries at 0xE4C000

00 bd_ptr=0xC000 pak=0x0AE470 ds=0xE52EA8 status=80 pak_size=0

01 bd_ptr=0xC014 pak=0x0ADB60 ds=0xE50D10 status=80 pak_size=0

02 bd_ptr=0xC028 pak=0x0AE2A0 ds=0xE527F0 status=80 pak_size=0

03 bd_ptr=0xC03C pak=0x0AF860 ds=0xE57890 status=80 pak_size=0

04 bd_ptr=0xC050 pak=0x0AF690 ds=0xE571D8 status=80 pak_size=0

05 bd_ptr=0xC064 pak=0x0AF120 ds=0xE55DB0 status=80 pak_size=0

06 bd_ptr=0xC078 pak=0x0AE0D0 ds=0xE52138 status=80 pak_size=0

07 bd_ptr=0xC08C pak=0x0AD5F0 ds=0xE4F8E8 status=80 pak_size=0

08 bd_ptr=0xC0A0 pak=0x0AF2F0 ds=0xE56468 status=80 pak_size=0

09 bd_ptr=0xC0B4 pak=0x0AEBB0 ds=0xE54988 status=80 pak_size=0

10 bd_ptr=0xC0C8 pak=0x0AFDD0 ds=0xE58CB8 status=80 pak_size=0

11 bd_ptr=0xC0DC pak=0x0ADD30 ds=0xE513C8 status=80 pak_size=0

12 bd_ptr=0xC0F0 pak=0x0AE810 ds=0xE53C18 status=80 pak_size=0

13 bd_ptr=0xC104 pak=0x0AFC00 ds=0xE58600 status=80 pak_size=0

14 bd_ptr=0xC118 pak=0x0AD7C0 ds=0xE4FFA0 status=80 pak_size=0

15 bd_ptr=0xC12C pak=0x0AD990 ds=0xE50658 status=80 pak_size=0

16 bd_ptr=0xC140 pak=0x0AE640 ds=0xE53560 status=80 pak_size=0

cpb = 0xE4, eda = 0xC800, cda = 0xC800

TX ring with 2 entries at 0xE4C800

00 bd_ptr=0xC800 pak=0x000000 ds=0x000000 status=80 pak_size=0

01 bd_ptr=0xC814 pak=0x000000 ds=0x000000 status=80 pak_size=0

02 bd_ptr=0xC828 pak=0x000000 ds=0x000000 status=80 pak_size=0

409 missed datagrams, 0 overruns

0 bad datagram encapsulations, 0 memory errors

0 transmitter underruns

21101 residual bit errors

Highlighted
Valued Contributor
Valued Contributor

Re: Netvanta 1224STR w/T1 module to TSU100e/Cisco 2513

It looks like both the TSU 100e and the Netvanta 1224 are showing LOS, so the cable is the first thing to check. A loopback on each T1 interface may also be helpful.

Highlighted
New Contributor

Re: Netvanta 1224STR w/T1 module to TSU100e/Cisco 2513

I think I figured something out.  It appears to be behaving like a timing or timing drift or sync timing drift issue.  I found that cycling the physical cable between the TSU100 and 1224 fixes the issue, quickly.  It usually takes about 2 or 3 cycles but that takes less than 10 seconds total.  Wondering if it might be the TSU100 I first swapped it out for an IQ710 and then for a TSU600.  Neither of them seemed to exhibit the issue although I onlly had the 710 in the mix for about 5 min but the 600 has been stable for over 24hrs...I'm gonna flash the TSU100 tonight, hopefully that will stabilize it.

Highlighted
Anonymous
Not applicable

Re: Netvanta 1224STR w/T1 module to TSU100e/Cisco 2513

dtdionne,

Were you able to stabilize the unit?

Thanks,

kalync

Highlighted
Anonymous
Not applicable

Re: Netvanta 1224STR w/T1 module to TSU100e/Cisco 2513

dtdionne,

I am marking this question as 'Assumed Answered', since there have been no additional follow-up questions.  Please mark any replies that you found to be helpful or correct.  Let us know if you need any further assistance.

Thank you,

kalync