cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
sm8651
New Contributor II

924e Failover Probe ping failing

We have some Adtrans 908es 2nd gens out there that have issues with track and ICMP probe pings, and our issue is that when the primary internet goes offline, the adtran will send activate the backup connection but for less than a minute and go back to primary and keep the adtran offline until you physically remove the ethernet 0/1 wire, then the backup will kick in.

We are having major issues with certain firmware's up to AOS 13.10.1 and I believe now 13.11 as well.

Below is a sample of one of our failover scripts.

Let me know i you have a working one, or see what's wrong with ours here below. Thanks


!
!
domain-proxy
name-server 8.8.8.8 208.67.222.222
!
ip local policy route-map ICMP_FAILOVER
!
!
!
probe FAILOVER icmp-echo
destination 8.8.8.8
source-address (WAN1 IP Address)
period 10
tolerance consecutive fail 5 pass 10
no shutdown
!
track FAILOVER
snmp trap state-change
test if probe FAILOVER
no shutdown
!

!
interface eth 0/1
ip address (WAN1 IP Address) (SubnetMask)
no awcp
no shutdown
no lldp send-and-receive
media-gateway ip primary
!
!
interface eth 0/2
ip address (WAN2 IP Address) (SubnetMask)
ip access-policy WAN-FAILOVER
! IPv4 access-policy will not be used until IPv4 firewall is enabled
no awcp
no shutdown
no lldp send-and-receive
media-gateway ip primary
!
route-map probeping1 permit 10
match ip address ping1
set ip next-hop (WAN1 Gateway)
set interface null 0
route-map probeping1 permit 20
match ip address ping2
set ip next-hop (WAN1 Gateway)
set interface null 0
route-map ICMP_FAILOVER permit 10
match ip address pingprobe
set ip next-hop (WAN1 Gateway)
set interface null 0
!
!
ip access-list extended MATCHALL-FAILOVER
permit ip any any
!
ip access-list extended ping1
permit icmp any host 8.8.8.8
!
ip access-list extended ping2
permit icmp any host 208.67.222.222
!
ip access-list extended pingprobe
permit icmp host (WAN1 IP Address) host 8.8.8.8
!
no ip policy-class WAN-FAILOVER rpf-check
ip policy-class WAN-FAILOVER
allow list MATCHALL-FAILOVER self
allow list MATCHALL-FAILOVER stateless
!
ip route 0.0.0.0 0.0.0.0 (WAN1 Gateway)
ip route 0.0.0.0 0.0.0.0 (WAN2 Gateway) 250
!
end"

0 Kudos