cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
moshe
New Contributor

Adtran total access 903 WAN failover

Hi

i followed the documentation on setting up failover and below are my configs, so when the primary goes down 

i can ping the failover IP address but i cant login to ssh or send calls to the failover IP address

when the primary WAN comes back up the adtran sticks to the failover it will not activate the primary 

 

!
interface eth 0/1
  description Fios
  ip address  71.xx.xx.148  255.255.255.0
  media-gateway ip primary
  no shutdown
!
interface eth 0/2
  description cable
  ip address  184.xxx.xx.244  255.255.255.248
  media-gateway ip primary
  no shutdown
!
!
probe ping1 icmp-echo
  destination 4.2.2.2
  period 10
  tolerance consecutive fail 6 pass 3
  no shutdown
!
probe ping2 icmp-echo
  destination 208.67.222.222
  period 10
  tolerance consecutive fail 6 pass 3
  no shutdown
!
track ping1
  test list or
    if probe ping1
    if probe ping2
  no shutdown

!
route-map probeping1 permit 10
  match ip address ping1
  set ip next-hop 184.xxx.xx.241
  set interface null 0
route-map probeping1 permit 20
  match ip address ping2
  set ip next-hop 184.xxx.xx.241
  set interface  null 0
!
!
ip access-list extended probeping1
  permit icmp any  hostname 4.2.2.2
  permit icmp any  hostname 208.67.222.222
!
!
!
!
!
!
!
ip route 0.0.0.0 0.0.0.0 184.xxx.xx.241 track ping1
ip route 0.0.0.0 0.0.0.0 71.xx.xx.1 10
!
ip local policy route-map probeping1

 

0 Kudos
1 Reply

Re: Adtran total access 903 WAN failover

One thing I see, in your probe you have

 set interface null 0

You probably need

 set ip next-hop <whatever primary gateway IP address you would use when not in failover>