Showing results for 
Show  only  | Search instead for 
Did you mean: 
New Contributor II

FXS is Dead Air Until Reboot

Something I've been dealing with for years and I'm hoping other people have seen this and may have an answer.

An Adtran's FXS interface will sometimes stop working at random. Could be weeks, could be months. Eventually, a single FXS interface can see calls with ring voltage but when they pick up the calls it's either dead air or one-way audio on analog phones and even on lineman's test sets. The lineman's test set also cannot break dialtone as if DTMF is not being detected. Debug shows no digits dialed. This seems to only impact a single interface at a time. All the other FXS interfaces will be making calls without issue. I will sometimes see two or more FXS affected at the same time which leads me to believe it could be a per-interface setting.

A reboot of the ADTRAN will ALWAYS resolve the problem and the interface will start working like normal for another random amount of time. A Shut-no shut will typically not resolve the issue. Any ideas the community has would be helpful.

ADTRAN, Inc. OS version R13.12.1.E
Mainline Version: ENM.21.103
P4 Changelist: 674169
Checksum: ab8d9294ba96cd18c33b949d9a598d7846f45759919cbc8389007b141c66b25f
Built on: Fri Jan 21 08:14:05 CST 2022
Hardware version Vesuvius v.
Boot ROM version R13.7.0.B1
Built on: Thu Jul 16 22:09:40 CDT 2020
Compatibility Version: 1
Copyright (c) 1999-2022, ADTRAN, Inc.
Platform: Total Access 908 (3rd Gen), part number 4213908F1
Serial number CFG1879064
Flash: 216084480 bytes DRAM: 509648896 bytes

Cheshire_Med_Winchester uptime is 1 week, 6 days, 16 hours, 31 minutes, 14 seconds

slot 0, DSP 1
DSP software version: G3.R1.5.0-R
DSP hardware version: Freescale BSC9131
Total channels: 60

System returned to ROM by Soft Reset
Current system image file is ""
Primary boot system image file is ""
Backup boot system image file is ""
Primary system configuration file is "startup-config"

--- Debug of Call Attatched--

0 Kudos
3 Replies
New Contributor

Re: FXS is Dead Air Until Reboot

I am having this exact same issue on TA924 Gen 3. We are running firmware 14.1.1.HA.

User cannot break dialtone. They can answer a call, and hear the outside person, but the outside person cannot hear them. One way audio. We have duplicated this with a buttset. Rebooting does fix the issue temporarily. But it comes back at random times. 

Our TA924 Gen 2 do not seem to have this issue. We have about 100 units in the field and we are dealing with this every week. 

Re: FXS is Dead Air Until Reboot

I also am having this issue too.  What I noticed on the sites having issues is the Boot ROM version is R13.7.0.B1.   Configuration is in use at many different customer locations and they aren't having the issue.   Did you happen to find a resolution?

New Contributor

Re: FXS is Dead Air Until Reboot

I am also having this issue randomly. The ports are either dead with no dial tone or calls complete with no/one-way audio. The no audio is fixed by fxs reset but the no dial tone requires a reload. I have tried multiple versions of newest and oldest AOS versions but seem to get the same result at these locations.  I am wondering what other commands i can use for debugging the root cause of the dial tone failure or inability to break tone issue. 

Reloading isnt exactly a great fix for the customer so any help i can get or give for data points would be appreciated.