cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
garoye
New Contributor II

FXS to SIP Trunk Busy

I am having a problem getting my fxs ports to dial out my SIP trunk. When I place a call I get a fast busy. I have 5 fxs ports, 4 of those being in a ring group and the 5th registered with its own registration and Trunk T01 with an active registration. If I call out fxs 5 it works fine. Inbound calls are working as well. I know at least part of the issue is an authentication problem because I see the sip message using <1001@> when it should be <sipusername@>. I updated my voice user 1001 using sip-identity sipusername T01 and it was able to dial out. Problem is sip-identity has to be unique and I am already using them on my ring groups.  I have pasted my config below. Can someone tell me how to get this to work.

 

 

!
!
! ADTRAN, Inc. OS version R13.5.1.E
! Boot ROM version 14.05.00.SA
! Platform: Total Access 908e (2nd Gen), part number 4242908L1
! Serial number CFG0913055
!
!
hostname "3"
enable password encrypted
!
!
clock timezone -8
!
ip subnet-zero
ip classless
ip routing
ipv6 unicast-routing
!
!
name-server 8.8.8.8
!
!
no auto-config
auto-config authname adtran encrypted password
!
event-history on
no logging forwarding
no logging email
!
service password-encryption
!
username "000" password encrypted ""
!
!
no ip firewall alg msn
no ip firewall alg mszone
no ip firewall alg h323
!
!
!
!
!
!
!
!
no dot11ap access-point-control
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface eth 0/1
ip address dhcp hostname "TA908e"
no shutdown
media-gateway ip primary
!
!
interface eth 0/2
no ip address
shutdown
!
!
!
!
interface t1 0/1
shutdown
!
interface t1 0/2
shutdown
!
interface t1 0/3
shutdown
!
interface t1 0/4
shutdown
!
!
interface fxs 0/1
no shutdown
!
interface fxs 0/2
no shutdown
!
interface fxs 0/3
no shutdown
!
interface fxs 0/4
no shutdown
!
interface fxs 0/5
no shutdown
!
interface fxs 0/6
shutdown
!
interface fxs 0/7
shutdown
!
interface fxs 0/8
shutdown
!
!
interface fxo 0/0
no shutdown
!
!
!
!
!
!
!
ip access-list standard magmt-allow-list
permit host x.x.x.x

!
ip access-list standard sip-allow-list
permit host x.x.x.x
!
!
!
!
!
!
ip route 0.0.0.0 0.0.0.0 x.x.x.x
!
no tftp server
no tftp server overwrite
http server
no http secure-server
no snmp agent
no ip ftp server
no ip scp server
no ip sntp server
!
http ip access-class magmt-allow-list in
http ip secure-access-class magmt-allow-list in
!
!
!
!
!
!
!
sip
sip udp 5060
no sip tcp
!
!
!
voice feature-mode network
voice forward-mode network
!
!
!
!
!
!
!
!
voice dial-plan 1 local NXX-XXXX
voice dial-plan 2 long-distance 1-NXX-NXX-XXXX
voice dial-plan 3 extensions 2000X
!
!
!
!
voice codec-list VOICE
default
codec g729
codec g711ulaw
!
!
!
!
voice trunk T01 type sip
description "SIP out"
match dnis "NXX-NXX-XXXX" substitute "1-NXX-NXX-XXXX"
match dnis "NXX-XXXX" substitute "1-714-NXX-XXXX"
sip-server primary x.x.x.x
registrar primary x.x.x.x
outbound-proxy primary x.x.x.x
domain "x.x.x.x"
register user auth-name "user" password encrypted ""
codec-list VOICE both
!
!
voice grouped-trunk SIP
trunk T01
accept $ cost 0
!
!
voice user 1001
connect fxs 0/1
no cos
password encrypted ""
description "TN 1001"
no call-waiting
sip-authentication password encrypted ""
codec-list VOICE
!
!
!
voice user 1002
connect fxs 0/2
no cos
password encrypted ""
description "tn for 1002"
no call-waiting
sip-authentication password encrypted ""
codec-list VOICE
!
!
!
voice user 1003
connect fxs 0/3
no cos
password encrypted ""
description "tn for 1003"
no call-waiting
sip-authentication password encrypted ""
codec-list VOICE
!
!
!
voice user 1004
connect fxs 0/4
no cos
password encrypted ""
description "did for 1004"
no call-waiting
sip-authentication password encrypted ""
codec-list VOICE
!
!
!
voice user 1005
connect fxs 0/5
no cos
password encrypted ""
description "tn 1005"
no call-waiting
sip-identity user5 T01 register auth-name "user5" password encrypted ""
sip-authentication password encrypted ""
codec-list VOICE
!
!
voice ring-group 20001
type linear
num-rings 0
member 1001
login-member 1001
coverage internal 20002
coverage internal 20003
coverage internal 20004
no prefix
sip-identity user1 T01 register auth-name "user1" password encrypted ""
!
!
voice ring-group 20002
type linear
num-rings 0
member 1002
login-member 1002
coverage internal 20003
coverage internal 20004
coverage internal 20001
no prefix
sip-identity user2 T01 register auth-name "user2" password encrypted ""
!
!
voice ring-group 20003
type linear
num-rings 0
member 1003
login-member 1003
coverage internal 20004
coverage internal 20001
coverage internal 20002
no prefix
sip-identity user3 T01 register auth-name "user3" password encrypted ""
!
!
voice ring-group 20004
type linear
num-rings 0
member 1004
login-member 1004
coverage internal 20001
coverage internal 20002
coverage internal 20003
no prefix
sip-identity user4 T01 register auth-name "user4" password encrypted ""
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
line con 0
no login
!
line telnet 0 4
no login
no shutdown
ip access-class magmt-allow-list in
line ssh 0 4
login local-userlist
no shutdown
ip access-class magmt-allow-list in
!
!
!
!
!
end

 

Labels (3)
0 Kudos