cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
mvandusen
New Contributor

PRI to SIP issues

This is my first time messing with an Adtran and I have been able to get about 95% of the programming completed, but we are not able to call out from our test system. What we are doing on the SIP side is registering it as an extension on another system instead of directly to the SIP provider.

This is our setup

Mitel SX-200 ICP - PRI > Adtran Total Access 908e (2nd gen) - SIP > Mitel MBG gateway/3300. The Mitel SX-200 PRI is syncing up, and the SIP is syncing up to the MGB/3300, but when I try to call out from the 200 I'm getting no access from the console and I do not see it trying to pick up the PRI trunks. On the Mitel 200 it's our normal PRI config so I know the issue is not there.

Any help that can be provided is appreciated.

 

#
!
!
no ip firewall alg msn
no ip firewall alg mszone
no ip firewall alg h323
!
!
!
!
!
!
!
!
no dot11ap access-point-control
!
!
!
!
!
!
!
ip dhcp pool "Private"
network 10.10.10.0 255.255.255.0
netbios-node-type h-node
default-router 10.10.10.1
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface eth 0/1
description WAN
ip address <ip removed>
media-gateway ip primary
no awcp
no shutdown
!
!
interface eth 0/2
description DHCP
no ip address
no shutdown
!
!
!
!
interface t1 0/1
description t1
framing d4
coding ami
snmp trap line-status
shutdown
!
interface t1 0/2
framing d4
coding ami
snmp trap line-status
tdm-group 1 timeslots 1-12 speed 64
tdm-group 2 timeslots 13-24 speed 64
no shutdown
!
interface t1 0/3
no shutdown
!
interface t1 0/4
description PRI to PBX
tdm-group 1 timeslots 1-24 speed 64
no shutdown
!
!
interface pri 1
description PRI to PBX
isdn name-delivery setup
connect t1 0/4 tdm-group 1
no shutdown
!
!
interface fxs 0/1
no shutdown
!
interface fxs 0/2
no shutdown
!
interface fxs 0/3
no shutdown
!
interface fxs 0/4
no shutdown
!
interface fxs 0/5
no shutdown
!
interface fxs 0/6
no shutdown
!
interface fxs 0/7
no shutdown
!
interface fxs 0/8
no shutdown
!
!
interface fxo 0/0
no shutdown
!
!
isdn-group 1
connect pri 1
!
!
!
!
!
!
!
ip access-list standard Test
permit host <ip removed>
!
!
!
!
!
!
ip route 0.0.0.0 0.0.0.0 <ip removed>
!
no tftp server
no tftp server overwrite
http server
http secure-server
snmp agent
no ip ftp server
no ip scp server
no ip sntp server
!
!
!
!
snmp-server contact "Support"
snmp-server contact phone "removed"
snmp-server contact email "removed"
snmp-server location "Test"
snmp-server community united RO
!
!
!
!
sip
sip udp 5060
no sip tcp
!
!
!
voice feature-mode network
voice forward-mode network
!
!
!
!
!
!
!
!
voice dial-plan 1 long-distance 1-NXX-NXX-XXXX
voice dial-plan 2 local NXX-NXX-XXXX
!
!
!
!
voice codec-list Trunk
codec g729
codec g711ulaw
!
!
!
voice trunk T01 type sip
description "SIP"
sip-server primary <removed>
register 6008 auth-name "6008" password encrypted
"1b132d8fdd4844ad2a1b0fc983ce3e214e68"
codec-list Trunk both
!
voice trunk T02 type isdn
description "PRI to PBX"
resource-selection circular descending
connect isdn-group 1
early-cut-through
rtp delay-mode adaptive
codec-list Trunk
!
!
voice grouped-trunk PRI
trunk T02
accept $ cost 0
!
!
voice grouped-trunk SIP
trunk T01
trunk T02
accept $ cost 0
!
!
voice user 6008
connect sip
first-name "Adtran"
last-name "Test"
password encrypted "2723ef1bace523e88dc1839aa58a7da49d2f"
sip-authentication password encrypted
"2129a187549f6d1055fc62b5796c652c338a"
t38
!
!
!
!
!
!
!
!
!
sip authenticate
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
line con 0
login
!
line telnet 0 4
login local-userlist
password encrypted 404772e3e846128d2b8f69f020171f8fd3ea
no shutdown
line ssh 0 4
login local-userlist
shutdown
!
sntp server pool.ntp.org version 2
!
!
!
!
end

 

0 Kudos
3 Replies
spence
New Contributor II

Re: PRI to SIP issues

Our Mitel system requires 

 

interface t1 0/2
framing ESF
coding B8ZS

 

I din't know is that helps but my be worth a check.

jayh
New Contributor III

Re: PRI to SIP issues

I'd remove trunk T02 from voice grouped-trunk SIP.

Then do a "debug voice verbose" and try to make a call in both directions. You should see a lot of output which may give a hint as to why the calls are failing. Post the result here if you don't see something obvious.

You may also need to modify the PRI interface to send fewer digits, typically the PBX expects 3, 4, or 7.

jayh
New Contributor III

Re: PRI to SIP issues

That looks to be old configuration from a robbed-bit setup or the like. In any case it doesn't look like T1 0/2 is in service. PRI is on T1 0/4 which is indeed set to B8ZS/ESF (default configuration).