cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
New Contributor

Phones failing to register behind Transparent Proxy

Jump to solution

Product: Adtran 924eG3 w/LFXO

Firmware: ADTRAN, Inc. OS version R12.2.0.SA.E

Running into an issue where the phones behind the Transparent SIP Proxy are refusing to register correctly. If the phone is connected behind another Vendor's router/firewall they work fine. The phones are registering to a metaswitch installation.

Seeing this in the logs:

12:42:34.517 SIP.PROXY ROUTING Modify response for proxy

12:42:34.517 SIP.PROXY ROUTING ERROR! Failed to set local address.

12:42:34.517 SIP.PROXY ROUTING ERROR! proxyResponseAsServer failed.

12:42:34.518 SIP.PROXY ROUTING ERROR! proxyResponse failed.

I can ping the SBC from the Adtran unit and can set up the FXS ports to register without issue.

I have several of these out in the field with a very similar config that are working fine.

Extremely puzzled as to why this one isn't working.

Attached is a sanitized copy of the configuration and logs.

Any ideas?

Labels (1)
0 Kudos
Reply
1 Solution

Accepted Solutions
Highlighted
Honored Contributor
Honored Contributor

Re: Phones failing to register behind Transparent Proxy

Jump to solution

Under the inside interfaces with the phones to be proxied, add media-gateway ip primary .

interface eth 0/1.10

  description VOIPGW

  vlan-id 10

...

...

media-gateway ip primary

interface eth 0/2.1010

  vlan-id 1010

...

...

media-gateway ip primary

View solution in original post

0 Kudos
Reply
2 Replies
Highlighted
Honored Contributor
Honored Contributor

Re: Phones failing to register behind Transparent Proxy

Jump to solution

Under the inside interfaces with the phones to be proxied, add media-gateway ip primary .

interface eth 0/1.10

  description VOIPGW

  vlan-id 10

...

...

media-gateway ip primary

interface eth 0/2.1010

  vlan-id 1010

...

...

media-gateway ip primary

View solution in original post

0 Kudos
Reply
Highlighted
New Contributor

Re: Phones failing to register behind Transparent Proxy

Jump to solution

Apparently the older boxes we have running 10.x firmware didn't require this to be happy. Running on 11.x and 12.x they do.

0 Kudos
Reply