cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
PBXstore
New Contributor

Sip Trunk not failing over to secondary interface

Hi guys,

I'm using an Adtran 908e 3rd gen with Dual Wan failover and a SIP trunk. The Wan failover portion is working fine but the problem I'm having is that the sip trunk does not work during a failover to the secondary interface, unless i manually trigger the re-registration of the sip trunk. All other traffic but the Sip traffic routes accordantly over the secondary interface.  

Configuration is attached. Any help is appreciated

!
!
! ADTRAN, Inc. OS version R13.9.0.HB.E
! Boot ROM version R10.9.3.B2
! Platform: Total Access 900e (3rd Gen), part number 4243924L8
! Serial number XXXXXXX
!
!
hostname "TA908e"
enable password XXXXXXX
!
!
clock timezone -5-Eastern-Time
!
ip subnet-zero
ip classless
ip routing
ipv6 unicast-routing
!
!
name-server 8.8.8.8 8.8.4.4
!
ip local policy route-map PROBE
!
no auto-config
!
event-history on
no logging forwarding
no logging email
!
no service password-encryption
!
username "admin" password "XXXXXXX"
!
!
ip firewall
ip firewall fast-nat-failover
no ip firewall alg msn
no ip firewall alg mszone
no ip firewall alg h323
!
!
!
!
!
!
!
!
no dot11ap access-point-control
!
!
!
probe PRIMARY cmp-echo
destination 8.8.8.8
source-address XX.XXX.XXX.11
period 3
timeout 1000
tolerance consecutive fail 3 pass 5
no shutdown
!
track PRIMARY
test if probe PRIMARY
no shutdown
!
!
!
!
!
ip dhcp pool "Private"
network 10.10.10.0 255.255.255.0
dns-server 8.8.8.8 XX.XX.XX.XX XXX.XXX.X.X
netbios-node-type h-node
default-router 10.10.10.1
!
!
!
!
!
!
!
ip crypto ffe
!
!
!
!
!
!
!
interface eth 0/1
description WAN1
ip address XX.XX.XXX.11 255.255.255.248
ip mtu 1500
ip access-policy Public
no shutdown
media-gateway ip primary
!
!
interface eth 0/2
description WAN2
ip address XXX.XXX.XXX.5 255.255.255.0
ip mtu 1500
ip access-policy Public2
no shutdown
media-gateway ip primary
!
!
!
interface gigabit-eth 0/1
ip address 10.10.10.1 255.255.255.0
ip access-policy Private
no shutdown
!
!
!
!
interface t1 0/1
description PRI to NEC
tdm-group 1 timeslots 1-24 speed 64
no shutdown
!
interface t1 0/2
shutdown
!
interface t1 0/3
shutdown
!
interface t1 0/4
shutdown
!
!
interface pri 1
description pri 1
isdn name-delivery setup
connect t1 0/1 tdm-group 1
no shutdown
!
!
interface fxs 0/1
no shutdown
!
interface fxs 0/2
no shutdown
!
interface fxs 0/3
no shutdown
!
interface fxs 0/4
no shutdown
!
interface fxs 0/5
no shutdown
!
interface fxs 0/6
no shutdown
!
interface fxs 0/7
no shutdown
!
interface fxs 0/8
no shutdown
!
interface fxs 0/9
no shutdown
!
interface fxs 0/10
no shutdown
!
interface fxs 0/11
no shutdown
!
interface fxs 0/12
no shutdown
!
interface fxs 0/13
no shutdown
!
interface fxs 0/14
no shutdown
!
interface fxs 0/15
no shutdown
!
interface fxs 0/16
no shutdown
!
interface fxs 0/17
no shutdown
!
interface fxs 0/18
no shutdown
!
interface fxs 0/19
no shutdown
!
interface fxs 0/20
no shutdown
!
interface fxs 0/21
no shutdown
!
interface fxs 0/22
no shutdown
!
interface fxs 0/23
no shutdown
!
interface fxs 0/24
no shutdown
!
!
interface fxo 0/0
shutdown
!
!
isdn-group 1
connect pri 1
!
!
!
!
route-map PROBE permit 10
match ip address PING
set ip next-hop XX.XXX.XXX.9
!
!
!
!
ip access-list standard wizard-ics
remark Internet Connection Sharing
permit any
!
!
ip access-list extended PING
permit icmp any any
permit icmp host XX.XXX.XXX.11 host 8.8.8.8
!
ip access-list extended self
remark Traffic to Total Access
permit ip any any log
!
ip access-list extended web-acl-10
remark Wan2 Access
permit tcp any any eq https log
!
ip access-list extended web-acl-11
remark Wan2 Access
permit tcp any any eq https log
!
ip access-list extended web-acl-3
remark Remote
permit tcp XX.XXX.XXX.8 0.0.0.7 any eq https log
!
ip access-list extended web-acl-4
remark PBXsip1
permit ip XXX.XX.40.0 0.0.7.255 any
!
ip access-list extended web-acl-6
remark PBXsip2
permit ip XX.XX.196.0 0.0.1.255 any
!
ip access-list extended web-acl-7
remark PBXsip3
permit ip XXX.XXX.216.0 0.0.3.255 any
!
ip access-list extended web-acl-8
remark PBXsip3
permit ip XXX.XXX.216.0 0.0.3.255 any
!
ip access-list extended web-acl-9
remark PBXsip2
permit ip XX.XX.196.0 0.0.1.255 any
!
!
!
!
ip policy-class Private
allow list self self
nat source list wizard-ics interface eth 0/1 overload policy Public
nat source list wizard-ics interface eth 0/2 overload policy Public2
!
ip policy-class Public
allow list web-acl-3 self
allow list web-acl-10 self
allow list web-acl-4
allow list web-acl-6
allow list web-acl-7
!
ip policy-class Public2
allow list web-acl-3 self
allow list web-acl-11 self
allow list web-acl-4
allow list web-acl-8
allow list web-acl-9
!
!
!
ip route 0.0.0.0 0.0.0.0 XX.XXX.XXX.9 track PRIMARY
ip route 0.0.0.0 0.0.0.0 XXX.XXX.XXX.1 50
!
no tftp server
no tftp server overwrite
no http server
http secure-server
no snmp agent
no ip ftp server
no ip scp server
no ip sntp server
!
!
!
!
!
!
!
!
sip
sip udp 5060
no sip tcp
no sip tls
!
!
!
voice feature-mode network
voice forward-mode local
!
!
!
!
!
!
!
!
voice dial-plan 1 local NXX-NXX-XXXX default
voice dial-plan 3 extensions 2000X
!
!
!
!
!
!
voice trunk T01 type sip
description "PBXhosted"
sip-server primary XXXX.XXXXXXXX.com
registrar primary XXX.XX.XX.228
outbound-proxy primary XXX.XX.XX.228
sip-keep-alive options 30
register XXXXXX_pbxsdemo auth-name "XXXXXX_pbxsdemo" password "1111111111"
authentication username "XXXXXX_pbxsdemo" password "1111111111"
default-ring-cadence external
!
voice trunk T02 type isdn
description "PRItrunks"
resource-selection circular descending
caller-id-override number-inbound XXXXXX3736 if-no-cpn
connect isdn-group 1
no early-cut-through
rtp delay-mode adaptive
!
!
voice grouped-trunk SIPTOPRI
trunk T02
accept $ cost 10
!
!
voice grouped-trunk PRITOSIP
trunk T01
accept $ cost 0
!
!
voice user 1061
connect fxs 0/11
no cos
first-name "Available"
password "1234"
!
!
!
voice user 1062
connect fxs 0/12
no cos
first-name "Available"
password "1234"
!
!
!
voice user 1063
connect fxs 0/13
no cos
first-name "Available"
password "1234"
!
!
!
voice user 1064
connect fxs 0/14
no cos
first-name "Available"
password "1234"
!
!
!
voice user 1065
connect fxs 0/15
no cos
first-name "Available"
password "1234"
!
!
!
voice user 1066
connect fxs 0/16
no cos
first-name "Available"
password "1234"
!
!
!
voice user XXXXXX2401
connect fxs 0/1
no cos
first-name "Elevator"
password "1234"
caller-id-override external-number XXXXXX2401
!
!
!
voice user XXXXXX2402
connect fxs 0/2
no cos
first-name "Elevator"
password "1234"
caller-id-override external-number XXXXXX2402
!
!
!
voice user XXXXXX2403
connect fxs 0/3
no cos
first-name "Elevator"
password "1234"
caller-id-override external-number XXXXXX2403
!
!
!
voice user XXXXXX2404
connect fxs 0/4
no cos
first-name "Elevator"
password "1234"
caller-id-override external-number XXXXXX2404
!
!
!
voice user XXXXXX2405
connect fxs 0/5
no cos
first-name "Elevator"
password "1234"
caller-id-override external-number XXXXXX2405
!
!
!
voice user XXXXXX2406
connect fxs 0/6
no cos
first-name "Elevator"
password "1234"
caller-id-override external-number XXXXXX2406
!
!
!
voice user XXXXXX2407
connect fxs 0/7
no cos
first-name "Elevator"
password "1234"
caller-id-override external-number XXXXXX2407
!
!
!
voice user XXXXXX2408
connect fxs 0/8
no cos
first-name "Alarm 1"
password "1234"
caller-id-override external-number XXXXXX2408
!
!
!
voice user XXXXXX2409
connect fxs 0/9
no cos
first-name "Alarm 2"
password "1234"
caller-id-override external-number XXXXXX2409
!
!
!
voice user XXXXXX2410
connect fxs 0/10
no cos
first-name "Security Desk"
password "1234"
caller-id-override external-number XXXXXX2410
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip rtp symmetric-filter
!
!
ip rtp quality-monitoring
ip rtp quality-monitoring sip
!
line con 0
login
!
line telnet 0 4
login
password XXXXXXXX
shutdown
line ssh 0 4
login local-userlist
shutdown
!
sntp server ntp.XXXXXX.com
!
!
!
!
end

 

 

0 Kudos
1 Reply

Re: Sip Trunk not failing over to secondary interface

PBXstore, I believe the below document should help point you in the right direction for doing the sip failover and force a re-registration

https://supportcommunity.adtran.com/jmaxz83287/attachments/jmaxz83287/nv-aos/329/1/Configuring%20SIP...