TA900 Sample Config - Basic SIP Requirements
Description:
The configuration output below represents the minimum necessary to utilize the Total Access 900 as a SIP device. This serves as a base on which to build a complete SIP configuration. Certain features - such as NAT, DHCP, VPN, QOS, or specific SIP features - are not represented here. Please note that parameters such as WAN and LAN IP addresses, server IP addresses, and voice user extension numbers will need to be changed according to the application. Remember to save by issuing the “copy run start” or “wr” command.
While this template covers an app in which the WAN connection and therefore the SIP server exists out the T1 interface, it should be noted that there are only a few changes needed for an Ethernet-fed config (i.e. behind a DSL/cable modem). Since the SIP trunk is virtual and not cross-connected to any specific physical interface, the unit relies on its gateway of last resort (default route of 0.0.0.0) to decide the interface used to transmit SIP messages. In other words, the IP of your SIP server is a layer 3 destination address treated no differently than any other packet, following the route table to decide its path. Along the same lines, the command “media-gateway ip primary” designates a given interface (Ethernet, PPP, etc) as one that will expect to transmit and receive RTP packets. It merely states “the primary IP of this interface will be a media gateway.” It does not mean “this interface is my primary media gateway” and therefore can be on more than one interface. Generally, the command needs to be on any IP interface expected to send and receive a packetized talk path via RTP. For an Eth-fed app, you will need this command on the Ethernet interface. For a T1-fed app, you will need this command on the layer 2 interface (PPP, HDLC, etc). For apps where both T1 and Eth ports will source/receive RTP (i.e. T1-fed with SIP phones on the LAN), the command will be on both.
Commented Config:
!
hostname "TA916"
no enable password
!
ip subnet-zero
ip classless
ip routing
!
event-history on
no logging forwarding
no logging email
logging email priority-level info
!
no service password-encryption
!
!
no ip firewall alg h323
!
!
!
!
!
!
!
!
interface eth 0/1
ip address 192.168.0.1 255.255.255.0
no shutdown
!
!
!
interface t1 0/1
tdm-group 1 timeslots 1-24 speed 64
no shutdown
!
interface t1 0/2
no shutdown
!
!
interface fxs 0/1
no shutdown
!
interface fxs 0/2
no shutdown
!
interface fxs 0/3
no shutdown
!
interface fxs 0/4
no shutdown
!
interface fxs 0/5
no shutdown
!
interface fxs 0/6
no shutdown
!
interface fxs 0/7
no shutdown
!
interface fxs 0/8
no shutdown
!
interface fxs 0/9
no shutdown
!
interface fxs 0/10
no shutdown
!
interface fxs 0/11
no shutdown
!
interface fxs 0/12
no shutdown
!
interface fxs 0/13
no shutdown
!
interface fxs 0/14
no shutdown
!
interface fxs 0/15
no shutdown
!
interface fxs 0/16
no shutdown
!
interface ppp 1
ip address 1.1.1.2 255.255.255.252
media-gateway ip primary
no shutdown
cross-connect 1 t1 0/1 1 ppp 1
!
!
!
!
!
!
ip route 0.0.0.0 0.0.0.0 ppp 1
!
no ip tftp server
no ip http server
no ip http secure-server
no ip snmp agent
no ip ftp agent
!
!
!
!
!
!
!
voice feature-mode network
!
!
voice dial-plan 1 local NXX-XXXX
voice dial-plan 2 long-distance 1-NXX-NXX-XXXX
!
!
!
!
voice codec-list GLOBAL
default
codec g729
codec g711ulaw
!
!
voice trunk T01 type sip
sip-server primary 10.0.0.1
!
!
voice grouped-trunk MAIN
no description
trunk T01
accept $ cost 0
!
!
voice user 1001
connect fxs 0/1
sip-identity 1001 T01 register auth-name USER1 password PASSWORD1
codec-group GLOBAL
!
!
voice user 1002
connect fxs 0/2
sip-identity 1002 T01 register auth-name USER2 password PASSWORD2
codec-group GLOBAL
!
!
ip sip
!
line con 0
no login
!
line telnet 0 4
login
password adtran
!
!
end