cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
New Contributor

experiencing disconnects with MS Remote Desktop sessions

We currently have Verizon service for Internet and VOIP whereby they installed an AdTran TotalAccess 900e device to provide both services. We have users utilizing the Internet connection to connect to a Windows Remote Desktop server and the issue faced is that randomly throughout the day users would get disconnected from the server. This does not happen to the users at the same time so while it may happen to the first user, the second user may not experience it until later. One thing is certain though, the second user will experience sooner or later. It happens to all users who use this connection multiple times a day. We have contacted Verizon on this matter and it seems like they've done everything they could and that the only solution left is to obtain two separate connections, one for VOIP and one for Internet thereby having an underutilized VOIP connection. What we have done so far either on my own or via Verizon are:

reduced the number of hops going from our site to the remote server

replaced all cables between the outside line, AdTran router, and to our network switch

replaced the AdTran

luckily we have a secondary Internet line, Verizon FIOS, that does not exhibit any of these disconnects and was able to use this to ultimately determine the cause is something on the AdTran that's causing the disconnects. out current setup is as follows: outside -> Canoga -> AdTran -> local LAN. after connecting a laptop to port Gig 0/1 and still getting the disconnects, Verizon had me introduce a switch between the Canoga and AdTran and then connect a laptop to the switch effectively bypassing the AdTran for Internet. it only during this time that this connection did not experience any disconnects! are there any experts out there than can help determine what might be the cause of this before ultimately sticking with this latter setup?

Tags (2)
0 Kudos
2 Replies
Highlighted
Honored Contributor
Honored Contributor

Re: experiencing disconnects with MS Remote Desktop sessions

Does this happen if the RDP session has been idle for ten minutes? The firewall/NAT function will by default tear down sessions with no traffic after a timeout period. This prevents hung sessions from tying up resources indefinitely. The default is 600 seconds (ten minutes).

Try the following commands:

ip policy-timeout tcp 3389 7200

ip policy-timeout udp 3389 7200

This will keep idle RDP sessions alive for two hours, which should be sufficient in most cases. You can make it longer if you desire.

Highlighted
New Contributor

Re: experiencing disconnects with MS Remote Desktop sessions

unfortunately RDP sessions disconnect regardless of being idle or not. sometimes a user would be working in the RDP session and it would disconnect right in the middle of an action.