Showing results for 
Show  only  | Search instead for 
Did you mean: 
New Contributor

BSAP 1920 Rebooting Loop


I found a new-in-box BSAP 1920 that I have been trying to get working. The fine folks at AdTran got me a license file quickly, and I was able to get it applied in the vWLAN controller without an issue.

When I downloaded the AP firmware (because that's what vWLAN was telling me to do), it seemed to automate a firmware update right to the AP without any further intervention. After this, the WAP is going into a rebooting loop.

The indicator stages proceed as:

1.) LED indicator will turn amber, pings to the AP stop

2.) All LED's go dark

3.) Power LED will go solid green

4.) Power LED turns amber

5.) Power LED flashes green, pings get returned

6.) Network activity light flashes green, pings return

> Go back to stage 1, and the process repeats

If there is another post addressing this, a link would be great. I didn't find one in my searches. Alternatively, if there is another way to go about resolving this, any pointers would be great.


0 Kudos
6 Replies

Re: BSAP 1920 Rebooting Loop

Duh... forgot to mention that vWLAN is on 2.9.0.HA.

Hmm... I may have 'jumped the gun on this'. After I posted this, I tried the firmware update process again, and now it's stable. Moderator: This post can be deleted, sorry for the trouble.

Not applicable

Re: BSAP 1920 Rebooting Loop

Vincent Asta,

No problem. I was going to offer that currently if major versions are mismatched (i.e. 2.9.X needs 2.9.X code) then you can run into reboot problems such as this as the configuration may not push to the APs correctly. It's a common problem.

Glad everything is working!



ADTRAN Product Support Engineer

Re: BSAP 1920 Rebooting Loop

What do we do if we are trying to put a AP 1920 that has not been used in a while and is on an old firmware.  6.6.30  and we are now on 3.7xx

Any suggestions on how to get it updated so we can use it?

New Contributor III

Re: BSAP 1920 Rebooting Loop

Just configure it to point to the controller and license the AP it will pull the latest from the controller if it is set in the templates to use that firmware.

Re: BSAP 1920 Rebooting Loop

Pointing to the controller and setting the license did not work, it continued to fail to get the firmware from the controller.  Ultimately I had to download the image file to a different server that supports SCP.  That server was defined in vWLAN\Configuration\Wireless\External Firmware Servers and the AP template was updated to reflect the new server for that firmware.  Worked perfectly.

New Contributor III

Re: BSAP 1920 Rebooting Loop

ah I wonder if you ran into the bug that was just recently addressed?

The 4.2.0 patch release for Adtran’s Bluesocket APs (BSAPs) is a minor patch release that addresses
upgrade issues for factory default APs running on 7.0.0-23 when they are upgraded to the 4.2.0 vWLAN release. Installing this patch allows the APs to upgrade to the vWLAN 4.2.0 release by addressing upgrade issues between the SSH Ciphers on APs running 7.0.0-23 and vWLAN instances running 4.2.0.

NOTE: These patches only apply to factory default APs running firmware 7.0.0-23.

The fixes included in these patches, and the steps to install them, are included in the release notes attached below.