I have a Netvanta 1238, with a few vlans, one for voice (phones & PBX Allworx) and Data
The Allworx provides some enduser config and webmenus but how I am currently configured I cant reach them from a PC connected to the phones.
This is how I have the ports set up
vlan 150
name "IP Phones"
!
vlan 160
name "Customer Data"
interface range switchport 0/1-46
description --->IP Phones<---
spanning-tree edgeport
no shutdown
switchport access vlan 160
switchport voice vlan 150
switchport voice-signaling vlan 150
!
interface switchport 0/47
description --->DATA Switch Uplink<---
spanning-tree edgeport
no shutdown
switchport access vlan 160
!
interface switchport 0/48
description --->Allworx LAN<---
spanning-tree edgeport
no shutdown
switchport access vlan 150
interface vlan 150
description IP Phones
ip address 192.168.3.240 255.255.252.0
no shutdown
!
interface vlan 160
description Customer Data Access
no ip address
shutdown
Any help would be greatly appreciated,
Thank you,
Sean
Is this a Gen. 1238 (1700598G1) or a Gen. 2 1238 (1702598G1)? If it is a Gen. 1 you will need to use the upstream router to connect the two subnets together at layer 3, and we need more information about that router. If Gen. 2, you can do as follows:
Assign an unused IP from the data subnet to VLAN 160.
Enable IP routing with the "ip routing" command.
On the upstream data router, add the command: "ip route 192.168.0.0. 255.255.252.0 ip.of.vlan.160
(How many phones do you have? That's a big subnet.)
Optionally, if the phones must reach the Internet directly, add the command on the 1238:
ip route 0.0.0.0 0.0.0.0 ip.of.data.router
Is this a Gen. 1238 (1700598G1) or a Gen. 2 1238 (1702598G1)? If it is a Gen. 1 you will need to use the upstream router to connect the two subnets together at layer 3, and we need more information about that router. If Gen. 2, you can do as follows:
Assign an unused IP from the data subnet to VLAN 160.
Enable IP routing with the "ip routing" command.
On the upstream data router, add the command: "ip route 192.168.0.0. 255.255.252.0 ip.of.vlan.160
(How many phones do you have? That's a big subnet.)
Optionally, if the phones must reach the Internet directly, add the command on the 1238:
ip route 0.0.0.0 0.0.0.0 ip.of.data.router
I went ahead and flagged the "Correct Answer" on this post to make it more visible and help other members of the community find solutions more easily. If you don't feel like the answer I marked was correct, feel free to come back to this post to unmark it and select another in its place with the applicable buttons. If you have any additional information on this that others may benefit from, please come back to this post to provide an update. If you still need assistance, we would be more than happy to continue working with you on this - just let us know in a reply.
Thanks,
Noor