cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Valued Contributor
Valued Contributor

Voice VLAN

Jump to solution

Thx for that tip, Levi .  Didn't know the two commands could be in conflict.  So I got rid of "access vlan" on a test switchport 0/32 and show interface status seems to indicate that swx 0/32 is back to default--access port for default VLAN 1.  It's not a trunk port.  But "voice vlan" seems to allow the phone to tag/encapsulate its traffic VLAN 7 anyway.  It's like a hybrid access port that allows 802.1Q for media endpoints only.  Is that a good way to describe it?

I will get rid of "access vlan" for the remaining phone ports today (need a maintenance window as it causes our endpoints to reinitialize), and I'll reply again with the status of the 1238's CPU load and the bcmLINK.0 task...

Labels (1)
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Anonymous
Not applicable

Re: Voice VLAN

Jump to solution

CJ:

I branched the topic of voice VLANs to a new question.

The switchport voice vlan <vlan id> [ cos <value> ] [dscp <value>] command is used for a couple specific scenarios:

1) it sets the access port to also accept tagged traffic with the specified VLAN ID

2) if the phone supports LLDP-MED, the phone should automatically switch to the specified VLAN for its traffic, as well as use the specified DSCP/COS values (CoS (5); and DSCP (46) are default for this command)

For example, if not doing LLDP-MED, then these configurations are pretty much the same thing:

interface switchport 0/1

switchport access vlan 100

switchport voice vlan 200

interface switchport 0/1

switchport mode trunk

switchport trunk allowed vlan 100,200

switchport trunk native vlan 100

I hope this makes sense, but please do not hesitate to reply to this discussion with further questions or additional information about "voice vlans."  I will be happy to help.

Levi

View solution in original post

3 Replies
Highlighted
Anonymous
Not applicable

Re: Voice VLAN

Jump to solution

CJ:

I branched the topic of voice VLANs to a new question.

The switchport voice vlan <vlan id> [ cos <value> ] [dscp <value>] command is used for a couple specific scenarios:

1) it sets the access port to also accept tagged traffic with the specified VLAN ID

2) if the phone supports LLDP-MED, the phone should automatically switch to the specified VLAN for its traffic, as well as use the specified DSCP/COS values (CoS (5); and DSCP (46) are default for this command)

For example, if not doing LLDP-MED, then these configurations are pretty much the same thing:

interface switchport 0/1

switchport access vlan 100

switchport voice vlan 200

interface switchport 0/1

switchport mode trunk

switchport trunk allowed vlan 100,200

switchport trunk native vlan 100

I hope this makes sense, but please do not hesitate to reply to this discussion with further questions or additional information about "voice vlans."  I will be happy to help.

Levi

View solution in original post

Highlighted
Valued Contributor
Valued Contributor

Re: Voice VLAN

Jump to solution

Great info.  Learned something today 

Highlighted
Anonymous
Not applicable

Re: Voice VLAN

Jump to solution

CJ:

I marked this as "assumed answered," but feel free to reply if you have further questions on this topic.

Levi