So I ran across this today and I have played around with routers and T1's before but I need a little help here. I have 2 netvanta 3205 each with a card in them that has a t1, dsx1 and a dbu port on it. The firmware is 15.05.00. We have a point to point T1 and just trying to get the 2 routers to talk back and forth so we can transfer some audio data across it. Any help on configurations would be great i took a look at it and tried a few things but couldn't make it work.
Thank you.
I am assuming this is a standard telco provided T1 between your 2 routers. Most T1's delivered today are ESF/B8ZS line coding/framing by default. You need to match the telco coding and framing so I would recommend changing back to those settings (check with your provider as to what they should be if you aren't sure). T1 protocol can be whatever you set on the router. Remember, whatever is set on one side will need to be set on the other.
You are focused on the config or routing being an issue, but you didn't say how you determined that. When you plug the T1 into the router, does the T1 interface go into an UP/UP state? What about the PPP group? Does PPP go into an UP/UP state with LCP OPEN? Do you take any errors on the T1 interface? With incorrect coding and framing you almost definitely will take errors, so clear that up before checking for errors.
Another thing I noticed was the IP addressing. You only sent one config, but your PPP interface is setup as "192.168.1.1 255.255.255.0". Your Ethernet interface is "10.10.10.3 255.255.255.0", but you also have a route for 10.10.10.0/24 pointing to "192.168.0.1".
So first things first. I would use a /30 network for the point-to-point T1 connection. Your IP addressing on the connecting interfaces must be in the same subnet as one another. Therefore side A should be something like "192.168.1.1 255.255.255.252" and side B should be "192.168.1.2 255.255.255.252". Routes on side A going to side B should be "x.x.x.x y.y.y.y 192.168.1.2" and vice versa "z.z.z.z y.y.y.y 192.168.1.1".
As far as routable networks, you won't be able to use the same Ethernet subnet on both sides. Side A should be something like "10.10.10.x/24" and side B should be something like "10.10.11.x/24". These are examples, set this up at your discretion.
Hope this helps.
This provides a simple example of the programming of the interfaces and route tables. This configuration uses a PPP interface for the T1 connection. I hope this helps.
Router A
!
interface eth 0/1
ip address 192.168.1.1 255.255.255.0
no shutdown
!
interface t1 1/1
description P2P Router B
clock source internal
tdm-group 1 timeslots 1-24 speed 64
no shutdown
!
interface ppp 1
ip address 172.16.1.5 255.255.255.252
ip access-policy Private
qos-policy out VoIP
no shutdown
cross-connect 1 t1 1/1 1 ppp 1
!
!
ip route 192.168.2.0 255.255.255.0 ppp 1
Router B
!
interface eth 0/1
ip address 192.168.2.1 255.255.255.0
no shutdown
!
interface t1 1/1
description P2P Router A
clock source line
tdm-group 1 timeslots 1-24 speed 64
no shutdown
!
interface ppp 1
ip address 172.16.1.6 255.255.255.252
ip access-policy Private
qos-policy out VoIP
no shutdown
cross-connect 1 t1 1/1 1 ppp 1
!
!
ip route 192.168.1.0 255.255.255.0 ppp 1
Thank you very much I will give it a shot today or tomorrow and then let you know how it works.
So I was able to get those settings in to the routers but no dice but there is progress the tx and rx lights on both routers are blinking now. Any other tips or settings changes i can make to get these guys talk.
Can you send me the config files?
Sent from my Verizon Wireless 4G LTE DROID
Will do as soon as i can get them.
On Wed, Feb 12, 2014 at 11:23 AM, vmaxdawg05 <
Ok sorry for the delay its been a little hard getting to the places where these are setup here is the config. Now I have tried the different framing options and coding and the speed of the time slots to see if that will get them to start working. I think I might be looking at a routing issue or something hopefully this helps and we can get this up and working. Thank you for all the help thus far.
!
!
! ADTRAN, Inc. OS version 15.02.00
! Boot ROM version 12.02.00
! Platform: NetVanta 3205 AC, part number 1202870L1
! Serial number LBADTN0810AL362
!
!
hostname "Router"
enable password password
!
clock timezone -8
!
ip subnet-zero
ip classless
ip routing
!
no auto-config
!
event-history on
no logging forwarding
no logging email
logging email priority-level info
!
no service password-encryption
!
username "admin" password "password"
!
banner motd #
****** Important Banner Message ******
Enable and Telnet passwords are configured to "password".
HTTP and HTTPS default username is "admin" and password is "password".
Please change them immediately.
The ethernet 0/1 interface is enabled with an address of 10.10.10.1
Telnet, HTTP, and HTTPS access are also enabled.
To remove this message, while in configuration mode type "no banner motd".
****** Important Banner Message ******
#
!
ip policy-timeout tcp telnet 14400
!
no ip firewall alg msn
no ip firewall alg h323
!
!
!
!
!
!
!
!
ip dhcp-server excluded-address 10.10.10.0 10.10.10.3
ip dhcp-server excluded-address 10.10.10.26 10.10.10.255
!
ip dhcp-server pool "Private"
network 10.10.10.0 255.255.255.0
netbios-node-type h-node
default-router 10.10.10.3
!
!
!
interface eth 0/1
ip address 10.10.10.3 255.255.255.0
no shutdown
!
!
!
!
interface t1 1/1
description Studio
framing d4
clock source internal
coding ami
tdm-group 1 timeslots 1-24 speed 56
no shutdown
!
interface t1 1/2
line-length 0
shutdown
!
interface ppp 1
ip address 192.168.1.1 255.255.255.0
no shutdown
cross-connect 1 t1 1/1 1 ppp 1
!
!
!
!
!
!
ip access-list extended web-acl-1
remark any:4444 -> 192.168.1.4:4444
permit tcp any eq 4444 192.168.1.0 0.0.0.255 eq 4444 log
!
ip policy-class "Audio Stream"
nat source list web-acl-1 interface eth 0/1 overload
!
!
!
ip route 10.10.10.0 255.255.255.0 192.168.0.1
!
no ip tftp server
no ip tftp server overwrite
ip http server
ip http secure-server
no ip snmp agent
no ip ftp server
no ip scp server
no ip sntp server
!
!
!
!
!
!
!
line con 0
no login
!
line telnet 0 4
login
password password
no shutdown
line ssh 0 4
login local-userlist
no shutdown
!
!
end
I am assuming this is a standard telco provided T1 between your 2 routers. Most T1's delivered today are ESF/B8ZS line coding/framing by default. You need to match the telco coding and framing so I would recommend changing back to those settings (check with your provider as to what they should be if you aren't sure). T1 protocol can be whatever you set on the router. Remember, whatever is set on one side will need to be set on the other.
You are focused on the config or routing being an issue, but you didn't say how you determined that. When you plug the T1 into the router, does the T1 interface go into an UP/UP state? What about the PPP group? Does PPP go into an UP/UP state with LCP OPEN? Do you take any errors on the T1 interface? With incorrect coding and framing you almost definitely will take errors, so clear that up before checking for errors.
Another thing I noticed was the IP addressing. You only sent one config, but your PPP interface is setup as "192.168.1.1 255.255.255.0". Your Ethernet interface is "10.10.10.3 255.255.255.0", but you also have a route for 10.10.10.0/24 pointing to "192.168.0.1".
So first things first. I would use a /30 network for the point-to-point T1 connection. Your IP addressing on the connecting interfaces must be in the same subnet as one another. Therefore side A should be something like "192.168.1.1 255.255.255.252" and side B should be "192.168.1.2 255.255.255.252". Routes on side A going to side B should be "x.x.x.x y.y.y.y 192.168.1.2" and vice versa "z.z.z.z y.y.y.y 192.168.1.1".
As far as routable networks, you won't be able to use the same Ethernet subnet on both sides. Side A should be something like "10.10.10.x/24" and side B should be something like "10.10.11.x/24". These are examples, set this up at your discretion.
Hope this helps.
Well guys I think I got it decided to bring both routers to my shop used a t1 crossover cable between them. With all the info you guys gave to me I was able to get them both to talk and was able to ping machines on the other end of each router. Going to put them back in the field today or tomorrow wish I could mark all of the responses as correct answers. They all helped very much thank you again.