cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
jessepdx
New Contributor II

Netvanta 3430 DHCP Relay

Jump to solution

i just bought a netvanta 3430 Gen 2 with the understanding it does DHCP Relay

when i type the command IP DHCP RELAY ?

i get

% Unrecognized command

this page says it does it: https://www.adtran.com/web/page/portal/Adtran/product/1202820G1/118

what am i doing wrong?

Labels (1)
Tags (2)
1 Solution

Accepted Solutions
vmaxdawg05
Contributor III
Contributor III

Re: Netvanta 3430 DHCP Relay

Jump to solution

The relay command is done at the interface programming level.

Try going into global config first:

type: configure terminal <Enter>

AIP 3430 Router(config)#

Then, select the interface that you want to relay the DHCP requests from (i.e. Eth 0/1, Eth 0/2).

Example for relaying requests broadcasted on eth 0/1:

AIP 3430 Router(config)# interface eth 0/1 <enter>

AIP 3430 Router(config-intf-eth 0/1)#

then type IP DHCP RELAY DESTINATION 192.168.0.199 <enter>

this will relay any dhcp requests seen on interface eth 0/1 to 192.168.0.199.

You can put this in each interface that will rely on a remote dhcp server.

View solution in original post

0 Kudos
12 Replies
vmaxdawg05
Contributor III
Contributor III

Re: Netvanta 3430 DHCP Relay

Jump to solution

there are a couple of ways to achieve DHCP relay in the NetVanta 3400 series routers.

With the newer versions of firmware, it is easy to do  You won't find a means of doing it with the web GUI. Use the CLI.

Example of interface configured to relay dhcp requests to a dhcp server:

interface ethernet 0/2

description LAN

ip address 192.168.1.1 255.255.255.0

ip dhcp relay destination <address of remote DHCP server>

no shutdown

Keep in mind that if a firewall is running, you may need to configure the firewall to allow the relaying of those dhcp packets (UDP 67,68).

R\

jessepdx
New Contributor II

Re: Netvanta 3430 DHCP Relay

Jump to solution

i'm running R10.0.0.E latest firmware

as i said in the post

aip 3430 router#ip dhcp relay 192.168.0.199

% Unrecognized command

when i query for possible command with the "?"

AIP 3430 Router(config)#ip dhcp ?

database - Configure a DHCP database agent

excluded-address - Configure DHCP address exclusions

ping - Configure DHCP ping parameters

pool - Configure a DHCP server address pool

AIP 3430 Router(config)#

relay isn't there

On Wed, Sep 11, 2013 at 12:23 PM, vmaxdawg05 <

vmaxdawg05
Contributor III
Contributor III

Re: Netvanta 3430 DHCP Relay

Jump to solution

The relay command is done at the interface programming level.

Try going into global config first:

type: configure terminal <Enter>

AIP 3430 Router(config)#

Then, select the interface that you want to relay the DHCP requests from (i.e. Eth 0/1, Eth 0/2).

Example for relaying requests broadcasted on eth 0/1:

AIP 3430 Router(config)# interface eth 0/1 <enter>

AIP 3430 Router(config-intf-eth 0/1)#

then type IP DHCP RELAY DESTINATION 192.168.0.199 <enter>

this will relay any dhcp requests seen on interface eth 0/1 to 192.168.0.199.

You can put this in each interface that will rely on a remote dhcp server.

View solution in original post

0 Kudos
jessepdx
New Contributor II

Re: Netvanta 3430 DHCP Relay

Jump to solution

that did it!

thank you

vmaxdawg05
Contributor III
Contributor III

Re: Netvanta 3430 DHCP Relay

Jump to solution

Great. Please mark the question as “Answered”.

Thanks

R\

eric_granite
New Contributor II

Re: Netvanta 3430 DHCP Relay

Jump to solution

I have a somewhat related question.  I have a router with two DHCP pools; one for voice and one for data.  I want to keep the DHCP pool for voice but use a relay agent to forward DHCP request to another location.  When I type the following commands:

ip forward-protocol udp domain

ip forward-protocol udp bootps

I get an error saying I can't enter these commands because there is an internal DHCP server running already.  So does that mean that it is impossible to have an internal DHCP server for on VLAN and relay DHCP request for another VLAN at the same time?  (I'm using a 3448 by the way)

vmaxdawg05
Contributor III
Contributor III

Re: Netvanta 3430 DHCP Relay

Jump to solution

This is what I find easiest.

On the interface that you want relay DHCP, issue the following (using VLAN 1 for demo purposes):

Interface VLAN 1

ip address X.X.X.X 255.255.255.0

No shutdown

ip dhcp relay destination

This is a feature that was added a year ago or so that makes life so much easier.

Hope this helps.

R\

eric_granite
New Contributor II

Re: Netvanta 3430 DHCP Relay

Jump to solution

Oh, ok.  So you are saying that this should be allowed even though a DHCP pool exists on the router already?  I will try that out and see if it works.

Thanks!

vmaxdawg05
Contributor III
Contributor III

Re: Netvanta 3430 DHCP Relay

Jump to solution

Yes,

When the router has one or more DHCP pools, it listens on all interfaces for DHCP requests. If an interface’s network is not one of the scopes, it will not be able to assign an address to any hosts on that network. The “ip dhcp relay destination” statement in the interface causes the router to forward those requests to the address specified rather than check it’s own pools for processing the DHCP request.

This way you can provide DHCP for some interfaces, but relay for others.

R\

vmaxdawg05
Contributor III
Contributor III

Re: Netvanta 3430 DHCP Relay

Jump to solution

Let me elaborate on that a little. If you have a matching pool (same network and subnet), then that would present a problem. I’m not sure what scenario would require that though. Ideally, only have pools for the network you want to provide DHCP on.

An example would be that you have two networks (VLAN 1 and VLAN 2). You want to provide DHCP for VLAN 2, but relay for VLAN 1. Only maintain dhcp pool for that network on the router.

ip dhcp pool voice

Network 192.168.2.0 255.255.255.0

default-router 192.168.2.1

dns-server 8.8.8.8 4.2.2.2

domain-name mynetwork.voice

Interface vlan 1

description Data LAN

ip address 192.168.1.1 255.255.255.0

access-policy Private

ip dhcp relay destination 192.168.1.100 (address of DHCP server)

no shutdown

Interface vlan 2

Description Voice LAN

ip address 192.168.2.1 255.255.255.0

access-policy Private

no shutdown

eric_granite
New Contributor II

Re: Netvanta 3430 DHCP Relay

Jump to solution

No, thank you very much.  I understood exactly what you were saying.  We have a DATA vlan and a VOICE vlan.  We want to continue to have the voice gateway (DHCP pool and SVI) on the router but we want to take the DATA DHCP off of that router (remove the pool) and relay it to a different location.  Based on what I had tried before, it seemed to be impossible on an Adtran, but it looks like it's doable according to this new command (which I didn't know about).  I'm going to test this out today... I hope the AOS I'm using supports it.  Your example above fits my situation perfectly.  I understand everything else about the configuration, I just didn't know that command existed.

Thanks again!

vmaxdawg05
Contributor III
Contributor III

Re: Netvanta 3430 DHCP Relay

Jump to solution

I’ve used this setting a lot in installations I do. Usually, my customer has a DHCP server on their network, but I want to control DHCP for my voice installation. I configure the Adtran router or switch to provide DHCP for the voice, and relay for the data network. Works pretty well.

R\