Forgive my ignorance, but our company just got everything setup with a netvanta 4305 router and for the life of me I cannot get this thing to assign ip addresses through dhcp. I followed the steps in the "Configuring DHCP" pdf, however I feel as though I am missing something. I set up the pool and according to the guide that is all that is needed, however no linux based computer, windows based computer, or VOIP phone will receive an IP address. What am I doing wrong?
Try assigning a netbios-node-type to the Pool:
ip dhcp-server pool "Local PCs"
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
netbios-node-type h-node
dns-server xxx.xxx.xxx.xxx
You can then add other parameters such as DNS servers, NTP servers, etc. The netbios-node-type h-node is the hybrid node and is recommended by Adtran to use.
Also your default router has to be an interface on the Adtran if you want it to supply the DHCP.
interface eth 0/2
ip address dhcp hostname "Router" (change to ip address 192.168.1.1 255.255.255.0 if possible)
no shutdown
Then anything with access to eth 0/2 will use the default router to obtain DHCP.
is right; however, for the ADTRAN device to be the DHCP server, it doesn't HAVE to be the default router, but it must have an interface assigned in that subnet to know where to deliver IP addresses.
For example, if you would like the AOS device to deliver addresses in the 192.168.1.0 /24 subnet, then the AOS device must have an interface in the 192.168.1.0 /24 subnet (Ethernet 0/2 in the example below).
ip dhcp-server pool "Local_PCs"
network 192.168.1.0 255.255.255.0
!
interface eth 0/2
ip address 192.168.1.x 255.255.255.0
no shutdown
If you would also like the AOS device to be the default-gateway for the PCs on the network, then the default-router <ip address> command in the DHCP pool must match the AOS device's IP address. Below is an example of the AOS device delivering DHCP addresses in the 192.168.1.0 /24 subnet, and sending itself as the PC's default-gateway:
ip dhcp-server pool "Local_PCs"
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
!
interface eth 0/2
ip address 192.168.1.1 255.255.255.0
no shutdown
Please, let me know if you still have questions. I will be happy to help.
Levi
I went ahead and flagged this post as “Assumed Answered.” If any of the responses on this thread assisted you, please mark them as either Correct or Helpful answers with the applicable buttons. This will make them visible and help other members of the community find solutions more easily. If you still need assistance, I would be more than happy to continue working with you on this - just let me know in a reply.
Levi