Showing results for 
Show  only  | Search instead for 
Did you mean: 
New Contributor

Windows DHCP Server indicates that all IPs are unavailable and assigned to the MAC of the Eth0/1 interface on Adtran 5305.

I have been having an odd issue which I've been beating on for several days now during a transition from a Class B to Class A network:

4 of the 5 scopes in my Windows DHCP Server are filling up with BAD_ADDRESS. When I check the event logs of any of the client machines, I find event 4199: The system detected an address conflict for IP address X.X.X.X with the system having the network hardware address 00-A0-C8-XX-XX-XX.

I have tracked down that MAC as belonging to the Ethernet 0/1 interface on my Adtran 5305 router, which does not have an IP assigned to it as it is trunking 802.1q. I've tried to arbitrarily assign it an address, but the AOS cli tells me very politely that the interface cannot currently be assigned an IP (presumably because of its trunking role).

Other research led me to believe that I might have created a bridge loop with my wireless access points. However, to the dismay of my organization, I have turned off the WAPs in an attempt to isolate the issue and the situation remains. Any attempt to pull a DHCP address from any scope results in BAD_ADDRESS in the DHCP server and the aforementioned entry in the client event logs.

I have used DHCP filters in an attempt to prevent the Eth0/1 MAC from "getting" these addresses. I have attempted to add my client workstations and IP phones as reservations. I have tried to use static IPs. All DHCP-related efforts result in BAD_ADDRESS and event 4199, with the Eth0/1 MAC. All efforts to statically assign IPs has resulted in event 4199 and APIPA addresses on client machines.

The only way I have able to get DHCP to cooperate is to disconnect the Ethernet 0/1 interface, which, of course, has dire consequences for my communications through the router.

I am at a complete loss and am hoping that someone here can help shed some light, or at the very least, help point me in the right direction.

Thank you,


0 Kudos
1 Reply

Re: Windows DHCP Server indicates that all IPs are unavailable and assigned to the MAC of the Eth0/1 interface on Adtran 5305.

Just in case someone stumbles across this, I determined that an active VLAN sub-interface of the Eth0/1 interface was the culprit in my case. The interVLAN router is all being handled by Layer 3 switches downstream from the router, so the VLAN sub-interfaces are unnecessary on the router. I disabled the sub-interface on the router and, just like magic, DHCP stopped giving me BAD_ADDRESS and Windows clients stopped throwing error 4199 regarding the MAC of the router Eth0/1 interface.