cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
bascheew
New Contributor II

Transparent SIP Proxy not working

I have configured a 6310 router for transparent SIP proxy using this document for the purpose of survivability to a local FXO port.  When I run the command "show sip proxy registration" there aren't any phones listed even though I have phones that sit behind this router that are successfully registered to the hosted PBX.  The hosted PBX is not running on the standard SIP port and could use either TCP/UDP 8060 as well as UDP 5090.  I added those ports to the SIP server on the router without any change in results.  Any ideas on what I can do to troubleshoot this?  Thanks in advance!


domain-proxy
domain-proxy failover
domain-lookup database local
name-server 208.67.222.222 8.8.8.8 208.67.220.220
!
ip firewall
no ip firewall alg msn
no ip firewall alg mszone
no ip firewall alg h323
!
ip dhcp pool "Voice"
  network 10.140.11.0 255.255.255.0
  dns-server 10.140.11.1 208.67.222.222 8.8.8.8
  default-router 10.140.11.1
!
interface eth 0/1
  encapsulation 802.1q
  no shutdown
!
interface eth 0/1.100
  description Voice VLAN
  vlan-id 100
  ip address  10.140.11.1  255.255.255.0
  media-gateway ip primary
  no shutdown
!
interface eth 0/2
  ip address  10.10.20.118  255.255.255.0
  media-gateway ip primary
  no shutdown
!
sip
sip udp 5090
sip udp 8060
sip tcp 8060
no sip tls
!
voice trunk T01 type analog supervision loop-start
  description "FXO"
  connect fxo 1/1
  connect fxo 1/2
  connect fxo 1/3
  connect fxo 1/4
  rtp delay-mode adaptive
!
voice grouped-trunk FXO
  trunk T01
  accept 911 cost 0
  accept 9NXX-XXXX cost 0
  accept 9NXX-NXX-XXXX cost 0
!
sip proxy
sip proxy transparent
!
sip proxy failover accept-registrations
sip proxy failover match-digits 4
!


Labels (1)
0 Kudos
2 Replies
bascheew
New Contributor II

Re: Transparent SIP Proxy not working

I just wanted to report that I rebooted the router and after that SIP registrations started to appear just fine!

david
Valued Contributor
Valued Contributor

Re: Transparent SIP Proxy not working

Mr. Scheewe,

You shouldn't need to reboot the unit for SIP proxy to work properly.  However, if you make changes to the UDP ports the phones are using, or change listening ports on the ADTRAN unit, you might need to clear the SIP proxy and reboot the phones, or otherwise get the phones to send a new SIP registration.  Please let ADTRAN know if you are having any further issues getting phone registrations to populate the SIP proxy database. 

Thanks!

David