cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
New Contributor

2 outbound caller id's on a PRI and removing 9 from FXS 0/1 (fax)

Adtran 7100 R11.4.5.E

I have a PRI that I want to have the primary outbound caller ID to be "xxxxxx4400" and that works, I also have a DID coming in that points to the to FXS 0/1 to a fax machine.

Can 2001 (fxs0/1) have a outbound caller id?

Internal works, but outbound doesn't.

voice trunk T01 type isdn

  description "PRI"

  resource-selection circular descending

  caller-id-override emergency-outbound match-substitute

  connect isdn-group 1

  match ani "XXX" substitute "xxxxxx4400" name "Des"

  match ani "2001" substitute "xxxxxx4417" name "Fax"

  plc

  rtp delay-mode adaptive



voice user 2001

  connect fxs 0/1

  cos "public_phones"

  first-name "Analog FXS"

  last-name "Port 0/1"

  password encrypted "3632c4555bae3c30d946651decec5e91b7ef"

  description "Fax xxxxxx4417"

  no call-waiting

  caller-id-override emergency-number xxxxxx4417

  caller-id-override external-name Fax

  caller-id-override external-number xxxxxx4417

  caller-id-override internal-name Fax

  caller-id-override internal-number xxxxxx4417

  did "xxxxxx4417"

  sip-authentication password encrypted "383c1b9e2f18b569b1350b96da4ae62fc205"

  codec-list g711_first

  no directory-include

  voicemail password encrypted "2622b51652bff45f7015d5cace18e9162d35"

  voicemail notify schedule Sunday 12:00 am

Labels (2)
0 Kudos
8 Replies
Highlighted
Valued Contributor
Valued Contributor

Re: 2 outbound caller id's on a PRI and removing 9 from FXS 0/1 (fax)

Dan, there shouldn't be any issues with doing that. Can you please post the full config with any passwords and public IPs scrubbed? Thanks

Jay

Highlighted
New Contributor

Re: 2 outbound caller id's on a PRI and removing 9 from FXS 0/1 (fax)

!

!

! ADTRAN, Inc. OS version R11.4.5.E

! Boot ROM version A2.06.B2.01

! Platform: NetVanta 7100, part number 1200796E1

! Serial number LBADT

!

!

hostname "xxdown"

enable password encrypted 1c16e6f2c0bc89cf2bac25b7f8c7076837d1

!

clock timezone -7-Mountain-Time

!

ip subnet-zero

ip classless

ip default-gateway xx.xx.xx.xx

ip routing

ipv6 unicast-routing

host "mail.xxdown.com" xx.xx.xx.xx

domain-name "xx.com"

domain-proxy

name-server xx.xx.xx.xx xx.xx.xx.xx

!

!

no auto-config

!

event-history on

no logging forwarding

logging email on

logging email receiver-ip smtp.c.net port 465 auth-username

logging email sender

!

!

service password-encryption

!

portal-list "phones" ftp

!

username "admin" privilege 7 password encrypted

!

!

ip firewall

ip firewall stealth

no ip firewall alg msn

no ip firewall alg mszone

no ip firewall alg h323

!

!

!

!

!

!

!

!

!

!

!

no dot11ap access-point-control

!

!

!

!

!

!

!

ip dhcp database local

ip dhcp excluded-address 10.10.20.2

ip dhcp excluded-address 10.10.10.2 10.10.10.5

!

ip dhcp pool "wizard_voice_pool"

  network 10.10.20.0 255.255.255.0

  dns-server 10.10.20.254 10.10.20.1

  netbios-node-type h-node

  default-router 10.10.20.254

  tftp-server ftp://polycomftp:password@10.10.20.254/Polycom

  ntp-server 10.10.20.254

  timezone-offset -7:00

  option 157 ascii TftpServers=0.0.0.0,FtpServers=10.10.20.254:/ADTRAN,FtpLogin=polycomftp,FtpPassword=password,Layer2Tagging=True,VlanID=2

!

ip dhcp pool "Data Pool"

  network 10.10.10.0 255.255.255.0

  dns-server 10.10.10.1

  default-router 10.10.10.1

  tftp-server ftp://polycomftp:password@10.10.10.1/Polycom

  ntp-server 10.10.10.1

  timezone-offset -7:00

  option 157 ascii TftpServers=0.0.0.0,FtpServers=10.10.20.1:/ADTRAN,FtpLogin=polycomftp,FtpPassword=password,Layer2Tagging=True,VlanID=2

  option 66 ascii "      ftp://polycomftp:password@10.10.20.1/polycom"

!

!

!

!

!

!

!

ip crypto

!

crypto ike policy 102

  initiate main

  respond anymode

  local-id fqdn xxdown

  peer xxx.xxx.xxx.xxx

  attribute 1

    encryption 3des

    hash md5

    authentication pre-share

!

crypto ike policy 103

  initiate main

  respond anymode

  local-id fqdn xxdown

  peer 75.70.134.120

  attribute 1

    encryption 3des

    hash md5

    authentication pre-share

!

crypto ike remote-id fqdn xx

!

!

ip crypto ipsec transform-set esp-3des-esp-md5-hmac esp-3des esp-md5-hmac

  mode tunnel

!

ip crypto map VPN xx

!

!

!

!

vlan 1

  name "Default"

!

vlan 2

  name "wizard_generated_vlan_2"

!

!

interface loop 1

  description Maint Paging

  ip address  10.10.20.1  255.255.255.255

  ip access-policy Private

  no shutdown

!

interface eth 0/0

  description Public Wan

  ip address  xx.xx.xx.xx xxx.xxx.xxx.xxx

  ip mtu 1500

  ip access-policy Public

  ip crypto map VPN

  media-gateway ip loopback 1

  no shutdown

  no lldp send-and-receive

!

!

interface eth 0/1

  spanning-tree edgeport

  no shutdown

  switchport mode trunk

!

!

interface eth 0/2

  spanning-tree edgeport

  no shutdown

  switchport mode trunk

!

!

interface eth 0/3

  spanning-tree edgeport

  no shutdown

  switchport mode trunk

!

!

interface eth 0/4

  spanning-tree edgeport

  no shutdown

  switchport mode trunk

!

!

interface eth 0/5

  spanning-tree edgeport

  no shutdown

  switchport mode trunk

!

!

interface eth 0/6

  spanning-tree edgeport

  no shutdown

  switchport mode trunk

!

!

interface eth 0/7

  spanning-tree edgeport

  no shutdown

  switchport mode trunk

!

!

interface eth 0/8

  spanning-tree edgeport

  no shutdown

  switchport mode trunk

!

!

interface eth 0/9

  spanning-tree edgeport

  no shutdown

  switchport mode trunk

!

!

interface eth 0/10

  spanning-tree edgeport

  no shutdown

  switchport mode trunk

!

!

interface eth 0/11

  spanning-tree edgeport

  no shutdown

  switchport mode trunk

!

!

interface eth 0/12

  spanning-tree edgeport

  no shutdown

  switchport mode trunk

!

!

interface eth 0/13

  spanning-tree edgeport

  no shutdown

  switchport mode trunk

!

!

interface eth 0/14

  spanning-tree edgeport

  no shutdown

  switchport mode trunk

!

!

interface eth 0/15

  spanning-tree edgeport

  no shutdown

  switchport mode trunk

!

!

interface eth 0/16

  spanning-tree edgeport

  no shutdown

  switchport mode trunk

!

!

interface eth 0/17

  spanning-tree edgeport

  no shutdown

  switchport mode trunk

!

!

interface eth 0/18

  spanning-tree edgeport

  no shutdown

  switchport mode trunk

!

!

interface eth 0/19

  spanning-tree edgeport

  no shutdown

  switchport mode trunk

!

!

interface eth 0/20

  spanning-tree edgeport

  no shutdown

  switchport mode trunk

!

!

interface eth 0/21

  spanning-tree edgeport

  no shutdown

  switchport mode trunk

!

!

interface eth 0/22

  spanning-tree edgeport

  no shutdown

  switchport mode trunk

!

!

interface eth 0/23

  spanning-tree edgeport

  no shutdown

  switchport mode trunk

!

!

interface eth 0/24

  spanning-tree edgeport

  no shutdown

  switchport mode trunk

!

!

!

interface gigabit-eth 0/1

  description Tie to Switch 10.10.10.2

  spanning-tree edgeport

  no shutdown

  switchport mode trunk

!

!

interface gigabit-eth 0/2

  spanning-tree edgeport

  no shutdown

  switchport mode trunk

!

!

!

!

interface vlan 1

  description wizard generated vlan 1

  ip address  10.10.10.1  255.255.255.0

  ip access-policy Private

  media-gateway ip primary

  no shutdown

!

interface vlan 2

  description wizard generated vlan 2

  ip address  10.10.20.254  255.255.255.0

  ip mtu 1500

  ip access-policy Private

  no rtp quality-monitoring

  media-gateway ip loopback 1

  no shutdown

!

!

interface t1 1/1

  description Comcast PRI

  system-timing primary

  tdm-group 1 timeslots 1-24 speed 64

  no shutdown

!

!

interface pri 1

  description pri 1

  connect t1 1/1 tdm-group 1

  no shutdown

!

!

interface fxs 0/1

  description "xxxxxxxx17"

  no shutdown

!

interface fxs 0/2

  no shutdown

!

!

interface fxo 0/1

  description "Analog FXO 0/1  xx.xx.xx.xx"

  impedance z1

  shutdown

!

interface fxo 0/2

  shutdown

!

!

isdn-group 1

  connect pri 1

!

!

isdn-group 2

!

!

isdn-group 3

!

!

isdn-group 4

  min-channels 24

  max-channels 24

  connect pri 1

!

isdn-number-template 1 prefix "" subscriber NXX-XXXX

isdn-number-template 2 prefix "" national NXX-NXX-XXXX

isdn-number-template 3 prefix 011 international X$

isdn-number-template 4 prefix "" unknown NXX

isdn-number-template 5 prefix "" unknown NXXX

isdn-number-template 6 prefix 1 national NXX-NXX-XXXX

!

!

!

!

!

!

ip access-list standard NAT

  remark NAT list NAT

  permit any

!

!

ip access-list extended self

  remark Traffic to NetVanta

  permit ip any  any     log

!

ip access-list extended VPN-30-vpn-selectors

  permit ip 10.10.20.0 0.0.0.255  10.10.21.0 0.0.0.255   

!

ip access-list extended VPN-40-vpn-selectors

  permit ip 10.10.20.0 0.0.0.255  10.10.22.0 0.0.0.255   

!

ip access-list extended web-acl-10

  remark adtran

  permit tcp host 76.164.174.115  any eq https   log

  permit tcp host 76.164.174.115  any eq ssh   log

!

ip access-list extended web-acl-11

  remark Marti Admin Access

  permit tcp host 50.232.247.162  any eq https   log

!

ip access-list extended web-acl-13

  remark Admin Access

xx

!

ip access-list extended web-acl-8

  remark Traffic to Netvanta

  permit ip any  any     log

!

ip access-list extended web-acl-9

  remark To Maint 908e

  permit tcp host xx  any eq https   log

  permit tcp host xx  any eq ssh   log

!

!

!

!

ip policy-class Private

  allow list VPN-40-vpn-selectors stateless

  allow list VPN-30-vpn-selectors stateless

  allow list self self

  nat source list wizard-ics interface eth 0/0 overload

  allow list web-acl-8 self

  allow list web-acl-11 self

!

ip policy-class Public

  allow reverse list VPN-40-vpn-selectors stateless

  allow reverse list VPN-30-vpn-selectors stateless

  allow list web-acl-13 self

  allow list web-acl-9 self

  allow list web-acl-10 self

!

!

!

tftp server

tftp server overwrite

tftp server default-filesystem cflash

http server

http session-timeout 4200

http secure-server

snmp agent

ip ftp server

ip ftp server default-filesystem cflash

no ip scp server

ip sntp server

ip sntp server send-unsynced

!

!

!

!

!

!

!

!

!

sip

sip udp 5060

sip tcp 5060

!

!

!

voice overhead-paging extension 899

voice park-return 45

!

!

!

!

!

!

!

!

voice system-mode default monday 08:00

voice system-mode night monday 17:00

voice system-mode default tuesday 08:00

voice system-mode night tuesday 17:00

voice system-mode default wednesday 08:00

voice system-mode night wednesday 17:00

voice system-mode default thursday 08:00

voice system-mode night thursday 17:00

voice system-mode default friday 08:00

voice system-mode night friday 17:00

!

!

!

voice timeouts named-digit-timeout digit_timeout 4

!

voice timeouts named-digit-timeout ext-3-sec 3

!

voice dial-plan 0 local NXX-NXX-XXXX

voice dial-plan 1 internal-operator 0

voice dial-plan 3 extensions MXX ext-3-sec

voice dial-plan 4 local 9-NXX-XXX-XXXX

voice dial-plan 5 long-distance 9-1-NXX-NXX-XXXX

voice dial-plan 6 toll-free 9-1-800-NXX-XXXX

voice dial-plan 7 toll-free 9-1-888-NXX-XXXX

voice dial-plan 8 toll-free 9-1-877-NXX-XXXX

voice dial-plan 9 toll-free 9-1-866-NXX-XXXX

voice dial-plan 10 operator-assisted 9-0-NXX-NXX-XXXX

voice dial-plan 11 international 9-011-$

voice dial-plan 12 900-number 9-1-900-NXX-XXXX

voice dial-plan 13 900-number 9-1-976-NXX-XXXX

voice dial-plan 14 900-number 9-976-XXXX

voice dial-plan 15 extensions [1-8]XXX

voice dial-plan 16 local 811

voice dial-plan 17 extensions [1-8]XX

voice dial-plan 18 local 1-NXX-NXX-XXXX

!

!

xxxxx

!

!

voice class-of-service normal_users

  override-passcode 6789

  default-level

  aa-dnd

  block-caller-id

  call-privilege extensions

  call-privilege local

  call-privilege long-distance

  call-privilege operator-assisted

  call-privilege specify-carrier

  call-privilege toll-free

  camp-on

  disable-callwaiting

  dnd

  door-phone

  external-fwd

  forward

  hold

  hotel

  logout-group

  logout-queue

  message-waiting

  overhead-paging

  park

  pickup

  program-user-speed

  redial

  remote-fwd

  retrieve-park

  return-last-call

  send-to-vm

  station-lock

  system-mode

  system-speed

  transfer

  user-speed

!

voice class-of-service public_phones

  override-passcode 1234

  call-privilege extensions

  call-privilege local

  call-privilege long-distance

  call-privilege toll-free

!

voice class-of-service "Fax Machine"

  override-passcode 6417

  call-privilege extensions

  call-privilege local

  call-privilege long-distance

  call-privilege specify-carrier

  call-privilege toll-free

  redial

!

voice codec-list g711_first

  default

  codec g711ulaw

  codec g729

!

!

!

voice trunk access-code none

!

!

!

voice trunk T01 type isdn

  description "PRI"

  resource-selection circular descending

  caller-id-override emergency-outbound match-substitute

  connect isdn-group 1

  match ani "XXX" substitute "xxxxxxxx00" name "xxdown"

  match ani "2001" substitute "xxxxxxxx17" name "xxFax"

  plc

  rtp delay-mode adaptive

!

voice trunk T03 type sip

  description "Maint Paging"

  sip-server primary 10.10.21.1

!

!

voice grouped-trunk PRI_TRUNKS

  trunk T01

  accept NXX-NXX-XXXX cost 0

  accept 1-NXX-NXX-XXXX cost 0

  accept 1-800-NXX-XXXX cost 0

  accept 1-888-NXX-XXXX cost 0

  accept 1-877-NXX-XXXX cost 0

  accept 1-866-NXX-XXXX cost 0

  accept 1-855-NXX-XXXX cost 0

  accept 011-$ cost 0

  accept 411 cost 0

  accept 611 cost 0

  accept 911 cost 0

  accept 0-NXX-NXX-XXXX cost 0

  accept 10-10-XXX-$ cost 0

  accept 811 cost 0

  reject NXX-976-XXXX

  reject 1-900-NXX-XXXX

  reject 1-976-NXX-XXXX

  reject 1-NXX-976-XXXX

!

!

voice grouped-trunk ANALOG69

  accept NXX-NXX-XXXX cost 200

  accept 1-NXX-NXX-XXXX cost 200

  accept 1-800-NXX-XXXX cost 200

  accept 1-888-NXX-XXXX cost 200

  accept 1-877-NXX-XXXX cost 200

  accept 1-866-NXX-XXXX cost 200

  accept 1-855-NXX-XXXX cost 200

  accept 011-$ cost 200

  accept 411 cost 200

  accept 611 cost 200

  accept 911 cost 200

  accept 0-NXX-NXX-XXXX cost 0

  accept 10-10-XXX-$ cost 200

  accept 811 cost 5

  reject 976-XXXX

  reject NXX-976-XXXX

  reject 1-900-NXX-XXXX

  reject 1-976-NXX-XXXX

  reject 1-NXX-976-XXXX

!

voice autoattendant "After Hours AA" extension 821

  description "After Hours Auto Attendant"

  entry-filename "aa821.xml"

!

voice autoattendant "DefaultAA" extension 820

  entry-filename "wizardAA.xml"

!

!

voice directory "SYSTEM"

  description "The system directory"

!

voice directory "Sys Ext"

!

voice coverage go_to_voicemail

  default

  coverage  vm

!

!

voice mail extension 850

!

voice mail leave-extension 840

!

voice mail max-login-attempts 3

!

!

voice mail class-of-service normal_voicemail

  default-level

  message-quota 30

  prompt-delete

!

!

!

voice ring-option "System Default"

  description "System default ring option"

  ring-type immediate

!

!

voice paging-group 503

  description "Inside Paging"

  no shutdown

  member 300

  member 301

  member 302

  member 304

  member 305

  member 306

  member 307

  member 308

  member 309

  member 310

  member 311

  member 312

  member 313

  member 314

  member 316

  member 317

  member 318

  member 320

  member 321

  member 323

  member 324

  member 325

  member 327

!

!

voice paging-group 504

  description "Inside Maint Page"

  no shutdown

  member 207

  member 215

  member 222

  member 226

!

!

voice paging-group 505

  description "Inside Nusery Page"

  shutdown

  member 550

!

!

voice paging-group 506

  description "Operator Paging"

  no shutdown

  member 207

  member 226

  member 307

  member 310

  member 311

  member 313

  member 316

  member 317

  member 327

!

voice status-group "All"

  user xx

!

!

voice status-group "CallPark"

  park-zone 0

  park-zone 1

  park-zone 2

  park-zone 3

  park-zone 4

  park-zone 5

  park-zone 6

  park-zone 7

  park-zone 8

  park-zone 9

!

!

xx

!

!

!

!

voice music-on-hold player System

  default

  file 5 ALittleNightMusic.wav

!

!

voice music-on-hold player System2

!

!

!

sip authenticate

!

!

!

sip registrar

!

!

!

!

!

!

!

!

sip database local

!

!

!

!

line con 0

  no login

!

line telnet 0 4

  login local-userlist

  no shutdown

line ssh 0 4

  login local-userlist

  no shutdown

!

sntp server time.nist.gov

!

!

!

!

monitor session 1 destination interface ethernet 0/1 no-isolate

!

!

end

!

configure terminal

!

!

!

!

voice user 2000

  connect sip

  first-name "Default"

  last-name "IP Phone"

  password encrypted "181c8d3fd9b54b7bcc7f4b1142c4e4b2371d"

  group-ring-call-waiting

  sip-authentication password encrypted "1e1aa742c2891bd23ae4dfcabae276c7347e"

  codec-list g711_first both

  no directory-include

  voicemail auth-mode password

  voicemail password encrypted "1d19ceda69a42a9bef9c14274072fd1ae35b"

  voicemail notify schedule Sunday 12:00 am

!

!

!

voice user 2001

  connect fxs 0/1

  cos "Fax Machine"

  first-name "Analog FXS"

  last-name "Port 0/1"

  password encrypted "3632c4555bae3c30d946651decec5e91b7ef"

  description "Fax xxxxxxxx17"

  no call-waiting

  caller-id-override emergency-number xxxxxxxx17

  caller-id-override external-name xxFax

  caller-id-override external-number xxxxxxxx17

  caller-id-override internal-name xxFax

  caller-id-override internal-number xxxxxxxx17

  did "xxxxxxxx17"

  speed-dial 1 97203633966 dan

  speed-dial 2 17203633966 dan 2

  sip-authentication password encrypted "383c1b9e2f18b569b1350b96da4ae62fc205"

  codec-list g711_first

  no directory-include

  voicemail password encrypted "2622b51652bff45f7015d5cace18e9162d35"

  voicemail notify schedule Sunday 12:00 am

!

!

!

voice user 2002

  connect fxs 0/2

  cos "normal_users"

  first-name "Analog FXS"

  last-name "Port 02"

  password encrypted "383c1b9e2f18b569b1350b96da4ae62fc205"

  group-ring-call-waiting

  coverage global go_to_voicemail

  sip-authentication password encrypted "2232c40ed8d55bdc6fe6385d97a4e1dd3284"

  no directory-include

  voicemail auth-mode password

  voicemail password encrypted "15116ef4fba078a29de5f22184e0a21588ac"

  voicemail notify schedule Sunday 12:00 am

!

!

!

!

!

voice ring-group 801

  type all

  description Operator Ring Group

  voicemail auth-mode password

  voicemail password encrypted "4044a0ec1b99ec2e460b8f2203161619f745"

!

!

!

voice operator-group

  type all

  num-rings 4

  num-rings night 1

  max-inbound 9

  member 226

  login-member 226

  member 316

  login-member 316

  member 311

  login-member 311

  member 327

  login-member 327

  member 317

  login-member 317

  member 310

  login-member 310

  member 307

  login-member 307

  member 300

  member 313

  login-member 313

  member 319

  login-member 319

  member 328

  login-member 328

  member 334

  login-member 334

  coverage  vm 310

  coverage  vm 310

  coverage  vm 310

  coverage night aa 821

  coverage night aa 821

  did "xxxxxxxx00"

  prefix "OutSide"

  originator-id user

  email adtran@xx.com

  voicemail greeting default

  voicemail password encrypted "4642275d03ad2627cea13e3b8fe320bf9b29"

!

!

!

end

Highlighted
Valued Contributor
Valued Contributor

Re: 2 outbound caller id's on a PRI and removing 9 from FXS 0/1 (fax)

Dan, I don't see any reason why the ANI substitution wouldn't work. Please capture the output of "debug voice verbose" and "debug isdn l2-f" running together while attempting to make a call out this second line. Thanks

Jay

Highlighted
New Contributor

Re: 2 outbound caller id's on a PRI and removing 9 from FXS 0/1 (fax)

debug isdn l2-f

12:40:11.129 ISDN.L2_FMT PRI  1  ==============================================

12:40:11.129 ISDN.L2_FMT PRI  1  T Sapi:00 C/R:R Tei:00 INFO Ns:87  Nr:75  P:0

12:40:11.129 ISDN.L2_FMT PRI  1    Prot:08  CRL:2  CRV:8519

12:40:11.129 ISDN.L2_FMT PRI  1    M - 45 DISCONNECT

12:40:11.129 ISDN.L2_FMT PRI  1     IE - 08 CAUSE               Len=2

12:40:11.129 ISDN.L2_FMT PRI  1          80 Location:U

12:40:11.130 ISDN.L2_FMT PRI  1          90 Cause:16 (NORMAL_CLEARING)

12:40:11.171 ISDN.L2_FMT PRI  1  ==============================================

12:40:11.171 ISDN.L2_FMT PRI  1  R Sapi:00 C/R:C Tei:00 INFO Ns:75  Nr:88  P:0

12:40:11.171 ISDN.L2_FMT PRI  1    Prot:08  CRL:2  CRV:0519

12:40:11.171 ISDN.L2_FMT PRI  1    M - 4D RELEASE   

12:40:11.172 ISDN.L2_FMT PRI  1  ==============================================

12:40:11.172 ISDN.L2_FMT PRI  1  T Sapi:00 C/R:R Tei:00 INFO Ns:88  Nr:76  P:0

12:40:11.172 ISDN.L2_FMT PRI  1    Prot:08  CRL:2  CRV:8519

12:40:11.172 ISDN.L2_FMT PRI  1    M - 5A RELEASE_CMP

2016.05.04 12:42:21 SIP.USER-REG 215 changed state to registered.

12:43:22.546 ISDN.L2_FMT PRI  1  ==============================================

12:43:22.546 ISDN.L2_FMT PRI  1  T Sapi:00 C/R:R Tei:00 INFO Ns:89  Nr:76  P:0

12:43:22.546 ISDN.L2_FMT PRI  1    Prot:08  CRL:2  CRV:0379

12:43:22.546 ISDN.L2_FMT PRI  1    M - 05 SETUP     

12:43:22.546 ISDN.L2_FMT PRI  1     IE - 04 BEARER CAPABILITY   Len=3

12:43:22.546 ISDN.L2_FMT PRI  1          80 Xfer Cap.:SPEECH          

12:43:22.546 ISDN.L2_FMT PRI  1          90 Xfer Rate:64k 

12:43:22.547 ISDN.L2_FMT PRI  1          A2 Layer 1:G.711 U-Law  

12:43:22.547 ISDN.L2_FMT PRI  1     IE - 18 CHANNEL ID          Len=3

12:43:22.547 ISDN.L2_FMT PRI  1          A1 Primary Rate

12:43:22.547 ISDN.L2_FMT PRI  1             Intfc ID:IMPLICIT

12:43:22.547 ISDN.L2_FMT PRI  1             Pref/Excl:PREFERRED

12:43:22.547 ISDN.L2_FMT PRI  1             D-Chan Indicated:NO

12:43:22.547 ISDN.L2_FMT PRI  1             Chan. Sel:FOLLOWS

12:43:22.547 ISDN.L2_FMT PRI  1          83 Numb/Map:NUMBER

12:43:22.547 ISDN.L2_FMT PRI  1          89 Channel:9

12:43:22.547 ISDN.L2_FMT PRI  1     IE - 6C CALLING PARTY #     Len=12

12:43:22.548 ISDN.L2_FMT PRI  1          21 Numb. Type:NATIONAL    

12:43:22.548 ISDN.L2_FMT PRI  1             Numb. Plan:E.164        

12:43:22.548 ISDN.L2_FMT PRI  1          80 Presentation:ALLOWED   

12:43:22.548 ISDN.L2_FMT PRI  1             Screening:USER PROVIDED

12:43:22.548 ISDN.L2_FMT PRI  1             Ph.# xxxxxxx17

12:43:22.548 ISDN.L2_FMT PRI  1     IE - 70 CALLED PARTY #      Len=11

12:43:22.548 ISDN.L2_FMT PRI  1          A1 Numb. Type:NATIONAL    

12:43:22.548 ISDN.L2_FMT PRI  1             Numb. Plan:E.164        

12:43:22.548 ISDN.L2_FMT PRI  1             Ph.# xxxxxxx66

12:43:22.562 ISDN.L2_FMT PRI  1  ==============================================

12:43:22.562 ISDN.L2_FMT PRI  1  R Sapi:00 C/R:C Tei:00 INFO Ns:76  Nr:90  P:0

12:43:22.562 ISDN.L2_FMT PRI  1    Prot:08  CRL:2  CRV:8379

12:43:22.562 ISDN.L2_FMT PRI  1    M - 02 CALL_PROC 

12:43:22.562 ISDN.L2_FMT PRI  1     IE - 18 CHANNEL ID          Len=3

12:43:22.562 ISDN.L2_FMT PRI  1          A9 Primary Rate

12:43:22.562 ISDN.L2_FMT PRI  1             Intfc ID:IMPLICIT

12:43:22.562 ISDN.L2_FMT PRI  1             Pref/Excl:EXCLUSIVE

12:43:22.562 ISDN.L2_FMT PRI  1             D-Chan Indicated:NO

12:43:22.563 ISDN.L2_FMT PRI  1             Chan. Sel:FOLLOWS

12:43:22.563 ISDN.L2_FMT PRI  1          83 Numb/Map:NUMBER

12:43:22.563 ISDN.L2_FMT PRI  1          89 Channel:9

12:43:24.982 ISDN.L2_FMT PRI  1  ==============================================

12:43:24.982 ISDN.L2_FMT PRI  1  R Sapi:00 C/R:C Tei:00 INFO Ns:77  Nr:90  P:0

12:43:24.982 ISDN.L2_FMT PRI  1    Prot:08  CRL:2  CRV:8379

12:43:24.982 ISDN.L2_FMT PRI  1    M - 03 PROGRESS  

12:43:24.983 ISDN.L2_FMT PRI  1     IE - 1E PROGRESS INDICATOR  Len=2

12:43:24.983 ISDN.L2_FMT PRI  1          82 Location:LN

12:43:24.983 ISDN.L2_FMT PRI  1          88 Description:INBAND AUDIO AVAIL

12:43:38.061 ISDN.L2_FMT PRI  1  ==============================================

12:43:38.061 ISDN.L2_FMT PRI  1  R Sapi:00 C/R:C Tei:00 INFO Ns:78  Nr:90  P:0

12:43:38.061 ISDN.L2_FMT PRI  1    Prot:08  CRL:2  CRV:8379

12:43:38.061 ISDN.L2_FMT PRI  1    M - 07 CONNECT   

12:43:38.062 ISDN.L2_FMT PRI  1  ==============================================

12:43:38.062 ISDN.L2_FMT PRI  1  T Sapi:00 C/R:R Tei:00 INFO Ns:90  Nr:79  P:0

12:43:38.062 ISDN.L2_FMT PRI  1    Prot:08  CRL:2  CRV:0379

12:43:38.062 ISDN.L2_FMT PRI  1    M - 0F CONNECT_ACK

12:43:43.992 ISDN.L2_FMT PRI  1  ==============================================

12:43:43.992 ISDN.L2_FMT PRI  1  R Sapi:00 C/R:C Tei:00 INFO Ns:79  Nr:91  P:0

12:43:43.992 ISDN.L2_FMT PRI  1    Prot:08  CRL:2  CRV:8379

12:43:43.992 ISDN.L2_FMT PRI  1    M - 45 DISCONNECT

12:43:43.992 ISDN.L2_FMT PRI  1     IE - 08 CAUSE               Len=2

12:43:43.992 ISDN.L2_FMT PRI  1          82 Location:LN

12:43:43.992 ISDN.L2_FMT PRI  1          90 Cause:16 (NORMAL_CLEARING)

12:43:43.993 ISDN.L2_FMT PRI  1  ==============================================

12:43:43.993 ISDN.L2_FMT PRI  1  T Sapi:00 C/R:R Tei:00 INFO Ns:91  Nr:80  P:0

12:43:43.993 ISDN.L2_FMT PRI  1    Prot:08  CRL:2  CRV:0379

12:43:43.993 ISDN.L2_FMT PRI  1    M - 4D RELEASE   

12:43:44.001 ISDN.L2_FMT PRI  1  ==============================================

12:43:44.001 ISDN.L2_FMT PRI  1  R Sapi:00 C/R:C Tei:00 INFO Ns:80  Nr:92  P:0

12:43:44.001 ISDN.L2_FMT PRI  1    Prot:08  CRL:2  CRV:8379

12:43:44.001 ISDN.L2_FMT PRI  1    M - 5A RELEASE_CMP

12:45:15.328 ISDN.L2_FMT PRI  1  ==============================================

12:45:15.328 ISDN.L2_FMT PRI  1  R Sapi:00 C/R:C Tei:00 INFO Ns:81  Nr:92  P:0

12:45:15.328 ISDN.L2_FMT PRI  1    Prot:08  CRL:2  CRV:051A

12:45:15.329 ISDN.L2_FMT PRI  1    M - 05 SETUP     

12:45:15.329 ISDN.L2_FMT PRI  1     IE - 04 BEARER CAPABILITY   Len=3

12:45:15.329 ISDN.L2_FMT PRI  1          80 Xfer Cap.:SPEECH          

12:45:15.329 ISDN.L2_FMT PRI  1          90 Xfer Rate:64k 

12:45:15.329 ISDN.L2_FMT PRI  1          A2 Layer 1:G.711 U-Law  

12:45:15.329 ISDN.L2_FMT PRI  1     IE - 18 CHANNEL ID          Len=3

12:45:15.329 ISDN.L2_FMT PRI  1          A1 Primary Rate

12:45:15.329 ISDN.L2_FMT PRI  1             Intfc ID:IMPLICIT

12:45:15.329 ISDN.L2_FMT PRI  1             Pref/Excl:PREFERRED

12:45:15.330 ISDN.L2_FMT PRI  1             D-Chan Indicated:NO

12:45:15.330 ISDN.L2_FMT PRI  1             Chan. Sel:FOLLOWS

12:45:15.330 ISDN.L2_FMT PRI  1          83 Numb/Map:NUMBER

12:45:15.330 ISDN.L2_FMT PRI  1          81 Channel:1

12:45:15.330 ISDN.L2_FMT PRI  1     IE - 1C FACILITY            Len=29

12:45:15.330 ISDN.L2_FMT PRI  1      Calling Name: Denver       CO

12:45:15.330 ISDN.L2_FMT PRI  1     IE - 6C CALLING PARTY #     Len=12

12:45:15.330 ISDN.L2_FMT PRI  1          00 Numb. Type:UNKNOWN     

12:45:15.330 ISDN.L2_FMT PRI  1             Numb. Plan:UNKNOWN      

12:45:15.330 ISDN.L2_FMT PRI  1          80 Presentation:ALLOWED   

12:45:15.331 ISDN.L2_FMT PRI  1             Screening:USER PROVIDED

12:45:15.331 ISDN.L2_FMT PRI  1             Ph.# xxxxxx45

12:45:15.331 ISDN.L2_FMT PRI  1     IE - 70 CALLED PARTY #      Len=11

12:45:15.331 ISDN.L2_FMT PRI  1          80 Numb. Type:UNKNOWN     

12:45:15.331 ISDN.L2_FMT PRI  1             Numb. Plan:UNKNOWN      

12:45:15.331 ISDN.L2_FMT PRI  1             Ph.# xxxxxxx00

Highlighted
Valued Contributor
Valued Contributor

Re: 2 outbound caller id's on a PRI and removing 9 from FXS 0/1 (fax)

Dan, I can't see the entire number, but the debug you sent shows us sending a call out with the same last 2 digits of caller-id as your user:

12:43:22.547 ISDN.L2_FMT PRI  1     IE - 6C CALLING PARTY #     Len=12

12:43:22.548 ISDN.L2_FMT PRI  1          21 Numb. Type:NATIONAL   

12:43:22.548 ISDN.L2_FMT PRI  1             Numb. Plan:E.164       

12:43:22.548 ISDN.L2_FMT PRI  1          80 Presentation:ALLOWED  

12:43:22.548 ISDN.L2_FMT PRI  1             Screening:USER PROVIDED

12:43:22.548 ISDN.L2_FMT PRI  1             Ph.# xxxxxxx17

Assuming that's the test call you made, it would appear that the provider is overriding caller-id after the call leaves the 7100. If that's the case, you'll need to speak to them about disabling that. Thanks

Jay

Highlighted
New Contributor

Re: 2 outbound caller id's on a PRI and removing 9 from FXS 0/1 (fax)

I will check with our provider, But originally they weren't supposed to be providing outgoing caller ID.I have an entry under the AniFor the main phone number and name. I will change it slightly and test.

Also, if I add an 11th digit it shows up on caller id.

With the fxs port, Where does it pull it's dialing Rules from? Does it pull its rules from the main dial plan, Under voice

Highlighted
Valued Contributor
Valued Contributor

Re: 2 outbound caller id's on a PRI and removing 9 from FXS 0/1 (fax)

Dan, yes, the FXS ports get their dial plan from the "System Setup", "Dial Plan" section. Thanks

Jay

Highlighted
New Contributor

Re: 2 outbound caller id's on a PRI and removing 9 from FXS 0/1 (fax)

I found the issue with a little more information from calling in to support. I had a MXX[1-8]XX and a MXXX/[1-8]XXX in my dial plan. once they were removed, the fax line was able to dial out.