cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
dlevasseur
Contributor
Contributor

Android softphone won't ring

Jump to solution

Excellent!  Found the ACL entries.  There was one for our UCServer already so I just expanded it for the block.

A couple things, maybe for a different post.  There seems to be more latency, though this was via WiFi so that might add to the issue.  Also, when I try to call the assigned extension back it goes directly to my voice mail (since no VM service is defined for that extension).  Can I call a Soft phone from one of my desk phones?

EDIT:  I found that "Call Coverage" for the SIP user was set to "Go directly to voicemail" so I set that to "Custom" and then ring extension then go to busy.  The call now goes directly to busy.

Labels (1)
0 Kudos
1 Solution

Accepted Solutions
dlevasseur
Contributor
Contributor

Re: Android softphone won't ring

Jump to solution

OK.  So I blew away all my settings in every app I have.  Reconfigured Zoiper and it registers as our public 24. address.  I then reconfigured CSipSimple and it properly registered with an internal 192. address and am able to make and receive calls!

Must be something with that Zoiper app which is really nice, but must be checking the internet for IP address and using that for registration.  5060 is NOT open on our Public WAN so no traffic can come or go through it.

EDIT:  After messing with the ZoiPer app, the issue is that STUN is enabled by default so it was discovering the external IP for NAT transversal and registering that with the 7100.  After turning that off, I was able to use the app flawlessly.

Thanks again Matt for all the help!  Sometimes you just need that second set of eyes.

View solution in original post

0 Kudos
11 Replies
Anonymous
Not applicable

Re: Android SIP Phone testing, phones won't register

Jump to solution

WiFi should be ok, unless you have abnormal latency for some reason.  Try pinging something on the WiFi network and something on the wired network and then compare the response times.  In any case you may need to configure QoS to improve voice quality.

For the busy problem can you paste a screenshot of the softphone voice user's coverage?

Thanks,

Matt

dlevasseur
Contributor
Contributor

Re: Android SIP Phone testing, phones won't register

Jump to solution

Thanks Matt.  I'll look at my QOS on the router and see if I can do any better.

Without changing anything and just messing around, I managed to get it to ring once, but then never again.  I don't understand why.

Capture.JPG

Anonymous
Not applicable

Re: Android SIP Phone testing, phones won't register

Jump to solution

That coverage should make the phone ring 4 times and then go to a busy signal.  It sounds like the phone may not be registered.  Check the Voice > Phone Registrations part of the GUI.  If the phone shows up there, I would need to see the output from a debug voice verbose and debug sip stack messages both enabled at the same time while you recreate the issue along with a copy of the current configuration.  You can submit them to our FTP server with the instructions below:


Open Internet Explorer web browser on their PC
Type the following URL:  ftp://ftp.adtran.com


Press the Alt key, click View, and then click Open FTP Site in Windows Explorer


Double-click the "Incoming" folder
Drag and drop files from PC into the Internet Explorer window


Reply to this post with the exact filenames used so we can retrieve the files



Thanks,

Matt

Anonymous
Not applicable

Re: Android softphone won't ring

Jump to solution

Just a side note - I branched this to a new discussion to concentrate on the problem of the softphone not ringing.

dlevasseur
Contributor
Contributor

Re: Android softphone won't ring

Jump to solution

Thanks for that.

The phone is registered and I can call out from it.  SIP registration list shows:

153Zoiper r2064724.220.77.1750604 mins 35 secs

Yesterday I saw another post about doing a debug with those messages enabled.  So I did so and the debug promptly crashed my 7100 and rebooted all the phones.  Not a good thing in the middle of the day.  I'll see about getting that over lunch or this evening.

Anonymous
Not applicable

Re: Android softphone won't ring

Jump to solution

Sorry to hear that.  You likely need to upgrade the firmware on the unit if you are experiencing a reboot.  If it continues to happen on recent code you will need to open a support ticket so we can track it appropriately. 

I see from the output you provided the phone is registered with a public IP, but I thought your original post implied it was on a private network.

Thanks,

Matt

dlevasseur
Contributor
Contributor

Re: Android softphone won't ring

Jump to solution

That's odd, I don't know why it is showing our public IP.  I'm connected to our internal network.  I also tried a different APP CSipSimple which does the same thing.  Also the Zoiper Desktop app also does not ring in.

Maybe there's a setting somewhere I'm missing that should report the internal IP to the register or something...

dlevasseur
Contributor
Contributor

Re: Android softphone won't ring

Jump to solution

OK.  So I blew away all my settings in every app I have.  Reconfigured Zoiper and it registers as our public 24. address.  I then reconfigured CSipSimple and it properly registered with an internal 192. address and am able to make and receive calls!

Must be something with that Zoiper app which is really nice, but must be checking the internet for IP address and using that for registration.  5060 is NOT open on our Public WAN so no traffic can come or go through it.

EDIT:  After messing with the ZoiPer app, the issue is that STUN is enabled by default so it was discovering the external IP for NAT transversal and registering that with the 7100.  After turning that off, I was able to use the app flawlessly.

Thanks again Matt for all the help!  Sometimes you just need that second set of eyes.

View solution in original post

0 Kudos
Anonymous
Not applicable

Re: Android softphone won't ring

Jump to solution

Thanks for the update.  As you pointed out, it sounds like the configuration of the app, or a limitation with it.  Can you come back to this thread and select your last reply as the Correct Answer? 

Thanks,
Matt

dlevasseur
Contributor
Contributor

Re: Android softphone won't ring

Jump to solution

None of those options are available "Mark as correct" or even "Mark Helpful Answer".  I noticed the thread topic isn't set as a Question, is that the issue?

Anonymous
Not applicable

Re: Android softphone won't ring

Jump to solution

That was the issue.  When I branched this thread it did not mark it as a question. Sorry about that.  I fixed it now.