cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
New Contributor

Re: Calls Cut Off After 15min

Jump to solution

Hi Matt

Attached are debug files and logging error reports from the cut off after 15 minutes. Let me know if you can determine cause You can see call being terminated at 20h07 In logging events it shows as 2014.01.22 20:07:33 VQM.EVENTS Monitoring session ended for 221 to xxxyyy8488, RTP=xx.xx.32.18:35104->192.168.2.110:3002, MOS (LQ/PQ)=4.20/4.45, loss=0 pkts, out-of-order=0 pkts, jitter=0 ms

Best regards

Pierre

Message was edited by: matt - removed personal contact info

Highlighted
Anonymous
Not applicable

Re: Calls Cut Off After 15min

Jump to solution

phonealchemist,

Looking at the debug that you provided, the SIP provider is using an INVITE at the 15 minute mark as a keep-alive for the call. When this happens, the 7100 is changing the audio port from the original port of 50460 to 50480. Most likely, the provider is sending the audio to the old port, 50460 instead of the new port and that is causing the one-way audio. Once the user loses the audio after the re-INVITE, they are most likely hanging up and ending the call. A packet capture of the WAN interface would provide evidence that the 7100 isn't receiving audio on the correct port.

Highlighted
New Contributor

Re: Calls Cut Off After 15min

Jump to solution

The logic follows there Ryan, but they don't lose audio; the call ends at the station, and the user has to redial. I'm sending the provider OPTION keep-alives to keep the call open, and they keep sending me more OPTION keep-alives to ensure that the trunks are open.

Highlighted
Anonymous
Not applicable

Re: Calls Cut Off After 15min

Jump to solution

Pierre - The attachments did not come through.  Can you please resubmit the debug output and the configuration to the FTP server with the instructions listed earlier in this thread?

Highlighted
Anonymous
Not applicable

Re: Calls Cut Off After 15min

Jump to solution

Phonealchemist,

Thanks for the clarification. Looking back over the debug, the call is ended by the SIP provider in both instances. At time stamps 15:15:28.714 and 15:31:07.598 the 7100 receives a BYE to tear down the call. The provider may be able to shed some more light on why the call is being torn down.

Highlighted
New Contributor

Re: Calls Cut Off After 15min

Jump to solution

Thanks for examining this Ryan. I've gone back to the carrier, and from their perspective, they're seeing the calls disconnect from the dialed-party's end, even then we know this is not the case. They're opening a ticket with their tech-support and will get back to me. I'll advise when I get something new from them.

Highlighted
New Contributor

Re: Calls Cut Off After 15min

Jump to solution

Ok, directly from an email that the SIP provider, this is what they're seeing:

From what I found on the call that originated at 15:00 on the 22nd, @ 15:00:07,569  XXX-452-1315 originated a call to XXX-241-7203, and at this time the Adtran set up the source RTP port of 50460, this call went along and 15 minutes into the call the Metaswitch call feature server sends out a “keep-alive”  re-invite to the adtran 7100,  the adtran 7100 responded back with a 200 OK to this re-invite   (the keep alive re-invite is set to the highest parameter in the CFS and this is something we cannot remove)  with this response 200 OK back from the adtran 7100 at 15:15:21.061 the adtran changed the source RTP port to 50480, this is what started the chain of events in dropping the call,  once the CFS saw the source RTP port change to 50480 we were waiting to accept packets from this port, yet it appears that the adtran was still sending the traffic on the RTP port 50460,   I am not totally sure this is the case, that is why you would need to perform a packet capture on the adtran to see if this is actually the case.

I have attached some of the trace I was able to capture on the first call placed that dropped showing a little bit of what I described above, and some of the engineering data captured by Metaswitch on this call (see below), showing that at 15:15:28,880 packets being dropped.

Checking my configs under Voice -> System Setup -> VoIP Settings -> RTP Settings, I see that 'Re-use NAT ports' is checked and therefore the 7100 shouldn't be trying to change the port unless something else is happening here. Ideas?

Highlighted
Anonymous
Not applicable

Re: Calls Cut Off After 15min

Jump to solution

That option in the GUI corresponds to the ip rtp firewall-traversal reuse-nat-ports command. If the reuse option is set, then the 7100 should stay with the same ports for a given call ID/SDP session ID.

Just for the sake of clarity, I was looking at the first call to xxx-241-7203 in the debug file you originally supplied.  In that debug the call comes up with the following details:


x.x.132.230 (7100) sends audio to x.x.240.66 (Metaswitch) on port 28394


x.x.240.66 (Metaswitch) sends audio to x.x.132.230 (7100) on port 50460



Then after 15 minutes, the Metaswitch sends a re-INVITE with the same SDP to serve as a keep-alive. The 7100 responds back with a 200 OK with SDP asking to receive audio on a new port (50480).  So the new call should be up with these details:


x.x.132.230 (7100) sends audio to x.x.240.66 (Metaswitch) on port 28394


x.x.240.66 (Metaswitch) SHOULD BE sending audio to x.x.132.230 (7100) on port 50480



The response you posted above indicated they were expecting the 7100 to send audio to the Metaswitch on port 50480, but it should have been the other way around. The Metaswitch should be sending audio to the 7100 on that port (50480).

Here are our suggestions to move forward with this issue:

  • Upgrade the IP 700 firmware to at least R2.3.0.  The current version running is not supported and may be contributing to the problem. 
  • Upgrade the 7100 to R10.9.2.
    • This may not resolve this specific issue, but you mentioned downgrading because of the TLS issue.  The TLS fix is included in R10.9.2. If we are going to look at a new debug, especially to investigate any potential issues, it would be best if you were running this later version.
  • Ensure the Metaswitch and the 7100 are configured according to this guide:

If after performing the steps above the issue is still occurs, a packet capture on the WAN of the 7100 would be the next step as the SIP provider suggested.  This would be the best bet to confirm what is truly happening.  It is imperative this be done in conjunction with the same debugs running on the 7100 again. I would suggest doing it when there is minimal traffic to help minimize the file size of the PCAP. If you can gather the packet capture, new debugs, and the current configuration I would be happy to review them.  You will need to submit them all in a .zip to the FTP server with the instructions in my earlier response on this thread.  When the issue is recreated it would also help to document if a party gets one way audio, and if so which side.

Thanks,

Matt

View solution in original post

0 Kudos
Highlighted
New Contributor II

Re: Calls Cut Off After 15min

Jump to solution

I am having the same issue on one of our 7100's, Metaswitch and 15 minutes and only long distance.  It is not clear to me _which_ of these things fixed the issue.  Is it unchecking the 'Re-use NAT ports', or the firmware update.  I'm seeing it on R10.8.1.E.

/rh

Highlighted
New Contributor

Re: Calls Cut Off After 15min

Jump to solution

Veuillez notez que je suis en vacance et serai de retour au bureau le 8 Janvier

Pour toute demande de service veuillez communiquer avec Dragan Jerbic au (514) 835-2065

Joyeuses Fêtes

***************************************************************************************************

Please note that I am on vacation and will return to the office on jan 8th

For any service call please communicate with Dragan Jerbic (514) 835-2065