cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
touristsis
Contributor III
Contributor III

Download of adtran_00xxxxxxxxx.txt failed

Jump to solution

Hi,  I have Netvanta 7100 (main location) and 1 phone at remote location.  They are vpn together via 3120.  have option 157 on the 3120 for ftp to the main 7100.  Some reason, I always get download of adtran_XXXXXXXXX.TXT failed at remote office.  Anyone have clues?  Something special I need on VPN?  Here is my debug ip ftp on the 7100.

2013.04.23 09:20:53 IP.FTP_SERVER (USER) Password required for 'polycomftp'.

2013.04.23 09:20:53 IP.FTP_SERVER (USER) User 'polycomftp' logged in.

2013.04.23 09:20:53 IP.FTP_SERVER (TYPE) Type is set to I.

2013.04.23 09:20:54 IP.FTP_SERVER (CWD) Directory changed to 'ADTRAN'.

2013.04.23 09:20:54 IP.FTP_SERVER (PORT) Opening port from 10,10,150,132,4,1 on VRF: -DEFAULT-

2013.04.23 09:20:54 IP.FTP_SERVER BINARY data connection for 'ls' (10.10.150.132,1025) on VRF: -DEFAULT-.

2013.04.23 09:20:54 IP.FTP_SERVER (NLST) 'Language_English.xml' transfer complete on VRF: -DEFAULT-.

2013.04.23 09:20:54 IP.FTP_SERVER (PORT) Opening port from 10,10,150,132,4,2 on VRF: -DEFAULT-

2013.04.23 09:20:54 IP.FTP_SERVER BINARY data connection for 'Language_English.xml' (10.10.150.132,1026) on VRF: -DEFAULT-.

2013.04.23 09:20:55 IP.FTP_SERVER (RETR) 'BINARY' transfer complete on VRF: -DEFAULT-.

2013.04.23 09:21:02 IP.FTP_SERVER (USER) Password required for 'polycomftp'.

2013.04.23 09:21:02 IP.FTP_SERVER (USER) User 'polycomftp' logged in.

2013.04.23 09:21:02 IP.FTP_SERVER (TYPE) Type is set to I.

2013.04.23 09:21:02 IP.FTP_SERVER (CWD) Directory changed to 'ADTRAN'.

2013.04.23 09:21:02 IP.FTP_SERVER (PORT) Opening port from 10,10,150,132,4,4 on VRF: -DEFAULT-

2013.04.23 09:21:02 IP.FTP_SERVER BINARY data connection for 'ls' (10.10.150.132,1028) on VRF: -DEFAULT-.

2013.04.23 09:21:03 IP.FTP_SERVER (NLST) 'adtran_phonebook.csv' transfer complete on VRF: -DEFAULT-.

2013.04.23 09:21:03 IP.FTP_SERVER (PORT) Opening port from 10,10,150,132,4,5 on VRF: -DEFAULT-

2013.04.23 09:21:03 IP.FTP_SERVER BINARY data connection for 'adtran_phonebook.csv' (10.10.150.132,1029) on VRF: -DEFAULT-.

2013.04.23 09:21:03 IP.FTP_SERVER (RETR) 'BINARY' transfer complete on VRF: -DEFAULT-.

2013.04.23 09:21:06 IP.FTP_SERVER (USER) Password required for 'polycomftp'.

2013.04.23 09:21:06 IP.FTP_SERVER (USER) User 'polycomftp' logged in.

2013.04.23 09:21:06 IP.FTP_SERVER (TYPE) Type is set to I.

2013.04.23 09:21:06 IP.FTP_SERVER (CWD) Directory changed to 'ADTRAN'.

2013.04.23 09:21:06 IP.FTP_SERVER (PORT) Opening port from 10,10,150,132,4,7 on VRF: -DEFAULT-

2013.04.23 09:21:06 IP.FTP_SERVER BINARY data connection for 'ls' (10.10.150.132,1031) on VRF: -DEFAULT-.

2013.04.23 09:21:06 IP.FTP_SERVER (NLST) 'iconpixmap.bmp' transfer complete on VRF: -DEFAULT-.

2013.04.23 09:21:06 IP.FTP_SERVER (PORT) Opening port from 10,10,150,132,4,8 on VRF: -DEFAULT-

2013.04.23 09:21:06 IP.FTP_SERVER BINARY data connection for 'iconpixmap.bmp' (10.10.150.132,1032) on VRF: -DEFAULT-.

2013.04.23 09:21:07 IP.FTP_SERVER (RETR) 'BINARY' transfer complete on VRF: -DEFAULT-.

2013.04.23 09:21:28 SIP.USER-REG 114 changed state to unregistered.

2013.04.23 09:21:28 SIP.USER-REG 5126379895(114) changed state to unregistered.

2013.04.23 09:21:28 SIP.USER-REG Line1(114) changed state to unregistered.

2013.04.23 09:21:31 SIP.USER-REG 114 changed state to registered.

2013.04.23 09:21:31 SIP.USER-REG 5126379895(114) changed state to registered.

2013.04.23 09:21:31 SIP.USER-REG Line1(114) changed state to registered.

2013.04.23 09:21:32 IP.FTP_SERVER (USER) Password required for 'anonymous'.

2013.04.23 09:21:32 IP.FTP_SERVER (USER) Login incorrect.

2013.04.23 09:21:36 IP.FTP_SERVER (USER) Password required for 'polycomftp'.

2013.04.23 09:21:36 IP.FTP_SERVER (USER) User 'polycomftp' logged in.

2013.04.23 09:21:37 IP.FTP_SERVER 'OPTS' command not understood.

2013.04.23 09:21:37 IP.FTP_SERVER (SYST) UNIX Type=L8 Version='TINY FTP'

2013.04.23 09:21:37 IP.FTP_SERVER 'SITE' command not understood.

2013.04.23 09:21:37 IP.FTP_SERVER (PWD) '/' is current directory.

2013.04.23 09:21:38 IP.FTP_SERVER (USER) Password required for 'polycomftp'.

2013.04.23 09:21:38 IP.FTP_SERVER (USER) User 'polycomftp' logged in.

2013.04.23 09:21:39 IP.FTP_SERVER 'OPTS' command not understood.

2013.04.23 09:21:39 IP.FTP_SERVER (SYST) UNIX Type=L8 Version='TINY FTP'

2013.04.23 09:21:39 IP.FTP_SERVER 'SITE' command not understood.

2013.04.23 09:21:40 IP.FTP_SERVER (PWD) '/' is current directory.

2013.04.23 09:21:40 IP.FTP_SERVER (TYPE) Type is set to A.

2013.04.23 09:21:40 IP.FTP_SERVER (PASV) Entering Passive Mode (192,168,150,254,19,237) on VRF: -DEFAULT-.

2013.04.23 09:21:40 IP.FTP_SERVER ASCII data connection for 'dir' on VRF: -DEFAULT-.

2013.04.23 09:21:41 IP.FTP_SERVER (LIST) ASCII transfer complete on VRF: -DEFAULT-.

2013.04.23 09:21:43 IP.FTP_SERVER (NOOP) Command successful.

2013.04.23 09:21:43 IP.FTP_SERVER (CWD) Directory changed to '/ADTRAN/'.

2013.04.23 09:21:44 IP.FTP_SERVER (TYPE) Type is set to A.

2013.04.23 09:21:44 IP.FTP_SERVER (PASV) Entering Passive Mode (192,168,150,254,19,238) on VRF: -DEFAULT-.

2013.04.23 09:21:45 IP.FTP_SERVER ASCII data connection for 'dir' on VRF: -DEFAULT-.

2013.04.23 09:21:45 IP.FTP_SERVER (LIST) ASCII transfer complete on VRF: -DEFAULT-.

Labels (1)
0 Kudos
1 Solution

Accepted Solutions
touristsis
Contributor III
Contributor III

Re: Download of adtran_00xxxxxxxxx.txt failed

Jump to solution

Hi Matt, Thanks that works.  Now I know how to manual provision the phones if I can't get option 157 to work. I've also found the problem on why option 157 does not work.

  option 157 ascii TftpServer=0.0.0.0,FtpServer=192.168.150.254:/Adtran,FtpLogin=polycomftp,FtpPassword=password,Layer2Tagging=False - WRONG

  option 157 ascii TftpServer=0.0.0.0,FtpServers=192.168.150.254:/Adtran,FtpLogin=polycomftp,FtpPassword=password,Layer2Tagging=False - CORRECT,  I made this mistake a few times.  FtpServers needed to be pluraral, so confusing.

View solution in original post

0 Kudos
9 Replies
jay
Valued Contributor
Valued Contributor

Re: Download of adtran_00xxxxxxxxx.txt failed

Jump to solution

Touristsis, the debug you supplied does not show the phone requesting that file, but it should be in an earlier part of the FTP process than what was provided. Does the phone boot up and register properly?

touristsis
Contributor III
Contributor III

Re: Download of adtran_00xxxxxxxxx.txt failed

Jump to solution

Yes it boot up properly.

Sent from my iPhone

jay
Valued Contributor
Valued Contributor

Re: Download of adtran_00xxxxxxxxx.txt failed

Jump to solution

If that is the case, the phone must be pulling its adtran_mac.cfg file at some point. That file contains the user and SIP registration information, so without it, the phone can not register. If you port mirror the port at the 3120 that the phone is attached to and take a packet capture, that should confirm everything that the phone requests and receives.

touristsis
Contributor III
Contributor III

Re: Download of adtran_00xxxxxxxxx.txt failed

Jump to solution

Jay,  I've attached a wireshark on the adtran ftp.  File name is adtran3120114sip.pcapng.  Can you check it out for me?  I just want the phone to download all the config file from the phone system via VPN, so I can update everything.

jay
Valued Contributor
Valued Contributor

Re: Download of adtran_00xxxxxxxxx.txt failed

Jump to solution

Touristsis, was that taken locally at the phone? Was the capture started before the phone was powered on? If so, try factory defaulting the phone. If not, please open a ticket with support for further troubleshooting.

touristsis
Contributor III
Contributor III

Re: Download of adtran_00xxxxxxxxx.txt failed

Jump to solution

Jay, that was taken from the 3120.  I had to add a POE behide the 3120 to power the phone.  That was taken with port mirroring on one of the 3120 ports.  This is getting a bit frustrating.  So here's where I'm at with it.  I've created a an access list -

ip access list standard DEBUG

permit host 10.10.150.140

permit host 10.10.150.139


Then I ran a debug ip packet DEBUG detail

Then I set the phone to factory default.

Here is all I'm getting from the debug, it doesn't looks like the phone is even attempting to go to the ftp server.

on the phone, I can see it get ip address 10.10.150.139, then 10.10.150.140, then download of adtran _xxxxxxxxx failed, download of ...failed...download of....failed.

but nothing on the debug?

IP: UDP: src=68, dst=67
IP: s=10.10.150.139 (vlan 1) d=10.10.150.1 (Loopback), rcvd, size = 329(309)
IP: UDP: src=68, dst=67
IP: s=10.10.150.139 (vlan 1) d=10.10.150.1 (vlan 1), entering FW, size = 128(108)
IP: ICMP: type=0, code=0
IP: s=10.10.150.139 (vlan 1) d=10.10.150.1 (Loopback), rcvd, size = 128(108)
IP: ICMP: type=0, code=0

That's all I got from the debug.  Any ideas?

Anonymous
Not applicable

Re: Download of adtran_00xxxxxxxxx.txt failed

Jump to solution

touristsis,


Were you ever able to resolve this?  It should be possible to make this work automatically.  In case it helps with the current situation, instructions are listed here to manually setup the phone:


Thanks,

Matt

touristsis
Contributor III
Contributor III

Re: Download of adtran_00xxxxxxxxx.txt failed

Jump to solution

Hi Matt, Thanks that works.  Now I know how to manual provision the phones if I can't get option 157 to work. I've also found the problem on why option 157 does not work.

  option 157 ascii TftpServer=0.0.0.0,FtpServer=192.168.150.254:/Adtran,FtpLogin=polycomftp,FtpPassword=password,Layer2Tagging=False - WRONG

  option 157 ascii TftpServer=0.0.0.0,FtpServers=192.168.150.254:/Adtran,FtpLogin=polycomftp,FtpPassword=password,Layer2Tagging=False - CORRECT,  I made this mistake a few times.  FtpServers needed to be pluraral, so confusing.

View solution in original post

0 Kudos
Anonymous
Not applicable

Re: Download of adtran_00xxxxxxxxx.txt failed

Jump to solution

touristsis,

Thank you for the update.  Can you come back to this thread and select any Correct or Helpful answers with the buttons?  That will make them more visible to others in the community.

Thanks,

Matt