cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
brian_ctl
Contributor
Contributor

Global Directory not complete

Jump to solution

I have a customer that can't seem to get the whole Directory downloaded to their phones.  Watching the phone boot they see ftp "adtran_phonebook.csv" download fine but  only 1Kbit, the files is over 2kbits. They only see 25 names but when I look at the cflash file there is 55 names in it.

Labels (1)
0 Kudos
1 Solution

Accepted Solutions
markfreeman
Valued Contributor II
Valued Contributor II

Re: Global Directory not complete

Jump to solution

Brian,

After talking to some guys here, your problem might be with a special character in your csv file. Check to see if their is a ' (apostrophe) in a user's name. It should be on the last line that is being loaded. that would prevent the phone from loading anything beyond that.

Post back if that fixed it.

-Mark

View solution in original post

0 Kudos
10 Replies
markfreeman
Valued Contributor II
Valued Contributor II

Re: Global Directory not complete

Jump to solution

Brian,

Not sure if you have tried this but make sure the new directories have been updated to the phone configs. Go to Voice > IP Phone Configs and select the MAC of the phone having problem, then go to Other Actions and choose Update Directories, then do Sync Phone or just reboot the phone by bouncing the PoE in the 7100 or from the phone itself. See picture:

update_dir.jpg

Let us know if that worked.

-Mark

brian_ctl
Contributor
Contributor

Re: Global Directory not complete

Jump to solution

Hi Mark,

yep tried that, these are all Adtran 7xx phones,  they have one polycom conf phone is all.

AOS 5.03


markfreeman
Valued Contributor II
Valued Contributor II

Re: Global Directory not complete

Jump to solution

Brian,

Log into 7100 and do a debug ip ftp

Lets try this from one of the ADTRAN phones, press Menu, then 2 then 9, and then press the del phbk button and then the factory button. Then attach the debug output to your reply. Click "Use Advanced editor" in the top right corner of the reply and then you will see an option below the reply to attach a file.

If you have already tried this let me know.

markfreeman
Valued Contributor II
Valued Contributor II

Re: Global Directory not complete

Jump to solution

Brian,

After talking to some guys here, your problem might be with a special character in your csv file. Check to see if their is a ' (apostrophe) in a user's name. It should be on the last line that is being loaded. that would prevent the phone from loading anything beyond that.

Post back if that fixed it.

-Mark

View solution in original post

0 Kudos
brian_ctl
Contributor
Contributor

Re: Global Directory not complete

Jump to solution

hear you go,  I did this yesterday,

as you can see I was debuging DHCP as well as the option was messed up.

brian_ctl
Contributor
Contributor

Re: Global Directory not complete

Jump to solution

Dang I forgot about that, I think you nailed it.  I will test with the customer Monday.

two names in csv file:

Sandra,O'Neil,,,,,,,,,,,5495,,,

Part/Board,Prep Cell,,,,,,,,,,,5719,,,

Message was edited by: matt - removed sensitive information

markfreeman
Valued Contributor II
Valued Contributor II

Re: Global Directory not complete

Jump to solution

Brian,

Any update?

-Mark

brian_ctl
Contributor
Contributor

Re: Global Directory not complete

Jump to solution

you nailed it thanks

markfreeman
Valued Contributor II
Valued Contributor II

Re: Global Directory not complete

Jump to solution

Brian,

Awesome! Glad that fixed your problem and thanks for marking the question as answered. Have a great week!

-Mark

gouc
New Contributor III

Re: Global Directory not complete

Jump to solution

Brian,

This issue has been addressed in our latest IP7xx phone firmware. If you were to run into this again, you may want to upgrade the firmware. The new firmware does support name wihth an apostrophe in it. https://supportforums.adtran.com/docs/DOC-6199

Thanks,

-Samir