cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Anonymous
Not applicable

Re: SMTP with Office365

Jump to solution

I just wanted to update this post to mention that AOS R10.9.2 was recently released, which included a fix for e-mail servers that use TLS.

View solution in original post

Highlighted
New Contributor II

Re: SMTP with Office365

Jump to solution

Thank you Matt. I have upgraded my 7100 and tested the SMTP with Office365 and it does work now that a second EHLO is being sent. I have changed the correct answer on the thread to Matt's post. (Debug output below)

To SMTP server: EHLO [x.x.x.x]

To SMTP server: 22 bytes of data

SMTP Response: 250-xxx.outlook.office365.com Hello [x.x.x.x]

SMTP Response: 250-SIZE 78643200

SMTP Response: 250-PIPELINING

SMTP Response: 250-DSN

SMTP Response: 250-ENHANCEDSTATUSCODES

SMTP Response: 250-STARTTLS

SMTP Response: 250-AUTH

SMTP Response: 250-8BITMIME

SMTP Response: 250-BINARYMIME

SMTP Response: 250 CHUNKING

To SMTP server: STARTTLS

To SMTP server: 10 bytes of data

SMTP Response: 220 2.0.0 SMTP server ready

To SMTP server: EHLO [x.x.x.x]

To SMTP server: 22 bytes of data

SMTP Response: 250-xxx.outlook.office365.com Hello [x.x.x.x]

SMTP Response: 250-SIZE 78643200

SMTP Response: 250-PIPELINING

SMTP Response: 250-DSN

SMTP Response: 250-ENHANCEDSTATUSCODES

SMTP Response: 250-AUTH LOGIN

SMTP Response: 250-8BITMIME

SMTP Response: 250-BINARYMIME

SMTP Response: 250 CHUNKING

To SMTP server: AUTH LOGIN

To SMTP server: 12 bytes of data

SMTP Response: 334 VXNlcxxxxxxx

To SMTP server: YWRtaWxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx=

To SMTP server: 38 bytes of data

SMTP Response: 334 UGFxxxxxxxxx

To SMTP server: OTlTaGxxxxxxxxxx

To SMTP server: 18 bytes of data

SMTP Response: 235 2.7.0 Authentication successful

BLAH BLAH BLAH more email stuffs......

0 Kudos
Reply