cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
dlevasseur
Contributor
Contributor

Trouble Parking/retrieving Calls

Jump to solution

I've gotten this complaint several times since we RMA'd our Netvanta 7100 (on my 3rd unit in 9 months... ouch).  Call comes into the ring group, member picks up, presses the Park 1 button (we have park 1-6 on our Adtran 712 phones).  The call does not park.  Can't use the status buttons to park at all.  Similarly people have reported that they have a call on Park and they go to retrieve it and the button isn't labeled as retrieve and the call cannot be retrieved.

FYI we are using a status group to display the 6 park zones and they switch from park/retrieve when there are calls parked.

Just wondering if anyone has had this issue?  Known problem?  Is there a fix?  Our first and Second NetVanta 7100 units never had this issue.  It only started after we received Unit #3.

FWIW:

Firmware: A4.12.00.E

0 Kudos
1 Solution

Accepted Solutions
Anonymous
Not applicable

Re: Trouble Parking/retrieving Calls

Jump to solution

If the problem is intermittent your best bet is to enable a persistent debug that runs indefinitely.  We wrote a guide detailing instructions on how to set this up.  Here is a link to it: .  If you can catch it with this debug please also try to note the following information if possible so we can track it down: extension of the phone having problems with the park, the time the problem happened, and the caller-ID of the number being parked.

If you can upload the following information to the FTP server ahead of the debug I would be happy to look through it:

  • the current 7100 configuration
  • phone config files: adtran_<mac-address-of-phone>.txt
  • output of show sip user-registration or screenshot of Voice > Reports > SIP Registration List
  • list of extensions that have experienced the problem

Thanks,
Matt

View solution in original post

0 Kudos
11 Replies
Anonymous
Not applicable

Re: Trouble Parking/retrieving Calls

Jump to solution

Using a park zone as a status group (BLF) was not supported on ADTRAN IP 700 phones until R2.2.0.  A warning was printed about this on page 3 of our Status Groups configuration guide.  If you would like to upgrade to take advantage of this feature you can download the firmware here and follow this guide for updating the phones: .  This feature has always been supported on Polycom phones, but prior to R2.2.0 phone firmware you could have had unpredictable results on ADTRAN IP 700 phones as it was not an officially support feature.

Thanks,
Matt

dlevasseur
Contributor
Contributor

Re: Trouble Parking/retrieving Calls

Jump to solution

Matt,

I'm just going with what Adtran set up for us.  Honestly I try not to touch things if I don't have to. 

I looked in via the GUI and FTP and I believe it shows we are using 2.1.0?  How can I find out for sure?  Is there any way to push this config to just one phone?

Anonymous
Not applicable

Re: Trouble Parking/retrieving Calls

Jump to solution

To check the current firmware of the phones from the web interface you can go to Voice > Reports > SIP Registration List.  The firmware version will be present in the Phone Type column.

The firmware is applied from Voice > IP Phone Globals > Boot Settings tab > Default Firmware tab but is delivered to a phone only upon a reboot.  Write down or take a screenshot of how the names are set currently so you can revert if desired.  To upgrade only one phone follow all of the steps outlined in the guide referenced from my last post but reboot only one phone after setting the dropdown boxes to the appropriate new file names on the Default Firmware tab.  After upgrading your test phone you can either revert the file names back to what they were previously or leave the new firmware.

Thanks,

Matt

dlevasseur
Contributor
Contributor

Re: Trouble Parking/retrieving Calls

Jump to solution


We continue to have the same issue even after updating to the 2.2 firmware.  Users of the Adtran 700 series phones randomly cannot park or retrieve calls using either a BLF OR the actual park button.  So this seems more of a system problem than a phone/firmware problem.

Anonymous
Not applicable

Re: Trouble Parking/retrieving Calls

Jump to solution

Did you upgrade all phones or only a particular phone?  If you only upgraded one phone and did the park BLF from it but tried to retrieve it from a park BLF on another phone running 1.3.x firmware you can still run into issues.  You can check the firmware of the phones by going to Voice > Reports > SIP Registration List.  If all phones involved in the test show they are running 2.2 from that page in the web interface we would need to see the 7100 config, the phone config files, and the output from a debug voice verbose as well as a debug sip stack messages while the issue is recreated.  If you want to submit those you can zip them up and place them on our FTP server from the instructions below.  Please respond to this post with the exact file name of the zip file so I can retrieve them.


Open Internet Explorer web browser on their PC
Type the following URL:  ftp://ftp.adtran.com
Double-click the "Incoming" folder
Drag and drop files from PC into the Internet Explorer window


Thanks,
Matt

dlevasseur
Contributor
Contributor

Re: Trouble Parking/retrieving Calls

Jump to solution

It has only been a retrieve issue once or twice, it is mostly a park issue.  So parking from one and retrieving on another could be a problem, but the issue is at the parking stage.

As for recreating the issue, it is so intermittent that I wouldn't even know where to begin.  So when it happens We'd have to tell our customer "hang out on the line while we debug some phone problems we are having please".  That's kinda tacky.  I'll do my best to get that for you, but who knows if/when it will happen again.

Anonymous
Not applicable

Re: Trouble Parking/retrieving Calls

Jump to solution

If the problem is intermittent your best bet is to enable a persistent debug that runs indefinitely.  We wrote a guide detailing instructions on how to set this up.  Here is a link to it: .  If you can catch it with this debug please also try to note the following information if possible so we can track it down: extension of the phone having problems with the park, the time the problem happened, and the caller-ID of the number being parked.

If you can upload the following information to the FTP server ahead of the debug I would be happy to look through it:

  • the current 7100 configuration
  • phone config files: adtran_<mac-address-of-phone>.txt
  • output of show sip user-registration or screenshot of Voice > Reports > SIP Registration List
  • list of extensions that have experienced the problem

Thanks,
Matt

View solution in original post

0 Kudos
Anonymous
Not applicable

Re: Trouble Parking/retrieving Calls

Jump to solution

dlevasseur,

I just wanted to check in on this issue.  Were you able to catch anything with the persistent debug?

Thanks,
Matt

Anonymous
Not applicable

Re: Trouble Parking/retrieving Calls

Jump to solution

I just wanted to add a note to this post to mention that 2.4.1 firmware was released for the IP 700 phones, which does include some recent fixes to Park BLF:

It may not be the source of this issue, but would definitely be worth a try if it is still happening.

Thanks,

Matt

dlevasseur
Contributor
Contributor

Re: Trouble Parking/retrieving Calls

Jump to solution

The 2.2 firmware seemed to fix it.  I'd consider moving to 2.4 but everything is working properly right now and no complaints.

Anonymous
Not applicable

Re: Trouble Parking/retrieving Calls

Jump to solution

I'm glad to hear that.  Thanks for the update.

Thanks,

Matt