cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
amoffett
New Contributor

Call to own number loses audio after 30 minutes

I have a TA916 set up as a SIP to PRI gateway to connect VoIP service to a PRI interface on a PBX.

The client has added a conference bridge feature on the PBX, but for a user in the building to join the conference they have to call the external number of the conference bridge (the phone system vendor says this can't be reached on an internal extension, they apparently *have* to use the external number).  So they end up with an outbound call that the VoIP carrier sends back to the, and two channels open.  Like this

[Desk Phone] <-> [PBX] <-PRI-> [Adtran TA916] <-Internet-> [VoIP provider] <-Internet-> [Adtran TA916] <-PRI-> [PBX] <-> [Conference Bridge]

What happens is after exactly 30 minutes they'll lose audio on these calls that are circling back in.  In a packet capture we see a SIP re-invite at the 30 minute mark also....I'm assuming that's related.  I tried to do a dsp capture of these calls to verify whether audio is making it to the PRI port, but the capture DAT files are filled with all 1's.  I did verify the capture method with a "normal" phone call, but these ones where it's looping back in the dsp capture gives me no data (files filled with all 1's).  I'm guessing that means the call isn't even touching the DSP?  Is the DSP not in use because it's bridging the PRI B channels together?

Anybody know what's going on here and how can I prevent the audio dropping?

 

0 Kudos
2 Replies
davidlas
New Contributor

Re: Call to own number loses audio after 30 minutes

Hi @amoffett

I have the same problem as you

ronp
New Contributor II

Re: Call to own number loses audio after 30 minutes

What brand firewall?