I am hoping this will be my final question on this specific journey. I have a TA900 that is currently serving an older PBX with PRI. I have also been working on installing a soft switch behind the TA900. I am able to place outbound calls from the softswitch but inbound calls are not making it. Initially I was seeing a 404 error on the adtran but after playing with the config some more I lost that as well? Luckily PRI continues to work as expected!
I tried adding another the following for inbound calls with no success. Not sure how to register a trunk from the PBX to Adtran either.
Voice Trunk T03 type SIP
sip-server primary 192.168.33.1
transfer-mode network
grammer from host local
Voice grouped-Trunk PBX
accept 13235556666 cost 0
Current Config
!
!
clock timezone -8
!
ip subnet-zero
ip classless
ip routing
ipv6 unicast-routing
auto-config
!
ip firewall
no ip firewall alg msn
no ip firewall alg mszone
no ip firewall alg h323
!
!
!
!
!
!
!
!
no dot11ap access-point-control
!
interface eth 0/1
description WAN
ip address 76.10.76.10 255.255.255.248
ip address 76.10.76.11 255.255.255.255 secondary
ip access-policy Public
media-gateway ip primary
no shutdown
!
!
interface eth 0/2
description (LAN)
ip address 192.168.33.1 255.255.255.0
ip access-policy Private
media-gateway ip primary
no awcp
no shutdown
!
!
!
interface gigabit-eth 0/1
no ip address
shutdown
!
!
!
!
interface t1 0/1
shutdown
!
interface t1 0/2
shutdown
!
interface t1 0/3
lbo short 15
tdm-group 1 timeslots 1-24 speed 64
no shutdown
!
interface t1 0/4
shutdown
!
!
interface pri 1
isdn name-delivery proceeding
connect t1 0/3 tdm-group 1
digits-transferred 4
no shutdown
!
!
interface fxs 0/1
impedance 600r
no shutdown
!
interface fxs 0/2
no shutdown
!
interface fxs 0/3
no shutdown
!
interface fxs 0/4
no shutdown
!
interface fxs 0/5
no shutdown
!
interface fxs 0/6
no shutdown
!
interface fxs 0/7
no shutdown
!
interface fxs 0/8
no shutdown
!
interface fxs 0/9
no shutdown
!
interface fxs 0/10
no shutdown
!
interface fxs 0/11
no shutdown
!
interface fxs 0/12
no shutdown
!
interface fxs 0/13
no shutdown
!
interface fxs 0/14
no shutdown
!
interface fxs 0/15
no shutdown
!
interface fxs 0/16
no shutdown
!
interface fxs 0/17
no shutdown
!
interface fxs 0/18
no shutdown
!
interface fxs 0/19
no shutdown
!
interface fxs 0/20
no shutdown
!
interface fxs 0/21
no shutdown
!
interface fxs 0/22
no shutdown
!
interface fxs 0/23
no shutdown
!
interface fxs 0/24
no shutdown
!
!
isdn-group 1
connect pri 1
!
!
!
!
!
!
!
!
ip access-list standard allow-all
remark allow all traffic
permit any
!
ip access-list standard mgmt-allow-list
70.11.11.99
!
ip access-list standard sip-allow-list
permit hostname xx.com
!
!
ip access-list extended WEB-ACL-3
permit tcp any any eq https
permit tcp any any eq ssh
!
ip access-list extended WEB-ACL-4
remark 1:1 NAT 76.10.76.11 > 192.168.33.11
permit ip any host 76.10.76.11
!
ip access-list extended WEB-ACL-5
remark 1:1 NAT 192.168.33.11 > 76.10.76.11
permit ip host 192.168.33.11 any
!
!
ip policy-class Private
nat source list allow-all interface eth 0/1 overload policy Public
allow list allow-all self
nat source list WEB-ACL-5 address 76.10.76.11 overload
!
ip policy-class Public
nat destination list WEB-ACL-4 address 192.168.33.11
allow list allow-all self
allow list WEB-ACL-3 self
!
!
!
ip route 0.0.0.0 0.0.0.0 76.10.76.10
!
no tftp server
no tftp server overwrite
no http server
http secure-server
no snmp agent
no ip ftp server
no ip scp server
no ip sntp server
!
!
sip
sip udp 5060
no sip tcp
!
!
!
voice feature-mode network
voice forward-mode network
!
!
voice dial-plan 2 long-distance 1-NXX-NXX-XXXX
!
!
!
!
voice codec-list VOICE
default
codec g711ulaw
!
voice codec-list FAX
codec g711ulaw
!
!
!
voice trunk T01 type sip
description "SIP"
match dnis "91-NXX-NXX-XXXX" substitute "1-NXX-NXX-XXXX"
match dnis "9NXX-XXXX" substitute "1-310-NXX-XXXX"
match dnis "NXX-NXX-XXXX" substitute "1-NXX-NXX-XXXX"
match dnis "NXX-XXXX" substitute "1-310-NXX-XXXX"
sip-server primary 88.88.88.88
registrar primary 88.88.88.88
domain "76.10.76.10"
register 100XXXXXXX auth-name "" password ""
codec-list VOICE both
authentication username "" password ""
!
voice trunk T02 type isdn
description "DSX-1"
resource-selection linear ascending
connect isdn-group 1
no early-cut-through
match dnis "1800XXXXXXX" substitute "13235551212"
match dnis "1844XXXXXXX" substitute "13235551212"
rtp delay-mode adaptive
codec-list VOICE
!
!
voice grouped-trunk SIP
trunk T01
accept $ cost 0
!
!
!
!
voice grouped-trunk ISDN
trunk T02
accept 1323XXXXXXX cost 0
!
sip access-class ip "sip-allow-list" in
!
line con 0
no login
!
line telnet 0 4
login local-userlist
password password
shutdown
ip access-class mgmt-allow-list in
line ssh 0 4
login local-userlist
no shutdown
ip access-class mgmt-allow-list in
!
!
!
!
!
end
g-man wrote:
I tried adding another the following for inbound calls with no success. Not sure how to register a trunk from the PBX to Adtran either.
Voice Trunk T03 type SIP
sip-server primary 192.168.33.1
transfer-mode network
grammer from host local
Voice grouped-Trunk PBX
accept 13235556666 cost 0
Try adding:
Voice grouped-Trunk PBX
trunk T03
accept 13235556666 cost 0
I was able to get the log of my calls and it looks like 76.10.76.11 which is the secondary address is not responding to invites. Shouldn't
ip access-list standard sip-allow-list
permit hostname xx.com
allow the sip traffic to the switch?
g-man wrote:
I tried adding another the following for inbound calls with no success. Not sure how to register a trunk from the PBX to Adtran either.
Voice Trunk T03 type SIP
sip-server primary 192.168.33.1
transfer-mode network
grammer from host local
Voice grouped-Trunk PBX
accept 13235556666 cost 0
Try adding:
Voice grouped-Trunk PBX
trunk T03
accept 13235556666 cost 0
g-man wrote:
I was able to get the log of my calls and it looks like 76.10.76.11 which is the secondary address is not responding to invites. Shouldn't
ip access-list standard sip-allow-list
permit hostname xx.com
allow the sip traffic to the switch?
OK, it looks like there are a couple of oddities here.
Your softswitch is on the LAN with an address of 192.168.33.XX, correct?
Add that private IP to your sip-allow-list .
You have trunk T03 pointing to your own interface as the SIP server. Point it to the IP of your softswitch. On the softswitch, point its SIP server address to 192.168.33.1.
Also note that a few firmware revisions back, Adtran deliberately broke the ability of TA900 devices to process some SIP-to-SIP calls unless you purchase an extra SBC license so you may need that to move forward. It's relatively cheap but quite an annoyance.
jayh,
Thank you so much for the assistance. I did as you suggested and still nothing. What is odd is that the call is not even making it to the TA. I tried SIP debug but I do not see anything. When I ask the SIP provider they say they are not getting a response to the invite. I would at least expect to see something. I am sending calls to the secondary address on the TA. Would the license be causeing such an isue
Is there any way to make this work directly between the softswitch and SIP Provider and bypass the adtran for SIP? I can register and make outbound calls going directly to the provider, just need a way to get the calls to the softswitch. Basically just use it as a Router
I inquired with adtran about the license. It seems like something is blocking my invite from the provider yet I have other calls that are processing?
Routing a call from one SIP trunk to another SIP trunk does require an SBC license, however if the ADTRAN receives an INVITE, it will at least acknowledge the packet, as long as the request-URI has the ADTRAN's IP address (addressed to the ADTRAN). If the SIP packet is not addressed to the ADTRAN, then the ADTRAN will not respond.
g-man wrote:
jayh,
Thank you so much for the assistance. I did as you suggested and still nothing. What is odd is that the call is not even making it to the TA. I tried SIP debug but I do not see anything. When I ask the SIP provider they say they are not getting a response to the invite.
Is this the same SIP provider that is sending calls to the PRI, and is the provider sending them in the same manner? Don't use the secondary address, use the main interface address just as you to for calls to the PRI.
What happens if you configure the grouped-trunk on the softswitch T03 to accept one of the numbers now routed to the PRI? Does that call now go to the softswitch?
g-man wrote:
Is there any way to make this work directly between the softswitch and SIP Provider and bypass the adtran for SIP? I can register and make outbound calls going directly to the provider, just need a way to get the calls to the softswitch. Basically just use it as a Router
You could put a switch on the public side ahead of the Adtran and configure the softswitch to be directly on the Internet. Make sure that you have security very well locked down on the softswitch. It also makes calls between the softswitch and the PRI take a sub-optimal path. I'd use the Adtran even if it means shelling out for the license or going back to older firmware before Adtran crippled it. More flexible and secure.
As far as registering the softswitch to the Adtran, you can do this but there is really no need to if it's directly on the LAN connected to the Adtran. Just reference it by IP address in the trunk.
I just tried that exact thing and the call does not make it to the softswitch. I don't even see the call hit the adtran. I pointed the softswitch calls to the Public IP of the secondary interface, the PBX is going to the first.
I contacted adtran and they said I didn't need the license? I have no problem getting a license. The thing that puzzles me is why am I not seeing the invite on calls routed to the softswitch?
I just got an invite from the PRI side.
09:40:42.181 SIP.STACK MSG Rx: UDP src=88.88.88.88:5060 dst=76.10.76.11:5060
09:40:42.181 SIP.STACK MSG INVITE sip:13237360311@76.10.76.11 SIP/2.0
09:40:42.182 SIP.STACK MSG Via: SIP/2.0/UDP 88.88.88.88:5060;branch=z9hG4bKcvpnng008g81vf0fn7k0.1
09:40:42.182 SIP.STACK MSG From: "Bernard,St." <sip:+16264919734@88.88.88.88>;tag=SDphks201-gK0458d68d
09:40:42.182 SIP.STACK MSG To: <sip:13237360311@76.10.76.11>
09:40:42.182 SIP.STACK MSG Remote-Party-ID: "Bernard,St." <sip:+16264919734@88.88.88.88:5060>;privacy=off;screen=yes
09:40:42.182 SIP.STACK MSG Call-ID: SDphks201-7282d27c2edb07ed73bf4900e7e32ad7-523g533
09:40:42.182 SIP.STACK MSG CSeq: 984876 INVITE
09:40:42.182 SIP.STACK MSG Max-Forwards: 68
09:40:42.183 SIP.STACK MSG Allow: INVITE,ACK,CANCEL,BYE,OPTIONS
09:40:42.183 SIP.STACK MSG Accept: application/sdp
09:40:42.183 SIP.STACK MSG Contact: <sip:88.88.88.88:5060;did=72b.0dc32b76;transport=udp>
09:40:42.183 SIP.STACK MSG Supported: replaces
09:40:42.183 SIP.STACK MSG Content-Length: 254
09:40:42.183 SIP.STACK MSG Content-Disposition: session; handling=required
09:40:42.184 SIP.STACK MSG Content-Type: application/sdp
09:40:42.184 SIP.STACK MSG
09:40:42.184 SIP.STACK MSG v=0
09:40:42.184 SIP.STACK MSG o=- 3788767953 759660 IN IP4 99.99.99.99
09:40:42.184 SIP.STACK MSG s=-
09:40:42.184 SIP.STACK MSG c=IN IP4 99.99.99.99
09:40:42.184 SIP.STACK MSG t=0 0
09:40:42.185 SIP.STACK MSG m=audio 4666 RTP/AVP 0 18 101
09:40:42.185 SIP.STACK MSG a=rtpmap:0 PCMU/8000
09:40:42.185 SIP.STACK MSG a=rtpmap:18 G729/8000
09:40:42.185 SIP.STACK MSG a=fmtp:18 annexb=no
09:40:42.185 SIP.STACK MSG a=rtpmap:101 telephone-event/8000
09:40:42.185 SIP.STACK MSG a=fmtp:101 0-15
09:40:42.185 SIP.STACK MSG a=sendrecv
09:40:42.186 SIP.STACK MSG a=ptime:20
09:40:42.186 SIP.STACK MSG
09:40:42.190 SIP.STACK MSG Tx: UDP src=76.10.76.11:5060 dst=88.88.88.88:5060
09:40:42.190 SIP.STACK MSG SIP/2.0 100 Trying
09:40:42.190 SIP.STACK MSG From: "Bernard,St."<sip:+16264919734@88.88.88.88>;tag=SDphks201-gK0458d68d
09:40:42.190 SIP.STACK MSG To: <sip:13237360311@76.10.76.11>
09:40:42.190 SIP.STACK MSG Call-ID: SDphks201-7282d27c2edb07ed73bf4900e7e32ad7-523g533
09:40:42.190 SIP.STACK MSG CSeq: 984876 INVITE
09:40:42.191 SIP.STACK MSG Via: SIP/2.0/UDP 88.88.88.88:5060;branch=z9hG4bKcvpnng008g81vf0fn7k0.1
09:40:42.191 SIP.STACK MSG Contact: <sip:13237360311@76.10.76.11:5060;transport=UDP>
09:40:42.191 SIP.STACK MSG Supported: 100rel,replaces
09:40:42.191 SIP.STACK MSG Allow: ACK, BYE, CANCEL, INFO, INVITE, NOTIFY, OPTIONS, PRACK, REFER, REGISTER
09:40:42.191 SIP.STACK MSG User-Agent: ADTRAN_Total_Access_900e_3rd_Gen/R10.9.5.E
09:40:42.191 SIP.STACK MSG Content-Length: 0
09:40:42.192 SIP.STACK MSG
09:40:42.197 SIP.STACK MSG Tx: UDP src=76.10.76.11:5060 dst=192.168.33.3:5060
09:40:42.197 SIP.STACK MSG INVITE sip:13237360311@192.168.33.3:5060 SIP/2.0
09:40:42.198 SIP.STACK MSG From: "Bernard,St." <sip:6264919734@76.10.76.11:5060;transport=UDP>;tag=63139890-a0a5801-13c4-1401a-2ea8031f-1401a
09:40:42.198 SIP.STACK MSG To: <sip:13237360311@192.168.33.3:5060>
09:40:42.198 SIP.STACK MSG Call-ID: 63161588-a0a5801-13c4-1401a-113af5b4-1401a@76.10.76.11
09:40:42.198 SIP.STACK MSG CSeq: 1 INVITE
09:40:42.198 SIP.STACK MSG Via: SIP/2.0/UDP 76.10.76.11:5060;branch=z9hG4bK-1401a-4e266b6-3abb03d
09:40:42.198 SIP.STACK MSG Max-Forwards: 70
09:40:42.199 SIP.STACK MSG Supported: 100rel,replaces
09:40:42.199 SIP.STACK MSG Allow: ACK, BYE, CANCEL, INFO, INVITE, NOTIFY, OPTIONS, PRACK, REFER, REGISTER
09:40:42.199 SIP.STACK MSG User-Agent: ADTRAN_Total_Access_900e_3rd_Gen/R10.9.5.E
09:40:42.199 SIP.STACK MSG Contact: <sip:6264919734@76.10.76.11:5060;transport=UDP>
09:40:42.199 SIP.STACK MSG Content-Type: application/sdp
09:40:42.199 SIP.STACK MSG Content-Length: 234
09:40:42.199 SIP.STACK MSG
09:40:42.200 SIP.STACK MSG v=0
09:40:42.200 SIP.STACK MSG o=- 3788767953 759660 IN IP4 99.99.99.99
09:40:42.200 SIP.STACK MSG s=-
09:40:42.200 SIP.STACK MSG c=IN IP4 99.99.99.99
09:40:42.200 SIP.STACK MSG t=0 0
09:40:42.200 SIP.STACK MSG m=audio 4666 RTP/AVP 0 101
09:40:42.200 SIP.STACK MSG a=sendrecv
09:40:42.201 SIP.STACK MSG a=ptime:20
09:40:42.201 SIP.STACK MSG a=rtpmap:0 PCMU/8000
09:40:42.201 SIP.STACK MSG a=silenceSupp:off - - - -
09:40:42.201 SIP.STACK MSG a=rtpmap:101 telephone-event/8000
09:40:42.201 SIP.STACK MSG a=fmtp:101 0-15
09:40:42.201 SIP.STACK MSG
09:40:42.702 SIP.STACK MSG Tx: UDP src=76.10.76.11:5060 dst=192.168.33.3:5060
09:40:42.702 SIP.STACK MSG INVITE sip:13237360311@192.168.33.3:5060 SIP/2.0
09:40:42.702 SIP.STACK MSG From: "Bernard,St." <sip:6264919734@76.10.76.11:5060;transport=UDP>;tag=63139890-a0a5801-13c4-1401a-2ea8031f-1401a
09:40:42.702 SIP.STACK MSG To: <sip:13237360311@192.168.33.3:5060>
09:40:42.702 SIP.STACK MSG Call-ID: 63161588-a0a5801-13c4-1401a-113af5b4-1401a@76.10.76.11
09:40:42.703 SIP.STACK MSG CSeq: 1 INVITE
09:40:42.703 SIP.STACK MSG Via: SIP/2.0/UDP 76.10.76.11:5060;branch=z9hG4bK-1401a-4e266b6-3abb03d
09:40:42.703 SIP.STACK MSG Max-Forwards: 70
09:40:42.703 SIP.STACK MSG Supported: 100rel,replaces
09:40:42.703 SIP.STACK MSG Allow: ACK, BYE, CANCEL, INFO, INVITE, NOTIFY, OPTIONS, PRACK, REFER, REGISTER
09:40:42.703 SIP.STACK MSG User-Agent: ADTRAN_Total_Access_900e_3rd_Gen/R10.9.5.E
09:40:42.704 SIP.STACK MSG Contact: <sip:6264919734@76.10.76.11:5060;transport=UDP>
09:40:42.704 SIP.STACK MSG Content-Type: application/sdp
09:40:42.704 SIP.STACK MSG Content-Length: 234
09:40:42.704 SIP.STACK MSG
09:40:42.704 SIP.STACK MSG v=0
09:40:42.704 SIP.STACK MSG o=- 3788767953 759660 IN IP4 99.99.99.99
09:40:42.705 SIP.STACK MSG s=-
09:40:42.705 SIP.STACK MSG c=IN IP4 99.99.99.99
09:40:42.705 SIP.STACK MSG t=0 0
09:40:42.705 SIP.STACK MSG m=audio 4666 RTP/AVP 0 101
09:40:42.705 SIP.STACK MSG a=sendrecv
09:40:42.705 SIP.STACK MSG a=ptime:20
09:40:42.705 SIP.STACK MSG a=rtpmap:0 PCMU/8000
09:40:42.706 SIP.STACK MSG a=silenceSupp:off - - - -
09:40:42.706 SIP.STACK MSG a=rtpmap:101 telephone-event/8000
09:40:42.706 SIP.STACK MSG a=fmtp:101 0-15
09:40:42.706 SIP.STACK MSG
09:40:43.707 SIP.STACK MSG Tx: UDP src=76.10.76.11:5060 dst=192.168.33.3:5060
09:40:43.707 SIP.STACK MSG INVITE sip:13237360311@192.168.33.3:5060 SIP/2.0
09:40:43.707 SIP.STACK MSG From: "Bernard,St." <sip:6264919734@76.10.76.11:5060;transport=UDP>;tag=63139890-a0a5801-13c4-1401a-2ea8031f-1401a
09:40:43.707 SIP.STACK MSG To: <sip:13237360311@192.168.33.3:5060>
09:40:43.707 SIP.STACK MSG Call-ID: 63161588-a0a5801-13c4-1401a-113af5b4-1401a@76.10.76.11
09:40:43.708 SIP.STACK MSG CSeq: 1 INVITE
09:40:43.708 SIP.STACK MSG Via: SIP/2.0/UDP 76.10.76.11:5060;branch=z9hG4bK-1401a-4e266b6-3abb03d
09:40:43.708 SIP.STACK MSG Max-Forwards: 70
09:40:43.708 SIP.STACK MSG Supported: 100rel,replaces
09:40:43.708 SIP.STACK MSG Allow: ACK, BYE, CANCEL, INFO, INVITE, NOTIFY, OPTIONS, PRACK, REFER, REGISTER
09:40:43.708 SIP.STACK MSG User-Agent: ADTRAN_Total_Access_900e_3rd_Gen/R10.9.5.E
09:40:43.709 SIP.STACK MSG Contact: <sip:6264919734@76.10.76.11:5060;transport=UDP>
09:40:43.709 SIP.STACK MSG Content-Type: application/sdp
09:40:43.709 SIP.STACK MSG Content-Length: 234
09:40:43.709 SIP.STACK MSG
09:40:43.709 SIP.STACK MSG v=0
09:40:43.709 SIP.STACK MSG o=- 3788767953 759660 IN IP4 99.99.99.99
09:40:43.709 SIP.STACK MSG s=-
09:40:43.710 SIP.STACK MSG c=IN IP4 99.99.99.99
09:40:43.710 SIP.STACK MSG t=0 0
09:40:43.710 SIP.STACK MSG m=audio 4666 RTP/AVP 0 101
09:40:43.710 SIP.STACK MSG a=sendrecv
09:40:43.710 SIP.STACK MSG a=ptime:20
09:40:43.710 SIP.STACK MSG a=rtpmap:0 PCMU/8000
09:40:43.711 SIP.STACK MSG a=silenceSupp:off - - - -
09:40:43.711 SIP.STACK MSG a=rtpmap:101 telephone-event/8000
09:40:43.711 SIP.STACK MSG a=fmtp:101 0-15
09:40:43.711 SIP.STACK MSG
09:40:44.212 SIP.STACK MSG
09:40:45.205 SIP.STACK MSG Tx: UDP src=76.10.76.11:5060 dst=88.88.88.88:5060
09:40:45.205 SIP.STACK MSG SIP/2.0 503 Service Unavailable
09:40:45.205 SIP.STACK MSG From: "Bernard,St."<sip:+16264919734@88.88.88.88>;tag=SDphks201-gK0458d68d
09:40:45.205 SIP.STACK MSG To: <sip:13237360311@76.10.76.11>;tag=63138c18-a0a5801-13c4-1401d-4ad6b38d-1401d
09:40:45.206 SIP.STACK MSG Call-ID: SDphks201-7282d27c2edb07ed73bf4900e7e32ad7-523g533
09:40:45.206 SIP.STACK MSG CSeq: 984876 INVITE
09:40:45.206 SIP.STACK MSG Via: SIP/2.0/UDP 88.88.88.88:5060;branch=z9hG4bKcvpnng008g81vf0fn7k0.1
09:40:45.206 SIP.STACK MSG Supported: 100rel,replaces
09:40:45.206 SIP.STACK MSG Allow: ACK, BYE, CANCEL, INFO, INVITE, NOTIFY, OPTIONS, PRACK, REFER, REGISTER
09:40:45.206 SIP.STACK MSG User-Agent: ADTRAN_Total_Access_900e_3rd_Gen/R10.9.5.E
09:40:45.206 SIP.STACK MSG Content-Length: 0
Voice Verbose
09:54:32.108 TM.T01 01 SipTM_Idle rcvd SIP call-leg request: INVITE
09:54:32.108 TM.T01 01 SipTM_Idle call-leg -> Offering
09:54:32.109 TM.T01 01 SipTM_Idle State change >> SipTM_Idle->SipTM_Trying
09:54:32.109 TM.T01 01 SipTM_Trying SDP offer is not loopback request
09:54:32.109 TM.T01 01 SipTM_Trying Processing From for Caller-ID.
09:54:32.110 TM.T01 01 T01 01 SipTM_Trying e164 calling number converted to dialstring 13235551212
09:54:32.110 TM.T01 01 SipTM_Trying Caller ID Name = "Bernard, St"
09:54:32.110 TM.T01 01 SipTM_Trying Caller ID Number = "13235551212"
09:54:32.110 TM.T01 01 SipTM_Trying info: unable to set redirect number(s) from INVITE
09:54:32.110 TM.T01 01 SipTM_Trying sent: TA->InboundCall
09:54:32.111 TM.T01 01 Looking up source address for destination 69.69.69.69
09:54:32.111 TM.T01 01 call-leg (0x0x63161390) -> src: 76.10.76.10: 5060 dst: 69.69.69.69 : 5060
09:54:32.112 TM.T01 01 SipTM_Trying sent: 100 Trying
09:54:32.112 TA.T01 01 TAIdle rcvd: inboundCall from TM
09:54:32.113 TA.T01 01 State change >> TAIdle->TAInboundCall (TAS_Calling)
09:54:32.113 TA.T01 01 Failed - DID translation: no match for 13237360311, using 13237360311
09:54:32.113 TA.T01 01 TAIdle sent: call to SB
09:54:32.113 TM.T01 01 SipTM_Trying tachg -> TAInboundCall
09:54:32.113 TM.T01 01 SipTM_Trying State change >> SipTM_Trying->SipTM_Pending
09:54:32.114 SB.CALL 479 Idle Called the call routine with 13237360311
09:54:32 SB.TGMgr For dialed number 13237360311, against template $, on TrunkGroup SIP, the score is 500
09:54:32 SB.TGMgr For dialed number 13237360311, against template 13237360311, on TrunkGroup PBX, the score is 12000
09:54:32.114 SB.CCM isMappable:
09:54:32.115 SB.CCM : Call Struct 0x0x7520e610 : Call-ID = 479
09:54:32.115 SB.CCM : Org Acct = T01 Dst Acct = T03
09:54:32.115 SB.CCM : Org Port ID = SipTrunk 0/0 Dst Port ID = unknown 0/0
09:54:32.115 SB.CCM : SDP Transaction = CallID: 479
09:54:32.115 SB.CCM : SDP Offer = 0x75201310, (88.88.88.88:44666)
09:54:32.116 SB.CCM isMappable: Call Connection Type is RTP_TO_RTP
09:54:32.116 SB.CCM handleRtpToRtp: Modifying SDP Offer
09:54:32.116 SB.CCM translateOffer: offer codec list: PCMU G729
09:54:32.117 SB.CCM translateOffer: revised offer codec list: PCMU
09:54:32.117 SB.CCM translateOffer: codec list after answerer: PCMU
09:54:32.118 SB.CCM translateOffer: DTMF signaling: answerer has no restrictions configured, passing offer(NTE 101) through
09:54:32.118 SB.CCM translateOffer: success
09:54:32.118 MEDIA.MANAGER Allocating media port.
09:54:32.119 MEDIA.MANAGER getSubstitutePort: No matching callIdMap entry found for call 479
09:54:32.119 MEDIA.MANAGER Call ID map : Added new entry : call ID 479 : session -3249275585INIP488.88.88.88 : version 951176 : index 1712
09:54:32.119 MEDIA.MANAGER New media entry : type(0), callID(479), sessionID(-3249275585INIP488.88.88.88), original IP(88.88.88.88) ports(44666-44667), substitute IP(::) ports(11712-11713), RtpChannel(NULL), connection(0x0x75313710), sdpOverride(0), me(0x0x75202310). No RtpChannel
09:54:32.119 SB.CALL 479 Idle Call sent from T01 to T03 (13237360311)
09:54:32.120 SB.CALL 479 State change >> Idle->Delivering
09:54:32.120 TA.T01 01 TAInboundCall CallResp event accepted
09:54:32.120 TA.T01 01 State change >> TAInboundCall->TAConnectWaitIn (TAS_Calling)
09:54:32.120 TA.T03 91 State change >> TAIdle->TAOutGoing (TAS_Delivering)
09:54:32.121 TM.T03 91 SipTM_Idle State change >> SipTM_Idle->Delivering
09:54:32.121 TM.T03 91 Delivering Applying E.164 settings to called party number (13237360311)
09:54:32.121 TM.T03 91 Delivering Skipping E.164 conversion due to voice international-prefix setting
09:54:32.121 TM.T03 91 Delivering Applying E.164 settings to calling party number (13235551212)
09:54:32.121 TM.T03 91 Delivering From user grammar setting is: domestic
09:54:32.122 TM.T03 91 Delivering Skipping E.164 conversion due to From user grammar setting
09:54:32.122 TM.T03 91 Looking up source address for destination 192.168.33.1
09:54:32.122 TM.T03 91 call-leg (0x0x63161f60) -> src: 76.10.76.10: 5060 dst: 192.168.33.1 : 5060
09:54:32.123 TM.T03 91 SDP DPI call ID 479 : No media bin.
09:54:32.123 TM.T03 91 Processing new SDP entries.
09:54:32.123 TM.T03 91 Checking for internal Media Gateway IP Address
09:54:32.123 TM.T03 91 RTP Channel is NULL, Media Gateway must not be involved in call
09:54:32.124 TM.T03 91 Undo of previous operation not required (RTP NAT Entry for 88.88.88.88:44666 not found)
09:54:32.124 TM.T03 91 Checking for internal Media Gateway IP Address
09:54:32.124 TM.T03 91 Given RTP Channel is null, checking for hairpinned RTP Channel
09:54:32.124 TM.T03 91 RTP Channel is NULL, Media Gateway must not be involved in call
09:54:32.124 TM.T03 91 Checking need for firewall traversal
09:54:32.124 TM.T03 91 Testing firewall policies
09:54:32.125 TM.T03 91 NAT not required, no need for firewall traversal here
09:54:32.126 TM.T03 91 Delivering call-leg -> Inviting
09:54:32.127 TM.T03 91 Delivering sent: INVITE
09:54:32.127 SB.CALL 479 Delivering Called the deliverResponse routine from Delivering
09:54:32.127 SB.CALL 479 Delivering DeliverResponse(accept) sent from T03 to T01
09:54:32.128 TA.T01 01 TAConnectWaitIn deliverResponse event accepted
09:54:32.128 TA.T01 01 TAConnectWaitIn ERROR! deliverResponse ignored
09:54:32 SB.CallStructObserver 479 Created
09:54:32 SB.CallStructObserver 479 <-> SDvpmc201-8d7cb69aee75599fcfc00a6d83e883a0-523g533
09:54:35.128 TM.T03 91 INVITE rollover timeout
09:54:35.128 TM.T03 91 Delivering Sip_CreateCallLegNextServer with default validator
09:54:35.128 TM.T03 91 Delivering State change >> Delivering->SipTM_Closing
09:54:35.129 TM.T03 91 SipTM_Closing sent: TA->Clear
09:54:35.129 TM.T03 91 SipTM_Closing call-leg -> Terminated
09:54:35.129 TA.T03 91 TAOutGoing rcvd: clear from TM
09:54:35.129 TA.T03 91 State change >> TAOutGoing->TATrunkClearing (TAS_Clearing)
09:54:35.130 TM.T03 91 SipTM_Closing tachg -> TATrunkClearing
09:54:35.130 TM.T03 91 SipTM_Closing State change >> SipTM_Closing->SipTM_Terminated
09:54:35.130 TM.T03 91 SipTM_Terminated sent: TA->AppearanceOff
09:54:35.130 TM.T03 91 SipTM_Terminated State change >> SipTM_Terminated->SipTM_Idle
09:54:35.130 SB.CALL 479 Delivering Called the clearCall routine
09:54:35.131 SB.CALL 479 Delivering SIP Proxy rejected call to 13237360311 for survivability - no matching Proxy user
09:54:35.131 SB.CALL 479 Delivering No available resources on call from T01 to T03 (last attempt)
09:54:35.131 SB.CALL 479 State change >> Delivering->Clearing
09:54:35.131 TA.T03 91 TATrunkClearing rcvd: appearance off from TM
09:54:35.131 TA.T03 91 State change >> TATrunkClearing->TAClearingComplete (TAS_Clearing)
09:54:35.132 TA.T03 91 TATrunkClearing Processing an appearance OFF
09:54:35.132 TA.T01 01 TAConnectWaitIn ClearCall event accepted
09:54:35.132 TA.T01 01 State change >> TAConnectWaitIn->TAClearingComplete (TAS_Clearing)
09:54:35.132 TM.T01 01 SipTM_Pending tachg -> TAClearingComplete
09:54:35.132 TM.T01 01 SipTM_Pending State change >> SipTM_Pending->SipTM_CallFail
09:54:35.133 TM.T01 01 SipTM_CallFail call-leg -> Disconnected
09:54:35.134 TM.T01 01 SipTM_CallFail CallLegStateChanged to Disconnected - TM change to closing state.
09:54:35.134 TM.T01 01 SipTM_CallFail State change >> SipTM_CallFail->SipTM_Closing
09:54:35.134 TM.T01 01 SipTM_Closing sent: TA->Clear
09:54:35.134 TM.T01 01 SipTM_CallFail sent: 503
09:54:35.134 TM.T01 01 SipTM_Closing State change >> SipTM_Closing->SipTM_Terminated
09:54:35.135 TM.T01 01 SipTM_Terminated sent: TA->AppearanceOff
09:54:35.135 TM.T01 01 SipTM_Terminated State change >> SipTM_Terminated->SipTM_Idle
09:54:35.135 SB.CALL 479 Clearing Called the clearResponse routine
09:54:35.135 SB.CALL 479 State change >> Clearing->CallIdlePending
09:54:35.136 SB.CCM release:
09:54:35.136 SB.CCM : Call Struct 0x0x7520e610 : Call-ID = 479
09:54:35.136 SB.CCM : Org Acct = T01 Dst Acct = T03
09:54:35.136 SB.CCM : Org Port ID = SipTrunk 0/0 Dst Port ID = SipTrunk 0/0.290
09:54:35.136 SB.CCM : SDP Transaction = CallID: 479
09:54:35.137 SB.CCM : SDP Offer = 0x75201310, (88.88.88.88:44666)
09:54:35.137 SB.CCM release: Call Connection Type is RTP_TO_RTP
09:54:35.137 SB.CALL 479 CallIdlePending ClearResponse sent from T01 to T03
09:54:35.137 TA.T01 01 TAClearingComplete rcvd: clear from TM
09:54:35.137 TA.T01 01 TAClearingComplete rcvd: appearance off from TM
09:54:35.137 TA.T01 01 TAClearingComplete Clear Local Variables
09:54:35.138 TA.T01 01 State change >> TAClearingComplete->TAIdle (TAS_Idle)
09:54:35.138 TM.T01 01 SipTM_Idle tachg -> TAIdle
09:54:35.138 TA.T03 91 TAClearingComplete clearResponse event accepted
09:54:35.138 TA.T03 91 TAClearingComplete Clear Local Variables
09:54:35.138 TA.T03 91 State change >> TAClearingComplete->TAIdle (TAS_Idle)
09:54:35.139 TM.T03 91 SipTM_Idle tachg -> TAIdle
09:54:35 SB.CallStructObserver 479 Finalized
2019.04.11 09:54:36 SMDR 479 04/11/2019 09:54:32 0.0 0 E 00/00 Bernard, St 13235551212 00/00 T03 13237360311 0 N no debug voice verbose
RDLINC#
Your softswitch on 192.168.33.3 isn't responding to the invite, or its response is being filtered.
From your log the TA900 sent three invites and received no response.
09:40:42.197 SIP.STACK MSG | Tx: UDP src=76.10.76.11:5060 dst=192.168.33.3:5060 |
09:40:42.197 SIP.STACK MSG | INVITE sip:13237360311@192.168.33.3:5060 SIP/2.0 |
09:40:42.702 SIP.STACK MSG | Tx: UDP src=76.10.76.11:5060 dst=192.168.33.3:5060 |
09:40:42.702 SIP.STACK MSG | INVITE sip:13237360311@192.168.33.3:5060 SIP/2.0 |
09:40:43.707 SIP.STACK MSG | Tx: UDP src=76.10.76.11:5060 dst=192.168.33.3:5060 |
09:40:43.707 SIP.STACK MSG | INVITE sip:13237360311@192.168.33.3:5060 SIP/2.0 |
After the third attempt the Adtran gave up and sent 503 to your SIP provider.
09:40:45.205 SIP.STACK MSG | Tx: UDP src=76.10.76.11:5060 dst=88.88.88.88:5060 |
09:40:45.205 SIP.STACK MSG | SIP/2.0 503 Service Unavailable |
Is either 192.168.33.0 0.0.0.255 or host 192.168.33.3 in your sip-allow-list? It should be.
Is the softswitch programmed with its SIP server as 192.168.1.1 ? It should be.
Do you have "media-gateway ip primary" set on your LAN interface of 192.168.33.1? You should.
g-man wrote:
I contacted adtran and they said I didn't need the license? I have no problem getting a license. The thing that puzzles me is why am I not seeing the invite on calls routed to the softswitch?
According to the log snippet, the call is being sent to the softswitch, but the TA900 isn't getting a response or the response is being filtered.
I got it working!!! I still cannot route calls via the secondary address on eth0/1 but it will have to do. I was on a deadline to have this working by tomorrow and it looks like I am going to make it. Thank you sooo much.