Dear All,
Config is below. My incoming calls work just fine but outgoing calls do not work at all.
When I debug I get this message:
02:10:48.143 SB.CALL 26 Idle | Called the call routine with 918662556978 |
02:10:48.143 SB.CALL 26 Idle | No TRUNK accepted dialed number (918662556978) |
02:10:48.143 SB.CALL 26 Idle | No LOCAL station matched dialed number (918662556978) |
02:10:48.144 SB.CALL 26 Idle | No routable destination found on call from (1000) to (918662556978) |
02:10:48.144 SB.CALL 26 State change | >> Idle->CallIdlePending |
If annyone could help I would be very grateful
!
!
! ADTRAN, Inc. OS version A4.11.00.E
! Boot ROM version 12.06.00
! Platform: Total Access 908e (1st Gen), part number 4240908L1
! Serial number LBADTN0707AA431
!
!
hostname "xxx.shopxxxx.com"
enable password xxxx
!
!
ip subnet-zero
ip classless
ip default-gateway xx.xx.62.193
ip routing
!
!
ip domain-name "shopxxxx.com"
ip name-server 8.8.8.8 8.8.4.4
!
!
no auto-config
!
event-history on
no logging forwarding
no logging email
!
no service password-encryption
!
username "admin" password "xxxx"
!
!
ip firewall
ip firewall stealth
no ip firewall alg msn
no ip firewall alg mszone
no ip firewall alg h323
!
!
!
!
!
no dot11ap access-point-control
!
!
!
!
!
!
!
!
!
!
!
!
!
interface eth 0/1
ip address xx.xx.62.207 255.255.255.224
access-policy Primary
media-gateway ip primary
no awcp
no shutdown
!
!
interface eth 0/2
description TowerStream Backup Interface
ip address xx.xxx.173.13 255.255.255.192
access-policy Backup
media-gateway ip primary
no awcp
no shutdown
!
!
!
!
interface t1 0/1
shutdown
!
interface t1 0/2
shutdown
!
interface t1 0/3
shutdown
!
interface t1 0/4
shutdown
!
!
interface fxs 0/1
no shutdown
!
interface fxs 0/2
no shutdown
!
interface fxs 0/3
no shutdown
!
interface fxs 0/4
no shutdown
!
interface fxs 0/5
no shutdown
!
interface fxs 0/6
no shutdown
!
interface fxs 0/7
no shutdown
!
interface fxs 0/8
no shutdown
!
!
interface fxo 0/0
no shutdown
!
!
!
!
!
!
!
!
ip access-list extended web-acl-1
permit tcp any any eq www log
permit tcp any any eq https log
permit tcp any any eq ssh log
permit icmp any any echo log
!
ip access-list extended web-acl-2
permit tcp any any eq www log
permit tcp any any eq https log
permit tcp any any eq ssh log
permit icmp any any echo log
!
ip access-list extended web-acl-3
remark VOIP Port Forward Allow - UDP
permit udp any any eq 5060
!
ip access-list extended web-acl-4
remark VOIP Port Forward Allow - TCP
permit tcp any any eq 5060
!
ip access-list extended web-acl-5
remark VOIP Port Forward Allow - UDP
permit udp any any eq 5060
!
ip access-list extended web-acl-6
remark VOIP Port Forward Allow - TCP
permit tcp any any eq 5060
!
!
ip policy-class Backup
allow list web-acl-5
allow list web-acl-6
allow list web-acl-2 self
!
ip policy-class Primary
allow list web-acl-4
allow list web-acl-3
allow list web-acl-1 self
!
!
!
ip route 0.0.0.0 0.0.0.0 xx.xx.62.193
ip route 0.0.0.0 0.0.0.0 xx.xxx.173.1
!
no ip tftp server
no ip tftp server overwrite
ip http server
no ip http secure-server
no ip snmp agent
no ip ftp server
no ip scp server
no ip sntp server
!
!
!
!
!
!
ip sip
ip sip udp 5060
no ip sip tcp
!
!
voice international-prefix abbreviated
!
voice feature-mode network
voice forward-mode network
!
!
!
!
!
!
!
voice dial-plan 1 toll-free 9-1-866-NXX-XXXX
voice dial-plan 2 long-distance 9-1-NXX-NXX-XXXX
voice dial-plan 3 toll-free 9-1-800-NXX-XXXX
voice dial-plan 4 local 9-1-NXX-XXXX
voice dial-plan 7 toll-free 9-1-888-NXX-XXXX
voice dial-plan 8 toll-free 9-1-877-NXX-XXXX
voice dial-plan 10 operator-assisted 9-0-NXX-NXX-XXXX
voice dial-plan 11 international 9-011-$
!
!
!
!
voice codec-list "g711 first"
default
codec g711ulaw
codec g729
!
!
!
voice trunk T01 type sip
description "Bandwith.com"
sip-server primary xx.xxx.4.195
outbound-proxy primary xx.xxx.4.195
max-number-calls 64
codec-group "g711 first"
default-ring-cadence external
no diversion-supported
!
!
voice grouped-trunk "BANDWITH.COM SIP"
trunk T01
!
!
voice user 1000
connect fxs 0/1
first-name "Analog Port1"
password "1234"
num-rings 4
coverage global "last choice"
sip-identity xxx6945034 T01
sip-authentication password "1234"
codec-group "g711 first"
!
!
voice user 1001
connect fxs 0/2
first-name "Analog Port2"
password "1234"
coverage global "last choice"
sip-identity xxx6945057 T01
sip-authentication password "1234"
codec-group "g711 first"
!
!
voice user 1002
connect fxs 0/3
first-name "Analog Port3"
password "1234"
coverage global "last choice"
sip-identity xxx6945058 T01
sip-authentication password "1234"
codec-group "g711 first"
!
!
voice user 1003
connect fxs 0/4
first-name "Analog Port4"
password "1234"
coverage global "last choice"
sip-identity xxx6945059 T01
sip-authentication password "1234"
codec-group "g711 first"
!
!
voice user 1004
connect fxs 0/5
first-name "Analog Port5"
password "1234"
coverage global "last choice"
sip-identity xxx6945198 T01
sip-authentication password "1234"
codec-group "g711 first"
!
!
voice user 1005
connect fxs 0/6
first-name "Analog Port6"
password "1234"
coverage global "last choice"
sip-identity xxx6945217 T01
sip-authentication password "1234"
codec-group "g711 first"
!
!
voice user 1006
connect fxs 0/7
first-name "Analog Port7"
password "1234"
coverage global "last choice"
sip-authentication password "1234"
codec-group "g711 first"
!
!
voice user 1007
connect fxs 0/8
first-name "Analog Port8"
password "1234"
coverage global "last choice"
sip-authentication password "1234"
codec-group "g711 first"
!
voice ring-group 8001
type linear
description Bandwith.Com Ring Group
num-rings 4
member 1000
login-member 1000
member 1001
login-member 1001
member 1002
login-member 1002
member 1003
login-member 1003
member 1004
login-member 1004
member 1005
login-member 1005
member 1006
login-member 1006
member 1007
login-member 1007
coverage external xxxx5787865
did "xxx6945608"
did "xxx6945607"
sip-identity xxx6945608 T01
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip sip grammar from user international
!
!
!
!
!
!
line con 0
no login
!
line telnet 0 4
login
no shutdown
line ssh 0 4
login local-userlist
no shutdown
!
!
!
!
!
end
Looking further at your config, there are some other things to clean up.
I think you have a typo in your local dial plan. You have:
voice dial-plan 4 local 9-1-NXX-XXXX
I think you want:
voice dial-plan 4 local 9-NXX-XXXX
You will probably want to specify 10-digit CLID for your analog stations. Note in your debug the call from "1000"? Something like:
voice user 1000
connect fxs 0/1
caller-id-override external-number xxx6945608
Your backup IP setup also needs a little tweak to work correctly.
At a minimum you'll want to track the state of the primary link, withdraw its default route when down, and assign a higher distance to the backup default route. Something like:
probe primary-probe icmp-echo
destination xx.xx.62.193
source-address xx.xx.62.207
period 3
timeout 500
tolerance consecutive fail 3 pass 40
no shutdown
!
track primary-track
test if probe primary-probe
no shutdown
!
ip route 0.0.0.0 0.0.0.0 xx.xx.62.193 track primary-track
ip route 0.0.0.0 0.0.0.0 xx.xxx.173.1 100
You aren't allowing any digit patterns out the Bandwidth trunk group.
Try:
voice grouped-trunk "BANDWITH.COM SIP"
trunk T01
accept 9-1-NXX-NXX-XXXX
accept 9-NXX-XXXX
accept 9-911
accept 9-N11
accept 9-011-$
Then you'll need to get rid of that leading "9" before sending it to Dash.
!
voice trunk T01 type sip
description "Bandwith.com"
match dnis "9-1-NXX-NXX-XXXX" substitute "1-NXX-NXX-XXXX"
match dnis "9-NXX-XXXX" substitute "1-YYY-NXX-XXXX" ! <-- Substitute your local area code for YYY
match "9-911" substitute "911"
match "9-N11" substitute "N11"
match "9-011-$" substitute "011-$"
It also looks like you're missing a few dial plan entries.
voice dial-plan 5 toll-free 9-1-855-NXX-XXXX
voice dial-plan 6 always-permitted 9-911
voice dial-plan 9 user1 9-N11
It would make things a lot easier if you could reprogram the connected key system or PBX to NOT send you the leading "9". Note that the TA900 won't return a second dial tone after the 9 which may be confusing unless the key or PBX system provides it.
Looking further at your config, there are some other things to clean up.
I think you have a typo in your local dial plan. You have:
voice dial-plan 4 local 9-1-NXX-XXXX
I think you want:
voice dial-plan 4 local 9-NXX-XXXX
You will probably want to specify 10-digit CLID for your analog stations. Note in your debug the call from "1000"? Something like:
voice user 1000
connect fxs 0/1
caller-id-override external-number xxx6945608
Your backup IP setup also needs a little tweak to work correctly.
At a minimum you'll want to track the state of the primary link, withdraw its default route when down, and assign a higher distance to the backup default route. Something like:
probe primary-probe icmp-echo
destination xx.xx.62.193
source-address xx.xx.62.207
period 3
timeout 500
tolerance consecutive fail 3 pass 40
no shutdown
!
track primary-track
test if probe primary-probe
no shutdown
!
ip route 0.0.0.0 0.0.0.0 xx.xx.62.193 track primary-track
ip route 0.0.0.0 0.0.0.0 xx.xxx.173.1 100
Thank you very much all works including fail-over.
On more minor thing. When I call in from the cell and hang up before I pickup from the ports line, it rings at least twice until it acknowledges my hangup. Is there a way to fix that?
vmirinav wrote:
On more minor thing. When I call in from the cell and hang up before I pickup from the ports line, it rings at least twice until it acknowledges my hangup. Is there a way to fix that?
Probably not. There is a slight delay in the tear-down from the cell network, and another possible delay in the SIP provider. If you have a key system or PBX on the analog ports, it generates its own ringing to the phones behind it and is likely the cause of the majority of the delay in tearing down an abandoned call.