cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
garabedy
New Contributor III

No Ringback Outbound Calls

I have a TA908e that suddenly lost ringback on outbound calls. The unit is connected via SIP to an IPPBX and providing fxs to a PBX. My PBX shows 183 with SDP being sent but it seems to be getting lost in the 908. Looking at the debug logs from the 908 I see what I believe is the issue just not sure why this started happening or how to correct.

6:26:05.511 SB.CALL 1154 Delivering           Sent preConnect from T01 to 1001

06:26:05.512 SB.CALL 1154 State change      >> Delivering->PreConnecting

06:26:05.512 SB.CALL 1154 PreConnecting        ERROR! Dropped deliverResponse routine

06:26:05.512 SA.1001 Ca:0 Calling              rcvd: preConnect from SB

06:26:05.512 SA.1001 Ca:0 Calling              State change      >> Calling->Alerting (CAS_Alerting)

06:26:05.512 SA.1001 Ca:0 Alerting             sent: AcctPhoneMgr_preconnect to PM

06:26:05.512 PM.0:1 Call Pending         Preconnect handled.

06:26:05.513 PM.0:1 Call Pending         processed CACHG:Connected

06:26:05.513 PM.0:1 State change      >> Call Pending->Connected

06:26:05.513 SA.1001 sent: preConnectResponse(pass) to SB

06:26:05.513 SA.1001 Ca:0 Alerting             rcvd: AcctPhoneMgr_connect from PM

06:26:05.513 SB.CCM preConnect: convert answer SDP to sendonly

06:26:05.514 SB.CCM connect:

6:26:05.523 MEDIA.MANAGER Setup RTP Channel true for 0/1.1

06:26:05.523 SB.CCM setupRtpChannel, source 1, silence 0

06:26:05.523 SB.CCM setupRtpChannel: Received SDP contains sendonly SDP; disabling RTP transmission

06:26:05.523 SB.CCM setupRtpChannel: setup using media connection

06:26:05.527 SB.CCM connect: TDM streams: port(FxsPhone 0/1) to port(SipTrunk 0/1.1)

06:26:05.527 SB.CALL 1154 State change      >> PreConnecting->PreConnected

06:26:05.528 SB.CALL 1154 PreConnected         Call PreConnecting from 1001 to T01

06:26:05.528 RTP.CHANNEL fxs 0/1 - Dsp 0/1.1 - RTP: starting

06:26:05.528 TA.T01 ERROR! preConnectResponse ignored

Labels (2)
0 Kudos
1 Reply
jay
Valued Contributor
Valued Contributor

Re: No Ringback Outbound Calls

Garabed, please reply with the config of the 900 as well as the output of the following 3 commands when attempting to call:

debug voice verbose

debug int fxs <interfaces in use>

debug sip stack message

Thanks

Jay