I am trying to pass calls between Provider and PBX via TA908. I have eth0/1 as public and eth0/2 as LAN. I can make outbound calls however when an inbound call arrives I am getting an error SB.CALL 3 RTP resource unavailable or SDP negotiation failed. Call from (xxxxxxxxxx) to (xxxxxxxxxx).
clock timezone -8
!
ip subnet-zero
ip classless
ip routing
ipv6 unicast-routing
!
!
name-server 209.18.47.61 209.18.47.62
!
!
no auto-config
!
!
service password-encryption
!
username
!
!
no ip firewall alg msn
no ip firewall alg mszone
no ip firewall alg h323
!
!
!
!
!
!
!
!
no dot11ap access-point-control
!
interface eth 0/1
description (WAN)
ip address xxx.xxx.xxx.xxx 255.255.255.248
no shutdown
media-gateway ip primary
!
!
interface eth 0/2
ip address xxx.xxx.xxx.xxx 255.255.255.0
no awcp
no shutdown
media-gateway ip primary
!
!
!
interface gigabit-eth 0/1
no ip address
shutdown
!
ip access-list standard mgmt-allow-list
permit xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx
!
ip access-list standard sip-allow-list
permit hostname provider.name.com
permit xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx
!
!
!
!
!
!
ip route 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xxx
!
no tftp server
no tftp server overwrite
http server
http secure-server
no snmp agent
no ip ftp server
no ip scp server
no ip sntp server
!
sip
sip udp 5060
no sip tcp
no sip tls
!
!
!
voice feature-mode network
voice forward-mode local
!
!
!
!
!
!
!
!
voice dial-plan 1 local NXX-XXXX
voice dial-plan 2 long-distance 1-NXX-XXX-XXXX
!
!
!
!
voice codec-list VOICE
default
codec g711ulaw
!
!
!
voice trunk T01 type sip
description "SIP"
caller-id-override emergency-outbound xxxxxxxxxx
sip-server primary xxx.xxx.xxx.xxx
registrar primary xxx.xxx.xxx.xxx
domain "public IP"
register 5555555555 auth-name "xxx" password "xxx"
codec-list VOICE both
authentication username "xxx" password "xxx"
!
voice trunk T11 type sip
description "PBX"
sip-server primary PBX LAN ADDRESS
grammar from host local
transfer-mode network
!
!
voice grouped-trunk PROVIDER
trunk T01
accept NXX-XXX-XXX cost 0
accept 1-NXX-NXX-XXXX cost 0
accept 011-$ cost 0
accept 411 cost 0
accept 911 cost 0
!
!
voice grouped-trunk PBX
trunk T11
accept XXXXXXXXXX cost 0
accept XXXXXXXXXX cost 0
!
!
sip access-class ip "sip-allow-list" in
!
line con 0
no login
!
line telnet 0 4
login local-userlist
no shutdown
ip access-class mgmt-allow-list in
line ssh 0 4
login local-userlist
no shutdown
ip access-class mgmt-allow-list in
!END
ADTRAN, Inc. OS version R12.3.0.SA.E
Mainline Version: ENM.16.126
P4 Changelist: 633842
Checksum: 30e472eeaf64e5d8d7d680446c0c1f79ec2114393ce495716255c5e039148abf
Built on: Tue Jan 24 17:12:35 CST 2017
Hardware version M.1.5.0.0-0
Boot ROM version R10.9.3.B1
Built on: Fri Apr 11 09:42:09 CDT 2014
Compatibility Version: 1
Copyright (c) 1999-2017, ADTRAN, Inc.
Platform: Total Access 908e (3rd Gen), part number 4243908F1
Flash: 97120256 bytes DRAM: 509648896 bytes
uptime is 0 days, 0 hours, 3 minutes, 22 seconds
slot 0, DSP 1
DSP software version: G3.R1.4..2-R
DSP hardware version: Freescale BSC9131
Total channels: 60
Your firmware is ancient. I haven't read through all of the release notes to see if this is a known bug, but upgrade to the latest extended maintenance release.
Also, some configurations of SIP-to-SIP require that you have an SBC license now, and that's a possibility.
A "debug sip stack messages" capture on a failed call could be useful.