cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
New Contributor

T.38 First-Time Configuration Issue

I'm attempting to configure T.38 on a TA908 for the first time and I'm having issues.  I have "modem-passthrough" and "t38" enabled on the voice user.  Based on the output of a "debug voice verbose", the TA908 recognizes the modem tones and sends a RE-INVITE upstream to my soft switch.  However, the RE-INVITE has the "media type" set to "audio" (I would expect to see "image").  My soft switch accepts the RE-INVITE and the fax is sent using g.711.  Is there something else I have to do on the TA908 to make it use T.38?  Any help would be appreciated.

Thanks,

Andy

0 Kudos
Reply
6 Replies
Highlighted
Contributor
Contributor

Re: T.38 First-Time Configuration Issue

Lugnut,

It's possible the attached fax machine is V.30/SG3 in which if our device would re-invite G.711 "audio".  By default, we have only the v21-preample tone enabled for T.38; however, you have the option of enabling others as well.  That said, I'd suggest you enable all other tones, then attempt to send a fax and see if the RE-INVITE has the "media type" set for "image".  If that works, then it's likely the fax tone preamble detected by our device wasn't v.21 and therefore defaulting to G.711 "Audio".  See example command and related AOS Fax Tone document link below:

TA900e(config)#voice fax-tone t38 t30-cng

TA900e(config)#voice fax-tone t38 v25-ans

TA900e(config)#voice fax-tone t38 v25-ans-pr

TA900e(config)#voice fax-tone t38 v8-ansam

TA900e(config)#voice fax-tone t38 v8-ansam-pr

-Burgair

0 Kudos
Highlighted
New Contributor

Re: T.38 First-Time Configuration Issue

I've added the commands you referenced, but unfortunately it's still not working.  Now, the TA908 isn't sending a RE-INVITE at all.

0 Kudos
Highlighted
Contributor
Contributor

Re: T.38 First-Time Configuration Issue

To confirm, you have the fax connected to an FXS port and attempting to originate/send a fax from that machine, right?  Also, are you certain the ITSP Provider of the SIP Trunk supports T.38? If the answer to both questions is Yes, then you should call our Post-Sales support team at (888)423-8726, or send and email to support@adtran.com and include the debug you referenced earlier.

0 Kudos
Highlighted
Contributor III
Contributor III

Re: T.38 First-Time Configuration Issue

Hello Andrew,

I was wondering if you were able to make any progress with the faxing.  If you still have questions or if you solved the problem, let us know.

Thanks,

Geoff

0 Kudos
Highlighted
New Contributor

Re: T.38 First-Time Configuration Issue

As of now, incoming faxes do not work, but outgoing faxes do.  I have a ticket open with our softswitch vendor (the switch is the far-end T.38 endpoint), to see if the issue is on their end.  If I connect 2 TA908's back to back, incoming and outgoing both work fine.  I do have a Wireshark of a failed attempt and it basically looks like the softswitch sends some data, there's a partial page request by the Adtran, then the softswitch sends the same data that it already sent.  This happens in a continuous loop.

I do have a question about the "max-datagram" setting.  It seems no matter what I set that to, the actual frame size that the Adtran transmits is 100 bytes.  Likewise, on the softswitch, it's 314 bytes.  Is that not what the "max-datagram" setting refers to?  For my test, I have both endpoints set to 300 for "max-datagram".  I thought that perhaps incoming is failing because the softswitch is sending frames that are much bigger than the Adtran expects.

0 Kudos
Highlighted
Contributor III
Contributor III

Re: T.38 First-Time Configuration Issue

Hello Andrew,

Thanks for the added info.  A setting like max-datagram only affects the SDP in the SIP Message.  In the SDP offer the ADTRAN will list the set value.  This is only needed if the other side needs to see a specific value in the SDP. 

Let us know what the vendor says as it sounds like they may be able to address that problem.

Regards,

Geoff

0 Kudos