cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
stevemiller
New Contributor

TA-9XX 2nd Gen - PRI and SIP FXS Configuration

I'm looking for configuration guidance or best practices on configuration of the TA-9XX 2nd Gen devices for using SIP backhauled PRI and SIP FXS service on the same device. Customer has a PBX that will accept PRI and several additional devices that use POTS service.

I've been able to make this work, using a single configured voice trunk, but there seems to be a strange issue where calls from the PRI originated within the provider's network (I am the provider in this case) work fine, but calls outside the provider's network have no-way-audio. I can remove the FXS configurations or set up a second voice trunk and associate the FXS ports to that trunk, and the issue disappears.

My current configuration, redacted for security, is below.

Thanks in advance for any advice.

! ADTRAN, Inc. OS version R13.10.1.E
! Boot ROM version 14.04.00
! Platform: Total Access 908 (2nd Gen), part number 4212908L1
! Serial number [REDACTED]
!
!
hostname "LAB-TA908-1"
!
!
clock timezone [REDACTED]
!
ip subnet-zero
ip classless
ip routing
!
!
!
!
no auto-config
auto-config method https allow-sslv3
!
event-history on
no logging forwarding
no logging email
!
no service password-encryption
!
no ip firewall alg msn
no ip firewall alg mszone
no ip firewall alg h323
!
!no dot11ap access-point-control
!
interface eth 0/1
ip address dhcp hostname "Lab TA908"
no shutdown
media-gateway ip primary
!
interface t1 0/1
shutdown
!
interface t1 0/2
tdm-group 1 timeslots 1-24 speed 64
no shutdown
!
interface pri 1
connect t1 0/2 tdm-group 1
no shutdown
!
interface fxs 0/1
impedance 900c
rx-gain -6.0
tx-gain -3.0
battery-mode high
no shutdown
!
interface fxs 0/2
impedance 900c
rx-gain -6.0
tx-gain -3.0
battery-mode high
no shutdown
!
interface fxs 0/3
impedance 900c
rx-gain -6.0
tx-gain -3.0
battery-mode high
no shutdown
!
interface fxs 0/4
impedance 900c
rx-gain -6.0
tx-gain -3.0
battery-mode high
no shutdown
!
interface fxs 0/5
impedance 900c
rx-gain -6.0
tx-gain -3.0
battery-mode high
no shutdown
!
interface fxs 0/6
impedance 900c
rx-gain -6.0
tx-gain -3.0
battery-mode high
no shutdown
!
interface fxs 0/7
impedance 900c
rx-gain -6.0
tx-gain -3.0
battery-mode high
no shutdown
!
interface fxs 0/8
impedance 900c
rx-gain -6.0
tx-gain -3.0
battery-mode high
no shutdown
!
isdn-group 1
connect pri 1
!
ip access-list standard SIP-GLOBAL
![REDACTED]
!
ip route [REDACTED]
!
no tftp server
no tftp server overwrite
no http server
http secure-server
no snmp agent
no ip ftp server
ip scp server
no ip sntp server
!
sip
sip udp 5060
no sip tcp
!
voice feature-mode network
voice flashhook mode transparent
voice forward-mode network
!
voice codec-list "Default Codecs"
codec g711ulaw
codec g711alaw
!
voice trunk T01 type sip
description "SIP Trunk to Service Provider"
sip-server primary [REDACTED]
registrar primary [REDACTED]
registrar threshold percentage 75
max-number-calls 20
register [REDACTED] auth-name [REDACTED] password [REDACTED]
codec-list "Default Codecs" both
!
voice trunk T02 type isdn
resource-selection circular descending
connect isdn-group 1
rtp delay-mode adaptive
!
voice grouped-trunk "TRUNK GROUP"
description "Default Trunk Group"
trunk T01
accept $ cost 0
!
voice grouped-trunk PRI
trunk T02
accept $ cost 0
!
voice grouped-trunk 1
description "SIP to Service Provider"
trunk T01
accept $ cost 0
!
voice user [REDACTED]
connect fxs 0/1
no cos
password [REDACTED]
no call-waiting
block-caller-id
sip-identity [REDACTED] T01 register auth-name [REDACTED] password [REDACTED]
modem-passthrough
t38
t38 max-rate 9600
codec-list "Default Codecs"
!
voice mgcp-endpoint 1
block-caller-id
codec-group "Default Codecs"
connect fxs 0/4
modem-passthrough
t38
t38 max-rate 9600
!
ip mgcp
ip mgcp call-agent primary [REDACTED]
ip mgcp local-domain-name media-gateway
no voice fax-tone modem-passthrough t30-cng
voice fax-tone t38 t30-cng
!
sip access-class ip "SIP-GLOBAL" in
!
ip rtp quality-monitoring
ip rtp quality-monitoring sip
!
line con 0
no login
line-timeout 0
speed 115200
!
line telnet 0 4
login
shutdown
line ssh 0 4
login local-userlist
no shutdown
!
ntp source ethernet 0/1
ntp server [REDACTED] source ethernet 0/1 prefer
!
end

0 Kudos
1 Reply
stevemiller
New Contributor

Re: TA-9XX 2nd Gen - PRI and SIP FXS Configuration

 As it turns out, the no-way-audio issue was being caused by defective test gear. The TBERD 2310 I was using to perform test calls has an internal issue causing the one-way-audio.