cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
most_ahdy
Contributor
Contributor

upgrading polycom ipPhone

Jump to solution

Kindly I need to know the procedures for upgrading polycom IPphone , and if this possible to upgrade only one phone model to higher release and the rest of models keeping their older release ?

I want to upgrade only IP650 polycom phone.

Thanks,

Mostafa Aly

1 Solution

Accepted Solutions
Anonymous
Not applicable

Re: upgrading polycom ipPhone

Jump to solution

If you want to run different versions of Polycom firmware I would recommend upgrading to R10.3.1.  You would need to delete or override the old Polycom firmware files when uploading the new versions via FTP in the Polycom folder of CFLASH as they have the same filenames as the old versions.  There are also specific configuration files that need to be loaded based on the Polycom release as syntax changes occur between releases. R10.3.1 includes these files and offers an easy way to manage applying the needed files to phones using a particular version of Polycom firmware behind the scenes.  In previous versions of AOS the Polycom firmware dependent configuration files had to be uploaded separately and then configuration files for the phones using them had to be manually altered to make sure everything was loaded properly.


Thanks,
Matt

View solution in original post

0 Kudos
5 Replies
Anonymous
Not applicable

Re: upgrading polycom ipPhone

Jump to solution

This ability was added in R10.3.1 on the IP Phone Globals > Boot Settings > Default Firmware page:

pastedImage_1.png

Prior to R10.3.1 you had to upload the correct firmware file for the particular model you wanted to upgrade to the Polycom folder on CFLASH.

Thanks,
Matt

most_ahdy
Contributor
Contributor

Re: upgrading polycom ipPhone

Jump to solution

I see that R10.3.1 has many new features   any way If I put the new polycom firmware in the polycom folder , have I delete the old firmware??

Thanks,

Mostafa Aly

Anonymous
Not applicable

Re: upgrading polycom ipPhone

Jump to solution

If you want to run different versions of Polycom firmware I would recommend upgrading to R10.3.1.  You would need to delete or override the old Polycom firmware files when uploading the new versions via FTP in the Polycom folder of CFLASH as they have the same filenames as the old versions.  There are also specific configuration files that need to be loaded based on the Polycom release as syntax changes occur between releases. R10.3.1 includes these files and offers an easy way to manage applying the needed files to phones using a particular version of Polycom firmware behind the scenes.  In previous versions of AOS the Polycom firmware dependent configuration files had to be uploaded separately and then configuration files for the phones using them had to be manually altered to make sure everything was loaded properly.


Thanks,
Matt

0 Kudos
Anonymous
Not applicable

Re: upgrading polycom ipPhone

Jump to solution

I went ahead and flagged this post as "Assumed Answered".  If any of the responses on this thread assisted you, please mark them as Correct or Helpful as the case may be with the applicable buttons.  This will make them visible and help other members of the community find solutions more easily.  If you still need  assistance, we would be more than happy to continue working with you on this - just let us know in a reply.

Thanks,

Matt

Anonymous
Not applicable

Re: upgrading polycom ipPhone

Jump to solution

I went ahead and flagged the "Correct Answer" on this post to make it more visible and help other members of the community find solutions more easily. If you don't feel like the answer I marked was correct, feel free to come back to this post and unmark it and select another in its place with the applicable buttons.  If you still need assistance, we would be more than happy to continue working with you on this - just let us know in a reply.

Thanks,

Matt