cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
dcorrea
Contributor
Contributor

Warning Message

Jump to solution

Hi guys,

The other day I made the upgrade of an AOS from the 18.X.X version to the new R10.X in a NV4430, the upgrade was successful but after the equipment starts I received the following message:

"WARNING: Downgrading firmware may prevent some newer command formats, which are not backward compatible, from being accepted on startup.  Please issue 'show output-errors' after startup to see which commands failed to load and need to be reconfigured in their old format."

Then I issued the command show output-errors and nothing appears, is this good or bad?

Also after this upgrade I start to received the following message on the console:

2000.01.16 17:46:22 HTTP_CLIENT CONNECT_TO_HTTP_SERVER errorCode 51

What does that mean?

Thanks in advance,

Labels (1)
0 Kudos
1 Solution

Accepted Solutions
jayh
Honored Contributor
Honored Contributor

Re: Warning Message

Jump to solution

dcorrea wrote:



The other day I made the upgrade of an AOS from the 18.X.X version to the new R10.X in a NV4430, the upgrade was successful but after the equipment starts I received the following message:



"WARNING: Downgrading firmware may prevent some newer command formats, which are not backward compatible, from being accepted on startup.  Please issue 'show output-errors' after startup to see which commands failed to load and need to be reconfigured in their old format."



Then I issued the command show output-errors and nothing appears, is this good or bad?



Good.  This message means that the running configuration has been re-written as part of the upgrade to conform to newer syntax.  It's a warning that if you try to roll back some commands won't parse and things won't be configured as expected.  For example, on many platforms IPv6 is now supported.  So, interface access policies are now entered, displayed and saved as:

interface ppp 1

  ip access-policy Public

instead of:

interface ppp 1

  access-policy Public

There are some other changes, new commands, etc that are now part of the new firmware.


Suppose that after you've done the upgrade and saved the configuration, you want to roll back to the old firmware, or the older firmware is now your secondary boot and the primary image becomes corrupted.  Any of the commands that have been changed (such as the added "ip" to distinguish from "ipv6") aren't going to be understood by the older firmware.  So you won't have any access policies applied to interfaces, as an example.


show output-errors will display what lines of the startup configuration, if any, weren't understood or processed.  You can then manually tweak these to the older syntax and re-save to get going with the previous firmware.



Also after this upgrade I start to received the following message on the console:



2000.01.16 17:46:22 HTTP_CLIENT CONNECT_TO_HTTP_SERVER errorCode 51



Among other things it means that the clock isn't set correctly. The box thinks it's January 16, 2000. 

I'm not certain as to errorCode 51, however.  If you have an access list controlling HTTP access, that is one of the commands that was changed in R10.  It went from:

ip http access-class acl-name in


to


http ip access-class acl-name in


Could this be the issue?  Can you access the GUI without issue? 

View solution in original post

0 Kudos
2 Replies
jayh
Honored Contributor
Honored Contributor

Re: Warning Message

Jump to solution

dcorrea wrote:



The other day I made the upgrade of an AOS from the 18.X.X version to the new R10.X in a NV4430, the upgrade was successful but after the equipment starts I received the following message:



"WARNING: Downgrading firmware may prevent some newer command formats, which are not backward compatible, from being accepted on startup.  Please issue 'show output-errors' after startup to see which commands failed to load and need to be reconfigured in their old format."



Then I issued the command show output-errors and nothing appears, is this good or bad?



Good.  This message means that the running configuration has been re-written as part of the upgrade to conform to newer syntax.  It's a warning that if you try to roll back some commands won't parse and things won't be configured as expected.  For example, on many platforms IPv6 is now supported.  So, interface access policies are now entered, displayed and saved as:

interface ppp 1

  ip access-policy Public

instead of:

interface ppp 1

  access-policy Public

There are some other changes, new commands, etc that are now part of the new firmware.


Suppose that after you've done the upgrade and saved the configuration, you want to roll back to the old firmware, or the older firmware is now your secondary boot and the primary image becomes corrupted.  Any of the commands that have been changed (such as the added "ip" to distinguish from "ipv6") aren't going to be understood by the older firmware.  So you won't have any access policies applied to interfaces, as an example.


show output-errors will display what lines of the startup configuration, if any, weren't understood or processed.  You can then manually tweak these to the older syntax and re-save to get going with the previous firmware.



Also after this upgrade I start to received the following message on the console:



2000.01.16 17:46:22 HTTP_CLIENT CONNECT_TO_HTTP_SERVER errorCode 51



Among other things it means that the clock isn't set correctly. The box thinks it's January 16, 2000. 

I'm not certain as to errorCode 51, however.  If you have an access list controlling HTTP access, that is one of the commands that was changed in R10.  It went from:

ip http access-class acl-name in


to


http ip access-class acl-name in


Could this be the issue?  Can you access the GUI without issue? 

View solution in original post

0 Kudos
Anonymous
Not applicable

Re: Warning Message

Jump to solution

:

I went ahead and flagged the "Correct Answer" on this post to make it more visible and help other members of the community find solutions more easily. If you don't feel like the answer I marked was correct, feel free to come back to this post and unmark it and select another in its place with the applicable buttons.  If you still need assistance, we would be more than happy to continue working with you on this - just let us know in a reply.

Thanks,

Levi