I am trying to understand DHCP relay better. Basically I have two firmware updated NV6310 model routers with the first one having a DHCP pool. What I would like to see is if I can make DHCP (from router one) work behind router two, interface ethernet 0/1. I have tried several command combinations with no luck. Right now I have very basic configs and can ping across all interfaces.
ROUTER ONE:
ip dhcp pool "Test Pool"
network 192.168.46.0 255.255.255.240
dns-server 8.8.8.8 8.8.4.4
default-router 192.168.47.254
lease 0 0 5
!
!
!
interface eth 0/1 - ROUTER 2 ETH PORT 2 FACING
ip address 192.168.31.254 255.255.240.0
no shutdown
!
!
interface eth 0/2 - NOT CURRENTLY USED
no ip address
shutdown
!
!
ip route 192.168.46.0 255.255.254.0 192.168.19.2
ROUTER TWO:
interface eth 0/1 - LAPTOP FACING
ip address 192.168.47.254 255.255.254.0
ip helper-address 192.168.31.254
no shutdown
!
!
interface eth 0/2 - ROUTER 1 ETH PORT 1 FACING
ip address 192.168.19.2 255.255.240.0
no shutdown
!
!
ip route 0.0.0.0 0.0.0.0 192.168.31.254
There is a newer command,
On Router 2, remove this command from your eth 0/1 interface: ip helper-address 192.168.31.254
And add this:
ip dhcp relay destination 192.168.31.254
Let me know how that works.
-Mark
There is a newer command,
On Router 2, remove this command from your eth 0/1 interface: ip helper-address 192.168.31.254
And add this:
ip dhcp relay destination 192.168.31.254
Let me know how that works.
-Mark
Unfortunately that did not do the trick to make DHCP work.
It’s working now. I just realized I had the subnet mask wrong in the DHCP pool. Thanks!
Good deal! Thanks for the update!
-Mark