cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
New Contributor II

FXS to Sip phone with no audio.

Jump to solution

Both number are programed in the same TA.  I tried adding a loopback IP but it did not work.  Don't know if I have the correct procedure.  Can someone send it?

Tags (5)
0 Kudos
1 Solution

Accepted Solutions
Highlighted
New Contributor II

Re: FXS to Sip phone with no audio.

Jump to solution

The problem was fixed with some changes on the configuration sugested by a coworker.

View solution in original post

0 Kudos
9 Replies
Highlighted
Honored Contributor
Honored Contributor

Re: FXS to Sip phone with no audio.

Jump to solution

No audio in either direction?  Does the signaling work?  In other words can you call the other number and get it to ring, answer the call and ringing stops?

Could you post configuration with sensitive info redacted?

Highlighted
New Contributor II

Re: FXS to Sip phone with no audio.

Jump to solution

Yes the phone ring and it is answered, buy there is no audio in any direction.  When we did the loopbank config we did not reboot the TA.  I added the config.

Highlighted
Honored Contributor
Honored Contributor

Re: FXS to Sip phone with no audio.

Jump to solution

Is the SIP phone also behind the TA900?  Do you have audio from the public phone network to both the analog and SIP phones?

You might need to turn on the transparent proxy.

ip sip proxy

ip sip proxy transparent

If the carrier is doing media path optimization it is expecting the RTP to go locally and failing.  I don't see any NAT, are the SIP phones on private RFC1918 addresses?

Highlighted
New Contributor II

Re: FXS to Sip phone with no audio.

Jump to solution

Yes, I work for the carrier and we do media release.  The phones are able to receive and generate calls outside the TA with good quality.  They are all in our private network, where we have all our sip customers.  Do the TA have to be rebooted after that change?

ip sip proxy

ip sip proxy transparent


Highlighted
New Contributor II

Re: FXS to Sip phone with no audio.

Jump to solution

Should I revove what we did with the loopback?

Highlighted
Honored Contributor
Honored Contributor

Re: FXS to Sip phone with no audio.

Jump to solution

No need to reboot the unit but you might want to reboot the SIP phones behind the Adtran or wait for them to re-register.  They should show up in a "show sip proxy user" command.  I'd do away with the loopback if adding the proxy doesn't fix it.

Are the SIP phones being NATted by the Adtran?  It didn't look like it from your configuration.

Doing a "debug sip stack messages" during a failed call may point out where the media is pointing and why it is failing.

Highlighted
New Contributor II

Re: FXS to Sip phone with no audio.

Jump to solution

Thanks, will try that.  The sip phones are not behind a NAT.

Highlighted
Anonymous
Not applicable

Re: FXS to Sip phone with no audio.

Jump to solution

Hello,

I just wanted to check back in with you to see if you are still having problems.  If so, feel free to respond with any additional questions you may have

here.

Regards,

Geoff

Highlighted
New Contributor II

Re: FXS to Sip phone with no audio.

Jump to solution

The problem was fixed with some changes on the configuration sugested by a coworker.

View solution in original post

0 Kudos