cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
glitchv0
New Contributor II

TA904 No audio to/from PBX

Jump to solution

I've been working with adtran support, but sometimes you need a fresh set of eyes.  Basically I have an adtran 904 sipping back to an asterisk server.  The 904 is setup as a PRI for a PBX.  Incoming and outgoing calls work fine (as in they are delivered).  However you get no audio.  Just dead silence.  I'm not sure of the model of the phone system I do know it is a newer Toshiba. Attached. is my config and a call debug.  I can also provide my asterisk setup if needed but it is working fine with other customers.

Labels (3)
Tags (5)
0 Kudos
1 Solution

Accepted Solutions
glitchv0
New Contributor II

Re: TA904 No audio to/from PBX

Jump to solution

This is now resolved.  I went back onsite, without changing my config, rebooted the PBX and calls work now.  Thanks for all the help, I knew something weird had to be up.

View solution in original post

0 Kudos
2 Replies
unified
Valued Contributor
Valued Contributor

Re: TA904 No audio to/from PBX

Jump to solution

I assume that the Asterisk server and TA904 are on the same network with no routing or NATing.

If this is not the case please post your network layout

Your config looks OK but try the following one at a time:

  • Downgrade to Firmware version A4.11.00.
  • On the T02 trunk remove "no nls" and rtp frame-packetizatation 30
  • On the PRI interface remove "isdn name-delivery setup"

If possible please provide a WireShark capture and/or the debug log from Asterisk

glitchv0
New Contributor II

Re: TA904 No audio to/from PBX

Jump to solution

This is now resolved.  I went back onsite, without changing my config, rebooted the PBX and calls work now.  Thanks for all the help, I knew something weird had to be up.

0 Kudos