Hi, I'm new to the Adtran Gateway. I'm trying to get a sip trunk to register. when I run a show sip trunk-registration this is what I'm getting
There are no matching registrations available.
Can anyone lead me in the right direction?
How can I force a sip trunk to register?
!
interface eth 0/1
ip address XX.XX.XX.XX 255.255.255.0
access-policy Private
media-gateway ip primary
no shutdown
!
interface eth 0/2
ip address XX.XX.XX.XX 255.255.255.248
access-policy WAN1
media-gateway ip primary
no shutdown
!
ip access-list standard nat
permit any
!
ip access-list extended admin
remark admin access
permit tcp any any eq https log
permit tcp any any eq ssh log
permit tcp any any eq ftp log
permit tcp any any eq echo log
!
ip access-list extended SIP
remark SIP
permit udp hostname bsip.bestline.net any eq 5060
!
ip policy-class Private
nat source list nat interface eth 0/2 overload
!
ip policy-class WAN1
allow list admin
allow list SIP
!
ip route 0.0.0.0 0.0.0.0 XX.XX.XX.XX
!
no ip tftp server
no ip tftp server overwrite
ip http server
ip http secure-server
no ip snmp agent
no ip ftp server
no ip scp server
no ip sntp server
!
ip sip
ip sip udp 5060
no ip sip tcp
!
voice feature-mode network
voice forward-mode network
!
voice codec-list "g729 first"
default
codec g729
codec g711ulaw
!
voice trunk T10 type sip
description "testsip"
sip-server primary TESTSIP.NET
outbound-proxy primary testsip.net
authentication username "xxxxxxxx" password encrypted "xxxxxxxxxxxxxxxxxxx"
max-number-calls 3
codec-group "g729 first"
!
voice grouped-trunk "SIP TRUNK GROUP"
trunk T10
accept NXX-XXX-XXXX cost 0
accept 1-NXX-XXX-XXXX cost 0
accept 911 cost 0
reject NXX-976-XXXX
reject 1-900-NXX-XXXX
reject 1-976-NXX-XXXX
reject 1-246-NXX-XXXX
!
ip sip registrar
Thanks Jay,
I got it to work.
register 5125555555 auth-name "512xxxxxxx" password encrypted "xxxxxxxxxxxxxxxxxx"
authentication username "512XXXXXXX" password encrypted "xxxxxxxxxx"
this is what made it work.
Are you trying to register to testsip.net or to bsip.bestline.net ? Your ACL permits the hostname bsip.bestline.net but your registration is to testsip.net.
You also may need to allow the WAN to communicate with the Adtran itself both for SIP and RTP.
ip access-list extended allow-udp
permit udp any any
ip policy-class WAN1
allow list admin
allow list SIP
allow list allow-udp self
I generally find it beneficial to allow all traffic to self from the WAN, then use access-lists separately for administration and SIP applied to the protocols but this way should work.
"debug sip stack messages" as well as "debug firewall" may be useful.
Thanks Jay,
I got it to work.
register 5125555555 auth-name "512xxxxxxx" password encrypted "xxxxxxxxxxxxxxxxxx"
authentication username "512XXXXXXX" password encrypted "xxxxxxxxxx"
this is what made it work.