cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
New Contributor III

Programming IP Helper-Address on Vlan Interface

Jump to solution

Hello,

  I have a 1335 that has multiple Vlans in it now. It is the DHCP Server for 2 of these Vlans (Vlan 3&4). Soon the customer will have his own DHCP Server for the 2 subnets. Once he has this server  configured I am trying to vefiy what I need to do in the 1335. I will do away with the DHCP Scopes and Excluded IP's for each of the vlans (Vlan3&4). Then Create a new Vlan that's just going to his Server, it will be VLan 5. Once created I will build vlan 5 interface. Then all I should have to do is put the IP DHCP Helper statement under each of the VLan interfaces  i want to recieve DHCP from the customers server, correct? I will use switchport 0/10 on the 1335 to connect to his server, the install guide for his DHCP server ask that the Switchport it was connected to be configured as a 802.1q Trunk port and use the nonegotiate statement. In the below config I need vlan 3 and 4 to get DHCP from the DHCP server on Vlan 5. The customers DHCP Server has a IP address of 192.168.5.2/24

interface vlan 1

  description W_Lan

  ip address 192.168.1.1 255.255.255.0

  no ip route-cache express

  no shutdown

!

interface vlan 2

  description Customer_Lan

  ip address  192.168.2.1  255.255.255.0

  ip route-cache express

  no shutdown

!

interface vlan 3

  description 3rd_Floor

  ip address  192.168.3.1  255.255.255.0

  ip helper-address 192.168.5.1

  ip route-cache express

  no shutdown

!

interface vlan 4

  descrition 4th_Floor

  ip address  192.168.4.1  255.255.255.0

  ip helper-address 192.168.5.1

  no ip route-cache express

  no shutdown

!

interface vlan 5

  description DHCP-Server

  ip address  192.168.5.1  255.255.255.0

  no ip route-cache express

  no shutdown

!

1335(config)#int switchport 0/10
1335(config)#description Trunk_2_DHCP_Server

1335(config)#switchport mode trunk
1335(config)#switchport trunk allow vlan 5
1335(config)#switchport nonegotiate

1335(config)#spanning-tree portfast

Should there be anymore config done in the 1335?

Thanks

Labels (1)
0 Kudos
Reply
1 Solution

Accepted Solutions
Highlighted
Anonymous
Not applicable

Re: Programming IP Helper-Address on Vlan Interface

Jump to solution

:

Thank you for asking this question in the Support Community.  You will have to setup UDP relay to forward DHCP Discovery messages to a DHCP server on another subnet.  Many services, such as DHCP, rely on clients being able to reach a server by broadcasting a request. These requests are limited by being broadcast. Broadcast traffic propagates only throughout the local subnet. If the client is not on the same subnet as the server, the broadcast will not reach the server. If it is necessary for clients to have the ability to communicate with a remote server through broadcast traffic, then UDP Relay must be enabled. UDP Relay, once set up, will not simply forward the broadcast packets. It also examines them, checks their validity, and adds any appropriate changes, such as its own IP address (which enables the server to return the traffic to the router). The router will then forward this traffic to the client.  Here is the Configuring UDP Relay in AOS guide for your reference.

In your configuration, you will need to point the ip helper-address to the DHCP server's IP address, not the VLAN IP address.  So, the command would be ip helper-address 192.168.5.2 on both VLAN 3 and 4 since the DHCP server will be 192.168.5.2.  You will need to enable UDP relay for DHCP with the ip forward-protocol udp bootps and ip forward-protocol udp domain commands.

Also, the commands switchport nonegotiate and spanning-tree portfast you mentioned above are not AOS commands and will not be accepted.  If your intention is to hardset the speed/duplex to 100 Mbps then the command is speed 100.  Also, typically the port connecting to the DHCP server would not need to be setup as a trunk port in this configuration.

Here is an example configuration based on the information you provided:

ip forward-protocol udp domain

ip forward-protocol udp bootps

interface switchport 0/10

  description Trunk_2_DHCP_Server

  speed 100

  spanning-tree edgeport

  no shutdown

  switchport access vlan 5

interface vlan 3

  description 3rd_Floor

  ip address  192.168.3.1  255.255.255.0

  ip helper-address 192.168.5.2

  ip route-cache express

  no shutdown

!

interface vlan 4

  descrition 4th_Floor

  ip address  192.168.4.1  255.255.255.0

  ip helper-address 192.168.5.2

  no ip route-cache express

  no shutdown

I hope that makes sense, but please do not hesitate to reply to this post with any additional information or questions.  I will be happy to help in any way I can.

Levi

View solution in original post

0 Kudos
Reply
3 Replies
Highlighted
Anonymous
Not applicable

Re: Programming IP Helper-Address on Vlan Interface

Jump to solution

:

Thank you for asking this question in the Support Community.  You will have to setup UDP relay to forward DHCP Discovery messages to a DHCP server on another subnet.  Many services, such as DHCP, rely on clients being able to reach a server by broadcasting a request. These requests are limited by being broadcast. Broadcast traffic propagates only throughout the local subnet. If the client is not on the same subnet as the server, the broadcast will not reach the server. If it is necessary for clients to have the ability to communicate with a remote server through broadcast traffic, then UDP Relay must be enabled. UDP Relay, once set up, will not simply forward the broadcast packets. It also examines them, checks their validity, and adds any appropriate changes, such as its own IP address (which enables the server to return the traffic to the router). The router will then forward this traffic to the client.  Here is the Configuring UDP Relay in AOS guide for your reference.

In your configuration, you will need to point the ip helper-address to the DHCP server's IP address, not the VLAN IP address.  So, the command would be ip helper-address 192.168.5.2 on both VLAN 3 and 4 since the DHCP server will be 192.168.5.2.  You will need to enable UDP relay for DHCP with the ip forward-protocol udp bootps and ip forward-protocol udp domain commands.

Also, the commands switchport nonegotiate and spanning-tree portfast you mentioned above are not AOS commands and will not be accepted.  If your intention is to hardset the speed/duplex to 100 Mbps then the command is speed 100.  Also, typically the port connecting to the DHCP server would not need to be setup as a trunk port in this configuration.

Here is an example configuration based on the information you provided:

ip forward-protocol udp domain

ip forward-protocol udp bootps

interface switchport 0/10

  description Trunk_2_DHCP_Server

  speed 100

  spanning-tree edgeport

  no shutdown

  switchport access vlan 5

interface vlan 3

  description 3rd_Floor

  ip address  192.168.3.1  255.255.255.0

  ip helper-address 192.168.5.2

  ip route-cache express

  no shutdown

!

interface vlan 4

  descrition 4th_Floor

  ip address  192.168.4.1  255.255.255.0

  ip helper-address 192.168.5.2

  no ip route-cache express

  no shutdown

I hope that makes sense, but please do not hesitate to reply to this post with any additional information or questions.  I will be happy to help in any way I can.

Levi

View solution in original post

0 Kudos
Reply
Highlighted
Anonymous
Not applicable

Re: Programming IP Helper-Address on Vlan Interface

Jump to solution

:


I went ahead and flagged this post as “Assumed Answered.”  If any of the responses on this thread assisted you, please mark them as either Correct or Helpful answers with the applicable buttons.  This will make them visible and help other members of the community find solutions more easily.  If you still need assistance, I would be more than happy to continue working with you on this - just let me know in a reply.

Levi

0 Kudos
Highlighted
New Contributor III

Re: Programming IP Helper-Address on Vlan Interface

Jump to solution

marked is as correct, thanks for all your help

0 Kudos