cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
touristsis
Contributor III
Contributor III

Adtran 7100 with Polycom IP 650

Jump to solution

Hi, we have some Polycom IP650 that I can't seems to update the directories.  Does anyone have any ideas?


I've updated in other directories Entry on each phones under IP Phone configs, I've updated it under IP phone globals, I've tried to reboot the phones and reboot the phone system with no luck.  Does anyone have any ideas what else I need to try?

Thanks!

0 Kudos
1 Solution

Accepted Solutions
touristsis
Contributor III
Contributor III

Re: Adtran 7100 with Polycom IP 650

Jump to solution

Matt,

That was it! Thank You! I had to change option 66 in the server from VLAN 2 ip of phone system to VLAN 1 ip of phone system so the phone can talk to the phone system on phase 1 of dhcp and full the files, before it boot to VLAN 2.

View solution in original post

0 Kudos
14 Replies
markfreeman
Valued Contributor II
Valued Contributor II

Re: Adtran 7100 with Polycom IP 650

Jump to solution

Did you go to IP Phone Configs and select all the phones, and then to “Other Actions” and then select “Update Directories”. Then you will have to reboot the phones.

-Mark

touristsis
Contributor III
Contributor III

Re: Adtran 7100 with Polycom IP 650

Jump to solution

Yes, I’ve did that.

Message was edited by: matt - removed sensitive information

markfreeman
Valued Contributor II
Valued Contributor II

Re: Adtran 7100 with Polycom IP 650

Jump to solution

What AOS version you running and what version is your Polycom IP 650

Do you have any other Polycom phones that are working with the directory?

-Mark

touristsis
Contributor III
Contributor III

Re: Adtran 7100 with Polycom IP 650

Jump to solution

4.0.x 2345-12600-001  - Polycom Phone Firm Ware

R10.11.0.E

All the phones are about the same, the directory is just a bit off.

Message was edited by: matt - removed sensitive information

markfreeman
Valued Contributor II
Valued Contributor II

Re: Adtran 7100 with Polycom IP 650

Jump to solution

FTP into the 7100 and look at the MAC-direcotry.xml and verify that it has the same directory as the ip phone globals directory,

If that matches, then the phone should be downloading that. Run debug ip ftp-server on 7100 and verify that the phone is grabbing that config.

If it is and still wrong,

Default the phone, reboot the phone, when the phone comes up you will see cancel button, press it, then when you see count down timer hold down keys 4-6-8-*

Then when prompted for password enter 456, after phone boots up check directory.

-Mark

touristsis
Contributor III
Contributor III

Re: Adtran 7100 with Polycom IP 650

Jump to solution

Hi Mark, I did all this. Now when the phone boots up it says network down.

This is the error on the debug I’m getting.

2014.05.22 11:53:59 LLDP LLDP: Speed Duplex mis-match on eth 0/6. Speed/Duplex: "100M/full-duplex" Neighbor Speed/Duplex: "10M/full-duplex"

2014.05.22 11:54:00 LLDP LLDP: Speed Duplex mis-match on eth 0/6. Speed/Duplex: "100M/full-duplex" Neighbor Speed/Duplex: "10M/full-duplex"

2014.05.22 11:54:01 LLDP LLDP: Speed Duplex mis-match on eth 0/6. Speed/Duplex: "100M/full-duplex" Neighbor Speed/Duplex: "10M/full-duplex"

2014.05.22 11:54:02 LLDP LLDP: Speed Duplex mis-match on eth 0/6. Speed/Duplex: "100M/full-duplex" Neighbor Speed/Duplex: "10M/full-duplex"

2014.05.22 11:54:03 LLDP LLDP: Speed Duplex mis-match on eth 0/6. Speed/Duplex: "100M/full-duplex" Neighbor Speed/Duplex: "10M/full-duplex"

2014.05.22 11:54:19 DHCP.SERVER Discarding message, no available pools: (Xid = 188fff6e) on 192.168.1.0/255.255.255.0 from 00:04:F2:30:F5:3C

2014.05.22 11:54:19 DHCP.SERVER No Reply required

2014.05.22 11:54:20 DHCP.SERVER Discarding message, no available pools: (Xid = 188fff6e) on 192.168.1.0/255.255.255.0 from 00:04:F2:30:F5:3C

2014.05.22 11:54:20 DHCP.SERVER No Reply required

markfreeman
Valued Contributor II
Valued Contributor II

Re: Adtran 7100 with Polycom IP 650

Jump to solution

What network is this? 192.168.1.0/255.255.255.0

Is the 7100 still using the default networks? 10.10.10 and 10.10.20?

-Mark

touristsis
Contributor III
Contributor III

Re: Adtran 7100 with Polycom IP 650

Jump to solution

192.168.1.0 – is the default VLAN.

No.

192.168.1.80

255.255.255.0

10.10.20.1
255.255.255.0

172.17.17.1

255.255.255.0

markfreeman
Valued Contributor II
Valued Contributor II

Re: Adtran 7100 with Polycom IP 650

Jump to solution

Your response got all messed up. If you replied via email it does that. Go to the website of forum and put your info.

Can you put the sh run config on here. I need to see your DHCP pools and your VLAN configuration.

-Mark

touristsis
Contributor III
Contributor III

Re: Adtran 7100 with Polycom IP 650

Jump to solution

Mark,

The DHCP pool - default vlan - vlan 1 is being assigned by the Windows Server.
vlan 2 - VOIP vlan - is being assigned by the 7100

Port 13 on the 7100 - is connected to vlan 1 switch (we have it set for VLAN 1 only traffic)

!
!
! ADTRAN, Inc. OS version R10.11.0.E
! Boot ROM version A2.06.B1.01
! Platform: NetVanta 7100, part number 1200796E1
! Serial number ahahaha
!
!
hostname "hahaga"
enable password hahaha
!
clock timezone -6-Central-Time
!
ip subnet-zero
ip classless
ip routing
ipv6 unicast-routing
host "hahaha" 192.168.1.3
domain-name "hahaha"
domain-proxy
name-server 4.2.2.1 4.2.2.2
!
!
no auto-config
!
event-history on
no logging forwarding
logging email on
logging email receiver-ip 192.168.1.4
logging email sender hahaha.com
!
no service password-encryption
!
portal-list "FTP" ftp
!
username "polycomftp" portal-list "FTP" password "hahaha"
username "keepitcool" password "hahaha"
username "PlcmSplp" portal-list "FTP" password "hahaha"
!
!
no ip firewall alg msn
no ip firewall alg mszone
no ip firewall alg h323
!
!
!
!
!
!
!
!
!
!
!
no dot11ap access-point-control
!
!
!
!
!
!
!
ip dhcp database local
ip dhcp excluded-address 10.10.20.230 10.10.20.254
!
ip dhcp pool "VoIP_pool"
  network 10.10.20.0 255.255.255.0
  domain-name "ari.local"
  dns-server 10.10.20.1
  netbios-node-type h-node
  default-router 10.10.20.1
  tftp-server tftp://10.10.20.1
  ntp-server 10.10.20.1
  timezone-offset -6:00
  option 157 ascii TftpServers=0.0.0.0,FtpServers=10.10.20.1:/ADTRAN,FtpLogin=polycomftp,FtpPassword=hahahha,Layer2Tagging=True,VlanID=2
  option 66 ascii ftp://polycomftp:hahaha@10.10.20.1/Polycom
!
!
!
!
!
!
!
!
!
!
!
qos map voice 1
  match dscp 46
  priority 1000
!
!
!
!
vlan 1
  name "Default"
!
vlan 2
  name "VoIP"
!
vlan 254
  name "TWC P2P"
!
!
interface loop 1
  ip address  10.10.20.254  255.255.255.255
  no shutdown
!
interface eth 0/0
  ip address dhcp hostname "NV7100"
  media-gateway ip primary
  no shutdown
  no lldp send-and-receive
!
!
interface eth 0/1
  spanning-tree edgeport
  no shutdown
  switchport mode trunk
!
!
interface eth 0/2
  spanning-tree edgeport
  no shutdown
  switchport mode trunk
!
!
interface eth 0/3
  spanning-tree edgeport
  no shutdown
  switchport mode trunk
!
!
interface eth 0/4
  spanning-tree edgeport
  no shutdown
  switchport mode trunk
!
!
interface eth 0/5
  spanning-tree edgeport
  no shutdown
  switchport mode trunk
!
!
interface eth 0/6
  spanning-tree edgeport
  no shutdown
  switchport mode trunk
!
!
interface eth 0/7
  spanning-tree edgeport
  no shutdown
  switchport mode trunk
!
!
interface eth 0/8
  spanning-tree edgeport
  no shutdown
  switchport mode trunk
!
!
interface eth 0/9
  spanning-tree edgeport
  no shutdown
  switchport mode trunk
!
!
interface eth 0/10
  spanning-tree edgeport
  no shutdown
  switchport mode trunk
!
!
interface eth 0/11
  spanning-tree edgeport
  no shutdown
  switchport mode trunk
!
!
interface eth 0/12
  spanning-tree edgeport
  no shutdown
  switchport mode trunk
!
!
interface eth 0/13
  spanning-tree edgeport
  no shutdown
!
!
interface eth 0/14
  spanning-tree edgeport
  no shutdown
  switchport mode trunk
!
!
interface eth 0/15
  spanning-tree edgeport
  no shutdown
  switchport mode trunk
!
!
interface eth 0/16
  spanning-tree edgeport
  no shutdown
  switchport mode trunk
!
!
interface eth 0/17
  spanning-tree edgeport
  no shutdown
  switchport mode trunk
!
!
interface eth 0/18
  spanning-tree edgeport
  no shutdown
  switchport mode trunk
!
!
interface eth 0/19
  spanning-tree edgeport
  no shutdown
  switchport mode trunk
!
!
interface eth 0/20
  spanning-tree edgeport
  no shutdown
  switchport mode trunk
!
!
interface eth 0/21
  spanning-tree edgeport
  no shutdown
  switchport mode trunk
!
!
interface eth 0/22
  spanning-tree edgeport
  no shutdown
  switchport mode trunk
!
!
interface eth 0/23
  spanning-tree edgeport
  no shutdown
  switchport mode trunk
!
!
interface eth 0/24
  spanning-tree edgeport
  no shutdown
  switchport access vlan 254
!
!
!
interface gigabit-eth 0/1
  no shutdown
  switchport mode trunk
!
!
interface gigabit-eth 0/2
  no shutdown
  switchport mode trunk
!
!
!
!
interface vlan 1
  ip address  192.168.1.80  255.255.255.0
  ip access-policy Private
  ! IPv4 access-policy will not be used until IPv4 firewall is enabled
  media-gateway ip primary
  no shutdown
!
interface vlan 2
  ip address  10.10.20.1  255.255.255.0
  ip access-policy Private
  ! IPv4 access-policy will not be used until IPv4 firewall is enabled
  media-gateway ip primary
  no shutdown
!
interface vlan 254
  ip address  172.17.17.1  255.255.255.0
  ip access-policy Private
  ! IPv4 access-policy will not be used until IPv4 firewall is enabled
  media-gateway ip loopback 1
  traffic-shape rate 5000000
  no awcp
  no shutdown
!
!
interface t1 1/1
  clock source internal
  tdm-group 1 timeslots 1-24 speed 64
  shutdown
!
interface t1 2/1
  system-timing primary
  tdm-group 1 timeslots 1-24 speed 64
  no shutdown
!
!
interface pri 1
  connect t1 2/1 tdm-group 1
  no shutdown
!
!
interface fxs 0/1
  no shutdown
!
interface fxs 0/2
  no shutdown
!
!
interface fxo 0/1
  no shutdown
!
interface fxo 0/2
  no shutdown
!
interface ppp 1
  ip address  10.1.1.1  255.255.255.252
  ip access-policy Private
  ! IPv4 access-policy will not be used until IPv4 firewall is enabled
  media-gateway ip primary
  qos-policy out voice
  ! QOS map disabled due to inadequate interface bandwidth
  no shutdown
  cross-connect 1 t1 1/1 1 ppp 1
!
!
isdn-group 1
  connect pri 1
!
isdn-number-template 0 prefix "" subscriber 911
isdn-number-template 1 prefix "" subscriber NXX-XXXX
isdn-number-template 2 prefix "" national NXX-NXX-XXXX
isdn-number-template 3 prefix 011 international X$
isdn-number-template 4 prefix "" unknown NXX
isdn-number-template 5 prefix "" unknown NXXX
isdn-number-template 6 prefix "" national 1-NXX-NXX-XXXX
!
!
!
!
!
!
!
ip access-list standard self
  permit any
!
!
ip access-list extended admin
  permit tcp any  any eq ssh 
  permit tcp any  any eq telnet 
  permit tcp any  any eq www 
  permit tcp any  any eq ftp 
  permit tcp any  any eq https 
!
ip access-list extended private_networks
  permit ip 10.1.1.0 0.0.0.3  192.168.2.0 0.0.0.255   
  permit ip 10.1.1.0 0.0.0.3  192.168.1.0 0.0.0.255   
  permit ip 10.1.1.0 0.0.0.3  10.10.21.0 0.0.0.255   
  permit ip 10.1.1.0 0.0.0.3  10.10.20.0 0.0.0.255   
  permit ip 192.168.2.0 0.0.0.255  10.1.1.0 0.0.0.3   
  permit ip 192.168.2.0 0.0.0.255  10.10.20.0 0.0.0.255   
  permit ip 192.168.2.0 0.0.0.255  10.10.21.0 0.0.0.255   
  permit ip 192.168.2.0 0.0.0.255  192.168.1.0 0.0.0.255   
  permit ip 192.168.1.0 0.0.0.255  10.1.1.0 0.0.0.3   
  permit ip 192.168.1.0 0.0.0.255  192.168.2.0 0.0.0.255   
  permit ip 192.168.1.0 0.0.0.255  10.10.20.0 0.0.0.255   
  permit ip 192.168.1.0 0.0.0.255  10.10.21.0 0.0.0.255   
  permit ip 10.10.20.0 0.0.0.255  10.1.1.0 0.0.0.3   
  permit ip 10.10.20.0 0.0.0.255  192.168.1.0 0.0.0.255   
  permit ip 10.10.20.0 0.0.0.255  192.168.2.0 0.0.0.255   
  permit ip 10.10.20.0 0.0.0.255  10.10.21.0 0.0.0.255   
  permit ip 10.10.21.0 0.0.0.255  10.10.20.0 0.0.0.255   
  permit ip 10.10.21.0 0.0.0.255  192.168.2.0 0.0.0.255   
  permit ip 10.10.21.0 0.0.0.255  192.168.1.0 0.0.0.255   
  permit ip 10.10.21.0 0.0.0.255  10.1.1.0 0.0.0.3   
  permit ip 172.17.17.0 0.0.0.3  192.168.2.0 0.0.0.255   
  permit ip 172.17.17.0 0.0.0.3  192.168.1.0 0.0.0.255   
  permit ip 172.17.17.0 0.0.0.3  10.10.21.0 0.0.0.255   
  permit ip 172.17.17.0 0.0.0.3  10.10.20.0 0.0.0.255   
  permit ip 192.168.1.0 0.0.0.255  172.17.17.0 0.0.0.3   
  permit ip 10.10.20.0 0.0.0.255  172.17.17.0 0.0.0.3   
  permit ip 10.10.21.0 0.0.0.255  172.17.17.0 0.0.0.3   
!
ip access-list extended sip_trunk
  permit udp host 10.1.1.2  host 10.1.1.1 eq 5060  
  permit udp host 10.1.1.1  host 10.1.1.2 eq 5060  
  permit udp host 172.17.17.2  host 172.17.17.1 eq 5060  
  permit udp host 172.17.17.1  host 172.17.17.2 eq 5060  
!
ip access-list extended smtp-test
  permit tcp any  any eq smtp 
  permit tcp any eq smtp any  
!
!
!
!
ip policy-class Private
  allow list self self
  allow list allowed_networks
  allow list admin
  allow list sip_trunk
!
!
!
ip route 0.0.0.0 0.0.0.0 192.168.1.2
ip route 10.10.21.0 255.255.255.0 172.17.17.2
ip route 192.168.2.0 255.255.255.0 172.17.17.2
!
tftp server
tftp server overwrite
http server
http secure-server
no snmp agent
ip ftp server
ip ftp server default-filesystem cflash
no ip scp server
ip sntp server
ip sntp server send-unsynced
!
!


markfreeman
Valued Contributor II
Valued Contributor II

Re: Adtran 7100 with Polycom IP 650

Jump to solution

1. What was our response when you checked this:

FTP into the 7100 and look at the MAC-direcotry.xml and verify that it has the same directory as the ip phone globals directory,

If that matches, then the phone should be downloading that. Run debug ip ftp-server on 7100 and verify that the phone is grabbing that config.

2. Run the following debug on the 7100

Debug ip ftp-server

3. Reboot phone

Enter out put.

-Mark

markfreeman
Valued Contributor II
Valued Contributor II

Re: Adtran 7100 with Polycom IP 650

Jump to solution

Other question is what do you have option 66 set to in the customer’s Windows DHCP server.

-Mark

touristsis
Contributor III
Contributor III

Re: Adtran 7100 with Polycom IP 650

Jump to solution

Matt,

That was it! Thank You! I had to change option 66 in the server from VLAN 2 ip of phone system to VLAN 1 ip of phone system so the phone can talk to the phone system on phase 1 of dhcp and full the files, before it boot to VLAN 2.

View solution in original post

0 Kudos
markfreeman
Valued Contributor II
Valued Contributor II

Re: Adtran 7100 with Polycom IP 650

Jump to solution

Glad you got it working.

We actually cover how to do your very application in our ATSP/UCAS certification class.

Have a great weekend.

-Mark

Sent from my mobile phone